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1. Manipulating Charts 

 

Charting or graphing of data makes it easier to understand a trend about presentation of data. Many 

of us need to create such graphs, charts or visual chars like pi-chart etc at times. It often 

complicated to understand and create charts with conventional tools or software. Not anymore, with 

powerful features of Microsoft Excel, charting and graphing has been extremely simplified. 

You can create a chart on its own sheet or as an embedded object on a worksheet. You can also 

publish a chart on a Web page. To create a chart, you must first enter the data for the chart on the 

worksheet. Then create a basic chart that you can format later. 

 

1.1 How to Draw Charts? 

First of all make sure that there is some data in your excel sheet and does not contain any blank 

cells between the different columns, then click the Insert menu and choose the chart type that you 

wish to draw.  

 

Then select the chart in the Insert Chart dialog to create the chart 
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Besides, the snappiest way to create a chart is to select some data and press [F11]. 

 

 

The data in your Excel sheet will be organized as a chart. You can change the attributes by 

right-click the chart and adjust the options for changing chart types, data, and other formatting. 

 

1.1.1 Chart Plot Area 

The area that is covered by a specific chart is called the chart plot area. By default Excel draws 

charts according to the default configuration, but it’s very easy to edit the plot area, simply 

right-click the chart and choose the Format Plot Area option. Now you will see a dialogue box 

which lets you set the chart’s fill style, borders, Glow and soft Edges, and 3-D effects. 
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1.1.2 Chart Tools 

Chart Tools menu allows you to modify Design, layout and formatting of the chart and the table. 

You can tweak many options related to the charts like layouts, formatting, design, chart type, 

displaying data, legends, color scheme etc. 

 

In the Design option in charting area, you can select other options line graph, pie chart for different 

kind of representation of the data.  
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2. Enhancing Chart Appearance 

2.1 Working with Titles 

2.1.1 Formatting a Title 

To change the font, color, border, background, or alignment of a title, you can right-click it and 

choose Format Chart Title to access the Format Chart Title dialog box, 

The idea of a diagonal chart title might seem silly at first. However, you can drag the title onto the 

plot area if you want. A slanted title on the plot area can make a stylish chart annotation.  

 

 

2.1.2 Formatting Individual Characters in a Title 

By formatting title characters individually, you can make your titles look like ransom notes. One 

possible use for individual-character formatting is the characters in the word up have been elevated 

via the superscript option.  

To change the appearance of one or more characters in a title, select the title, pause, and then select 

the characters you want to change. The dialog box that appears has only a Font tab. In other words, 

you can’t change the background characteristics of selected characters. 
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2.2 Working with Gridlines 

Excel automatically adds gridlines, but you can delete them if you decide they're not essential, and 

reduce clutter in the process. Select Format Gridlines after right click the chart. 

 

 

2.3 Working with Data Labels 

If you delete gridlines, but feel a little insecure without them, you can show your audience the exact 

number of value by the data labels above each column. To add data labels, you could first add the 

data label and then format it. 
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2.4 Change Colors and Use Fill Effects 

Excel formats the plot area a standard gray color. But you can choose another color, use no color at 

all, or go wild and use pink or purple for the plot area if that's right for your chart. But your chart 

will have a professional look even if you use plain white when you use fill effects.  

To use a gradient fill, you'd select the plot area, right-click, select the Format Plot Area and 

Format Data Series on the shortcut menu, select Fill, and then select a color.  

A gradient fill was also used for each data series to give the colors some shading and depth. The 

darkest color represents Peacock, whose sales in February were the highest for the quarter, to draw 

attention to her achievement. The gradient fills define each column well enough that borders around 

each column weren't necessary, and could be deleted. 

In general, avoid putting two dark colors next to each other. The contrast between light and dark 

adds extra emphasis to your data and makes it easier to see the differences between the different 

data series. Greater contrast between colors will also help anyone in your audience who may be 

color blind to read your charts. 
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3. Working with Chart Data 

3.1 Adding Data 

Excel provides several ways to add data to a chart. Excel drew two rectangles around the chart’s 

source data after the plot area is selected. The first rectangle outlines the worksheet range that the 

chart is using for its category-axis labels. The second rectangle outlines the data series. Excel uses 

blue for the first rectangle and purple for the second, to help you distinguish the two. 

 

3.1.1 Using Copy and Paste 

You can use standard copy-and-paste procedures if your chart and its data are close together on the 

same worksheet. Select the new data, and then choose Copy. Next, select the chart, and choose 

Paste.  

To extend the chart so that it includes the new data, drag the Fill handle in the lower right corner of 

either rectangle. Alternatively, you can use drag-and-drop by selecting the new data, including its 

category-axis labels. Position your mouse on the border of the selection so that the mouse pointer 

changes to an arrow. Then drag the selection and drop it anywhere on the chart. Excel confirms the 

addition by extending the rectangles to include the new data. 
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3.1.2 Adding Series 

Adding a new series is like adding new points to existing series: Select the data series you want to 

add, copy it, and then paste it onto the chart. If the new data series is adjacent to the existing data, 

Excel has no difficulty figuring out that you want to add a new series rather than some new points.  

 

 

3.2 Removing Data 

The simplest way to remove a data series from a chart is to select the series on the chart itself and 

press [Delete]. This method works even if you’ve refined the selection to a single point in the series; 

delete that point and the whole series is gone. If you try to delete the series by clearing or deleting 

the source data on the worksheet, your chart will still reference the empty or nonexistent cells. 

To delete points from either end of all the series in a chart, select the chart area or the plot area, and 

then drag the Fill handle at one of the corners of either the purple or blue bounding rectangle that 

surrounds your data. To remove points from a particular series, select that series, and then drag the 

blue Fill handle. 

 

3.3 Changing or Replacing Data 

If you drag the lower or upper perimeter of a data-bounding rectangle, rather than its Fill handle, 

Excel moves both the start and endpoint of your series. This can be an effective way to obtain 

detailed views of a chart’s data across the whole range of available data. To switch to an entirely 

different set of data, select any part of your chart, and then choose Source Data. You can adjust the 

entire chart at once (all series) by using the Data Range box on the Data Range tab, or you can 

work with individual series on the Series tab. 
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3.4 Changing the Plot Order 

To change the order in which series are plotted, select any series and choose Selected Data Source. 

Use the Move Up and Move Down buttons to manipulate the series order. 

 

 

3.5 Adding Trend Lines 

A trend line is a line that describes the general tendency of a data series. To add a trend line to a 

series in an area, bar, column, line, or xy (scatter) chart, first select the series, and then choose Add 

Trendline. If you select Polynomial, indicate the highest power for the independent variable in the 

adjacent Order box. If you select Moving Average, indicate the number of periods should use in its 

calculations in the adjacent Period box. After you’ve indicated the type of trend or regression line, 

select the Options tab if you want a name for the trend line to appear in the chart legend. For linear, 

polynomial, and exponential trend lines, you can also set the y-intercept in the Set Intercept box. 

You can also display the regression equation and the R-squared value beside the trend line plot. 
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3.6 Error Bars 

Error bars express potential error amounts that are graphically relative to each data point or data 

marker in a data series. For example, you could show 5 percent positive and negative potential error 

amounts in the results of a scientific experiment: 

 

You can add error bars to data series in a 2-D area, bar, column, line, xy (scatter), and bubble charts. 

For xy (scatter) and bubble charts, you can display error bars for the x values, the y values, or both. 

 

3.6.1 Add Error Bars 

1. Selected data point or data series, click the data point or data series that you want, or do the 

following to select it from a list of chart elements: 

2. On the Layout tab, in the Analysis group, click Error Bars. Click a predefined error bar 

option, such as Error Bars with Standard Error, Error Bars with Percentage, or Error 

Bars with Standard Deviation. 

 

3. Besides, you can click More Error Bar Options, and then under Vertical Error Bars or 

Horizontal Error Bars, click the display and error amount options that you want to use. 
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3.6.2 Change Error Bar Settings 

1. On a chart sheet or in an embedded chart, click the error bar or data series that has the error 

bars that you want to change. When you select an error bar, any changes that you make affect 

all of the error bars in its associated data series. 

2. On the Format menu, click Selected Data Series.  

3. Click the Y Error Bars tab or the X Error Bars tab, depending on the type of error bars that you 

want to change, and then do one or more of the following:  

 To select a different type of error bar, click the type that you want under Display.  

 To change the method used to determine the error, select the method that you want under 

Error amount.  

 To change a custom error amount, click Custom. In the Plus and Minus boxes, specify the 

worksheet range to use as error amount values, or enter the values that you want to use, 

separated by commas, for example, 0.4, 0.3, 0.8.  

 

 

3.6.3 Remove Error Bars 

On a chart sheet or in an embedded chart, click any error bar to remove all error bars in a data series, 

and then press [Delete]. Or you can right-click an error bar, and then click Clear. 

You can also remove error bars immediately after you add them to the chart by clicking Undo on 

the Edit menu, or by pressing [Ctrl] + [Z]. 
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4. Advanced Charting Techniques 

4.1 Choose the Right Chart Type 

Selecting the most effective chart type will make your data clearer, stronger, and more informative. 

Excel offers a wide variety of chart types and simple methods for selecting and previewing them.  

The best chart type is the one that gets your message across most effectively. This may be rich or 

simple, lines or points or parts of a circle, even a combination of several types. The more types 

you've seen and tried, the better you'll be able to choose the right one for your purpose. 

 

4.1.1 A Column Chart Compares Values Directly 

Imagine that you have a worksheet showing how many cases of Teatime Chocolate Biscuits were 

sold by each of three salespeople in each of three months. Now suppose that you want to create a 

chart that compares the salespeople, month by month. 

A Column chart is a good type for comparing values directly, and you want to compare how many 

cases each salesperson sold, so it's a good fit. When choosing a chart type, it's often wise to keep it 

simple, so that your message comes across clearly 

 

 

4.1.2 A Stacked Column Chart Compares Parts of Several Totals 

What if you want to compare contributions to total sales, instead of just case numbers? You can 

place a different emphasis on the same data by creating a different kind of chart, the Stacked 

Column. 

A Stacked Column chart compares the contributions to a total of different values, showing either 

units or percentages. The chart shown here is a 100% Stacked Column chart that shows 

contributions as percentages. 

Instead of comparing how much each person sold each month, this chart emphasizes the relative 

contribution made by each salesperson to each month's total. 
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4.1.3 A Pie Chart Compares Parts of One Total 

What if you want just the big picture? You could create a Pie chart. A Pie chart is designed to show 

comparisons within a single set of values, and to show how parts contribute to a whole. It's an ideal 

chart type to display each month's contribution to a quarterly sales total. 

In the chart shown here, you can see that February accounts for almost 50% of the sales in the first 

quarter. That message wasn't so strong in the Column charts. Pie charts are available in various 

sub-types, such as 3-D, which is visually attractive but can be difficult to understand if it has many 

sections. Again, choose the form of chart that makes your point most effectively. 

 

4.1.4 A Line Chart Compares Values over Time 

A type of chart well suited to showing changes and trends over time is the Line chart. You could 

make comparisons of salesperson performance dramatically visible by showing monthly numbers 

this way. 

Line charts and XY (Scatter) charts look very similar in the Chart type list. In fact they are quite 

different, as you can see in the two charts shown here. It's important to choose the one that will 

work for you. Here are some guidelines to help you choose. 
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 Line charts are good for displaying trends over time in such business numbers as sales, 

revenues, and profits. Use a Line chart if you want dates on the bottom of the chart, to make 

historical developments visible at a glance. Line charts usually have only one set of numbers, 

shown on the vertical axis.  

 An XY Scatter chart compares two sets of numbers at once, one on the horizontal X axis, one 

on the vertical Y axis. The data values are scattered across the chart. You have the option of 

connecting the values with lines, but those lines don't show trends over time. XY Scatter charts 

are good for showing comparisons of numbers such as scientific or statistical data, where 

several measurements need to be plotted on a single chart. If you wanted to show how many 

cases of flu occurred in various age groups, or the average incomes in cities of various sizes, 

an XY Scatter chart would be an effective type. 

 

 

4.2 Combination Charts     

A combination chart uses two or more chart types to emphasize that the chart contains different 

kinds of information. The chart in the example shows one data series (Projected) as a column chart 

type and the other (Actual) as a line. To create this kind of overlay effect:  

1. Create the first chart  

2. Select the data source, copy and paste it into the graph to create the secondary chart 

3. Select Chart ➔ Chart Type and select the secondary chart 

 

 


