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 Data Transformation 

1.1 Data Types 

In Power BI Desktop, you can determine and specify a column’s data type in the Query Editor, or in 

Data View or Report View. The Data Type drop down in Query Editor has two data types not 

currently present in Data or Report View: Date/Time/Timezone and Duration. When a column with 

these data types are loaded into the model and viewed in Data or Report view, a column with a 

Date/Time/Timezone data type will be converted into a Date/Time, and a column with a Duration 

data type is converted into a Decimal Number. 

Data Types in Query Editor Data Types in Data View or Report View 

 

 

1.1.1 Number Types 

Power BI Desktop supports three number types:  

1.1.1.1 Decimal Number  

Represents a 64 bit (eight-byte) floating point number. It is the most common number type and 

corresponds to numbers as you usually think of them. Although designed to handle numbers with 

fractional values, it also handles whole numbers. The Decimal Number type can handle negative 

values from -1.79E +308 through -2.23E -308, 0, and positive values from 2.23E -308 through 

1.79E + 308. For example, numbers like 34, 34.01, and 34.000367063 are valid decimal numbers. 

The largest value that can be represented in a Decimal Number type is 15 digits long. The decimal 

separator can occur anywhere in the number. The Decimal Number type corresponds to how Excel 

stores its numbers.  

1.1.1.2 Fixed Decimal Number  

Has a fixed location for the decimal separator. The decimal separator always has four digits to its 

right and allows for 19 digits of significance. The largest value it can represent is 

922,337,203,685,477.5807 (positive or negative). The Fixed Decimal Number type is useful in 
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cases where rounding might introduce errors. When you work with many numbers that have small 

fractional values they can sometimes accumulate and force a number to be just slightly off. Since 

the values past the four digits to the right of decimal separator are truncated, the Fixed Decimal type 

can help you avoid these kinds of errors.  

1.1.1.3 Whole Number  

Represents a 64-bit integer value. Because it’s an integer, it has no digits to the right of the decimal 

place. It allows for 19 digits; positive or negative whole numbers between 

-9,223,372,036,854,775,808 (-2^63) and 9,223,372,036,854,775,807 (2^63-1). It can represent the 

largest possible number of the various numeric data types. As with the Fixed Decimal type, the 

Whole Number type can be useful in cases where you need to control rounding. 1  

1.1.2 Date/Time types 

Power BI Desktop supports five Date/Time data types in Query View and three in the Report View 

and model. Both Date/Time/Timezone and Duration are converted during load into the model.  

1.1.2.1 Date/Time  

Represents both a date and time value. Underneath the covers, the Date/Time value is stored as a 

Decimal Number Type. So, you can actually convert between the two. The time portion of a date is 

stored as a fraction to whole multiples of 1/300 seconds (3.33ms). Dates between years 1900 and 

9999 are supported.  

1.1.2.2 Date  

Represents just a Date (no time portion). When converted into the model, a Date is the same as a 

Date/Time value with zero for the fractional value.  

1.1.2.3 Time  

Represents just Time (no Date portion). When converted into the model, a Time value is the same as 

a Date/Time value with no digits to the left of the decimal place.  

1.1.2.4 Date/Time/Timezone  

Represents a UTC Date/Time. Currently, it’s converted into Date/Time when loaded into the model.  

1.1.2.5 Duration  

Represents a length of time. It’s converted into a Decimal Number Type when loaded into the model. 

It can be added or subtracted from a Date/Time field with correct results. and you can easily use it 

in visualizations that show magnitude.  

1.1.3 Text Type 

1.1.3.1 Text  

A Unicode character data string. Can be strings, numbers or dates represented in a text format. 

Maximum string length is 268,435,456 Unicode characters or 536,870,912 bytes.  

1.1.4 True/False Type 

1.1.4.1 True/False  

A Boolean value of either a True or False.  
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1.1.5 Blanks/Nulls Type 

1.1.5.1 Blank  

Replaces SQL nulls. You can create a blank by using the BLANK function, and test for blanks by 

using the ISBLANK logical function.  

1.1.6 Table Data Type 

DAX uses a table data type in many functions, such as aggregations and time intelligence 

calculations. Some functions require a reference to a table; other functions return a table that can 

then be used as input to other functions. In some functions that require a table as input, you can 

specify an expression that evaluates to a table; for some functions, a reference to a base table is 

required.  

1.2 Query Editor Overview 

To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop. 

 

Once a query is loaded, Query Editor view becomes more interesting. If we connect to the 

following Web data source, Query Editor loads information about the data, which you can then 

begin to shape. 

1. In the ribbon, many buttons are now active to interact with the data in the query 

2. In the left pane, queries are listed and available for selection, viewing, and shaping 

3. In the center pane, data from the selected query is displayed and available for shaping 

4. The Query Settings window appears, listing the query’s properties and applied steps  
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1.2.1 The Query Ribbon 

The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.  

The Home tab contains the common query tasks such as first step in any query – Get Data.  

 

The Transform tab provides access to common data transformation tasks, such as adding or 

removing columns, changing data types, splitting columns, and other data-driven tasks.  

 

The Add Column tab provides additional tasks associated with adding a column, formatting 

column data, and adding custom columns.  

 

The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. It’s 

also used to display the Advanced Editor.  

 

1.2.2 The Left Pane 

The left pane displays the number of active queries, as well as the name of the query. When you 

select a query from the left pane, its data is displayed in the center pane, where you can shape and 

transform the data to meet your needs.  
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1.2.3 The Data Pane 

In the Data pane, date from the selected query is displayed. This is where much of the work of the 

Query view is accomplished. When you select a right-click menu item, Query applies the step to the 

data, and saves it as part of the query itself. The steps are recorded in the Query Settings. 

 

1.2.4 The Query Settings Pane 

The Query Settings pane is where all steps associated with a query are displayed. As additional 

shaping steps are applied to the query, they are captured in the Applied Steps section. In the Query 

Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. To do so, 

right-click the step in the Applied Steps section, and choose from the menu that appears. All query 

steps are carried out in the order they appear in the Applied Steps pane.  
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1.2.5 The Advanced Editor 

If you want to see the code that Query Editor is creating with each step, or want to create your own 

shaping code, you can use the Advanced Editor. To launch the advanced editor, select View from 

the ribbon, then select Advanced Editor. A window appears, showing the existing query code. 

 

1.3 Shape and Combine Data 

Shaping data means transforming the data – such as renaming columns or tables, changing text to 

numbers, removing rows, setting the first row as headers, and so on. Combining data means 

connecting to two or more data sources, shaping them as needed, then consolidating them into one 

useful query.  

1.3.1 Shape Data 

When you shape data in the Query Editor, you’re providing step-by-step instructions to adjust the 

data as Query Editor loads and presents it. The original data source is not affected; only this 

particular view of the data is adjusted, or shaped.  

The steps you specify are recorded by Query Editor, and each time this query connects to the data 

source those steps are carried out so that the data is always shaped the way you specify. This 

process occurs whenever you use the Query Editor feature of Power BI Desktop. Those steps are 

captured, sequentially, in the Query Settings pane under Applied Steps.  
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For starters, one column's scores were not automatically transformed from text to numbers when 

Query Editor loaded the table, and we need them to be numbers. No problem – just right-click the 

column header, and select Change Type > Whole Number to change them. To choose more than one 

column, first select a column then hold down SHIFT, select additional adjacent columns, and then 

right-click a column header to change all selected columns. You can also use the CTRL key to 

choose non-adjacent columns.  

 

  

 

You can also transform those columns from text to header from the Transform ribbon. Here’s the 

Transform ribbon, with an arrow pointing toward the Data Type button, which lets you transform 

the current data type to another.  

 

  

 

Note that in Query Settings, the Applied Steps reflect any shaping steps applied to the data. If I want 

to remove any step from the shaping process, I simply select the X to the left of the step. In the 

following image, Applied Steps reflects the steps so far: connecting to the website (Source); 

selecting the table (Navigation); and while loading the table, Query Editor automatically changed 

text-based number columns from Text to Whole Number (Changed Type). One column of rankings 

was not automatically changed to a number-based type, and we'll find out why in the next few 

paragraphs.  

 

  

 

Before we can work with this query, we need to make a few changes to get its data where we want 

it:  

•Remove the first column – we don’t need it, it just includes redundant rows that say “Check out 

how your state ranks for retirement” which is an artifact of this data source being a Web-based table 

•Fix a few Errors – one of the columns, Health care quality, contains a few ties in states' rankings, 

which was noted on the website by having the text (tie) after their numbers. That works well on the 

website, but it requires that we transform the column from text to data manually. It's easy to fix this 

using Power BI Desktop, and doing so demonstrates a cool feature of Applied Steps in Query 

•Change the Table Name – that Table 0 is not a useful descriptor, but changing it simple 

  

To remove the first column, simply select the column and choose the Home tab from the ribbon, 

then Remove Columns as shown in the following figure.  
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Next we need to address the text column, and transform it into numbers. At first it seems 

straightforward, that we can just change the type of the Health care quality column from text to 

number (such as Whole Number, or Decimal Number). But when we change the type from Text to 

Whole Number, then look through the values in that column, we find that Query Editor reports a 

few errors.  

 

  

 

There are a few ways to get more information about each error. You can select the cell (without 

clicking on the word Error), or click the word Error directly. If you select the cell without clicking 

directly on the word Error, Query Editor displays the error information on the bottom of the 

window.  

 

  

 

If you click the word Error directly, Query creates an Applied Step in the Query Settings pane and 

displays information about the error.  

 

  

 

To get back to the Query Editor, you have to remove that step by selecting the X next to it.  

 

When we select the most recent Applied Step, we see the error just described, as shown in the 

following image.  

 

  

 

Since Query Editor records steps sequentially, we can select the step prior to changing the type, in 

Applied Steps, and see what the value of that cell is prior to the transformation, as shown in the 

following image.  

 

  

 

Okay, now we can fix those values, and then change the type. Since Query Editor records the steps 

sequentially, yet independently of each other, you can move each Applied Step up or down in the 

sequence. Just right-click any step, and Query Editor provides a menu that lets you do the following: 

Rename, Delete, Delete Until End (remove the current step, and all subsequent steps too), Move Up, 

or Move Down.  
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In addition, you can select an Applied Step anywhere in the list, and continue shaping the data at 

that point in the sequence. Query Editor will automatically insert a new step directly after the 

currently selected Applied Step. Let's give that a try.  

 

First, we select the Applied Step prior to changing the type of the Health care quality column. Then 

we replace the values that have the text "(tie)" in the cell so that only the number remains. 

Right-click the cell that contains "35 (tie)" and select Replace Values... from the menu that appears. 

Note which Applied Step is currently selected (the step prior to changing the type).  

 

  

 

Since we're inserting a step, Query Editor warns us about the danger of doing so - subsequent steps 

could cause the query to break. We need to be careful, and thoughtful! Since this is a tutorial, and 

we're highlighting a really cool feature of Query Editor to demonstrate how you can create, delete, 

insert, and reorder steps, we'll push ahead and select Insert.  

 

  

 

There are three ties, so we replace the values for each. When you create a new Applied Step, Query 

Editor names it based on the action - in this case, Replaced Value. When you have more than one 

step with the same name in your query, Query Editor adds a number (in sequence) to each 

subsequent Applied Step to differentiate between them.  

 

The following screen shows the three Replaced Value steps in Query Settings, but it also shows 

something else that's even more interesting: since we removed each instance of the text "(tie)" from 

the Health care quality column, the Changed Type step now completes with no errors.  

 

  

 

 

Note  

 

You can also Remove Errors (using the ribbon or the right-click menu), which removes any rows 

that have errors. In this case it would’ve removed all the states that had "(tie)" from our data, and 

we didn’t want to do that – we like all the states, and want to keep them in the table.  

 

Okay that was a little involved, but it was a good example of how powerful and versatile Query 

Editor can be.  
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Lastly, we want to change the name of that table to something descriptive. When we get to creating 

reports, it’s especially useful to have descriptive table names, especially when we connect to 

multiple data sources, and they’re all listed in the Fields pane of the Report view.  

 

Changing the table name is easy: in the Query Settings pane, under Properties, simply type in the 

new name of the table, as shown in the following image, and hit Enter. Let’s call this table 

RetirementStats.  

 

  

 

Okay, we’ve shaped that data to the extent we need to. Next let’s connect to another data source, 

and combine data.  

 

Combine data  

 

That data about various states is interesting, and will be useful for building additional analysis 

efforts and queries. But there’s one problem: most data out there uses a two-letter abbreviation for 

state codes, not the full name of the state. We need some way to associate state names with their 

abbreviations.  

 

We’re in luck: there’s another public data source that does just that, but it needs a fair amount of 

shaping before we can connect it to our retirement table. Here’s the Web resource for state 

abbreviations:  

 

http://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations  

 

From the Home ribbon in Query Editor, we select New Source > Web and type the address, select 

OK, and the Navigator shows what it found on that Web page.  

 

  

 

We select Table[edit] because that includes the data we want, but it’s going to take quite a bit of 

shaping to pare that table’s data down to what we want.  

 

 

Tip  

 

Is there a faster or easier way to accomplish the steps below? Yes, we could create a relationship 

between the two tables, and shape the data based on that relationship. The following steps are still 
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good to learn for working with tables, just know that relationships can help you quickly use data 

from multiple tables.  

 

To get this data into shape, we take the following steps:  

•Remove the top two rows – they’re a result of the way that Web page’s table was created, and we 

don’t need them. From the Home ribbon, select Reduce Rows > Remove Rows > Remove Top 

Rows. 

  

  

 

The Remove Top Rows window appears, letting you specify how many rows you want to remove.  

•Remove the bottom 26 rows – they’re all the territories, which we don’t need to include. From the 

Home ribbon, select Reduce Rows > Remove Rows > Remove Bottom Rows. 

  

  

•Since the RetirementStats table doesn't have information for Washington DC, we need to filter it 

from our list. Select the drop-down arrow beside the Region Status column, then clear the checkbox 

beside Federal district. 

  

  

•Remove a few unneeded columns – we only need the mapping of state to its official two-letter 

abbreviation, so we can remove the following columns: Column2, Column3, and then Column5 

through Column10. First select Column2, then hold down the CTRL key and select the other 

columns to be removed (this lets you select multiple, non-contiguous columns). From the Home tab 

on the ribbon, select Remove Columns > Remove Columns. 

  

  

•Use the first row as headers – since we removed the top three rows, the current top row is the 

header we want. You can select Use First Row As Headers from the Home tab, or from the 

Transform tab in the ribbon. 

  

  

 

 

Note  

 

This is a good time to point out that the sequence of applied steps in Query Editor is important, and 

can affect how the data is shaped. It’s also important to consider how one step may impact another 

subsequent step; if you remove a step from the Applied Steps, subsequent steps may not behave as 

originally intended, because of the impact of the query’s sequence of steps.  
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Note  

 

When you resize the Query Editor window to make the width smaller, some ribbon items are 

condensed to make the best use of visible space. When you increase the width of the Query Editor 

window, the ribbon items expand to make the most use of the increased ribbon area.  

•Rename the columns, and the table itself – as usual, there are a few ways to rename a column; first 

select the column, then either select Rename from the Transform tab on the ribbon, or right-click 

and select Rename… from the menu that appears. The following image has arrows pointing to both 

options; you only need to choose one. 

  

  

 

Let’s rename them to State Name and State Code. To rename the table, just type the name into the 

Name box in the Query Settings pane. Let’s call this table StateCodes.  

 

Now that we’ve shaped the StateCodes table the way we want, let’s combine these two tables, or 

queries, into one; since the tables we now have are a result of the queries we applied to the data, 

they’re often referred to as queries.  

 

There are two primary ways of combining queries – merging and appending.  

 

When you have one or more columns that you’d like to add to another query, you merge the queries. 

When you have additional rows of data that you’d like to add to an existing query, you append the 

query.  

 

In this case we want to merge queries. To get started, from the left pane of Query Editor we select 

the query into which we want the other query to merge, which in this case is RetirementStats. Then 

select Combine > Merge Queries from the Home tab on the ribbon.  

 

  

 

You may be prompted to set the privacy levels, to ensure the data is combined without including or 

transferring data you didn't want transferred.  

 

  

 

Next the Merge window appears, prompting us to select which table we’d like merged into the 

selected table, and then, the matching columns to use for the merge. Select State from the 
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RetirementStats table (query), then select the StateCodes query (easy in this case, since there’s only 

one other query – when you connect to many data sources, there are many queries to choose from). 

When we select the correct matching columns – State from RetirementStats, and State Name from 

StateCodes – the Merge window looks like the following, and the OK button is enabled.  

 

  

 

A NewColumn is created at the end of the query, which is the contents of the table (query) that was 

merged with the existing query. All columns from the merged query are condensed into the 

NewColumn, but you can select to Expand the table, and include whichever columns you want.  

 

  

 

To Expand the merged table, and select which columns to include, select the expand icon (Expand). 

The Expand window appears.  

 

  

 

In this case, we only want the State Code column, so we select only that column and then select OK. 

We clear the checkbox from Use original column name as prefix because we don’t need or want that; 

if we leave that selected, the merged column would be named NewColumn.State Code (the original 

column name, or NewColumn, then a dot, then the name of the column being brought into the 

query).  

 

 

Note  

 

Want to play around with how to bring in that NewColumn table? You can experiment a bit, and if 

you don’t like the results, just delete that step from the Applied Steps list in the Query Settings pane; 

your query returns to the state prior to applying that Expand step. It’s like a free do-over, which you 

can do as many times as you like until the expand process looks the way you want it.  

 

We now have a single query (table) that combined two data sources, each of which has been shaped 

to meet our needs. This query can serve as a basis for lots of additional, interesting data connections 

– such as housing cost statistics, demographics, or job opportunities in any state.  

 

To apply changes and close Query Editor, select Close & Apply from the Home ribbon tab. The 

transformed dataset appears in Power BI Desktop, ready to be used for creating reports.  
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https://docs.microsoft.com/en-us/power-bi/desktop-shape-and-combine-data 

 

1.4 Common Query Tasks 

https://docs.microsoft.com/en-us/power-bi/desktop-common-query-tasks 

 

  

https://docs.microsoft.com/en-us/power-bi/desktop-shape-and-combine-data
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1.5 Combine Binaries 

Power BI Desktop now handles the combine binaries more effectively. You start by selecting 

combine binaries, either from the Home ribbon tab in Query Editor, or from the column itself.  

 

The combine binaries transform now behaves as follows:  

1. The combine binaries transform analyzes each input file, and determines the correct file format 

to use, such as text or Excel workbook or JSON file. 

2. The transform allows you to select a specific object from the first file, for example, an Excel 

workbook, to extract. 

3. The combine binaries then automatically does the following: 

• Creates an example query that performs all the required extraction steps in a single file. 

• Creates a function query that parameterizes the file/binary input to the exemplar query. The 

exemplar query and the function query are linked, so that changes to the exemplar query are 

reflected in the function query. 

• Applies the function query to the original query with input so it applies the function query 

for binary inputs on each row, then expands the resulting data extraction as top-level 

columns. 
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 Data Modeling  

2.1 Data View  

Data View helps you inspect, explore, and understand data in your Power BI Desktop model. It's 

different from how you view tables, columns, and data in Query Editor. With Data View, you’re 

looking at your data after it has been loaded into the model.  

When you’re modeling your data, sometimes you want to see what’s actually in a table or column 

without creating a visual on the report canvas, often right down to the row level. This is especially 

true when you’re creating measures and calculated columns, or you need to identify a data type or 

data category. 

 

Label Name Description 

1 Data View icon  Click to enter Data View. 

2 Data Grid  Shows the selected table and all columns and rows in it. Columns 

hidden from Report View are greyed out. You can right-click on a 

column for options.  

3 Modeling ribbon  Manage relationships, create calculations, change data type, format, 

data category for a column.  

4 Formula bar  Enter DAX formulas for Measures and Calculated columns.  

5 Search  Search for a table or column in your model.  

6 Fields list  Select a table or column to view in the data grid. 
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2.2 Relationship View in Power BI Desktop 

Relationship View shows all of the tables, columns, and relationships in your model. This can be 

especially helpful when your model has complex relationships between many tables. 

A. Relationship View icon – Click to show your model in Relationship View  

B. Relationship – You can hover your cursor over a relationship to show the columns used. 

Double-click on a relationship to open it in the Edit Relationship dialog box.   
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2.3 Create and Manage Relationships in Power BI Desktop 

When you import multiple tables, chances are you’re going to do some analysis using data from all 

those tables. Relationships between those tables are necessary in order to accurately calculate 

results and display the correct information in your reports. Power BI Desktop makes creating those 

relationships easy. In-fact, in most cases you won’t have to do anything, the Autodetect feature can 

do it for you. However, in some cases you might have to create relationships yourself, or you might 

need to make some changes to a relationship. Either way, it’s important to understand relationships 

in Power BI Desktop and how to create and edit them. 

2.3.1 Autodetect During Load 

If you query two or more tables at the same time, when the data is loaded, Power BI Desktop will 

attempt to find and create relationships for you. Cardinality, Cross filter direction, and Active 

properties are automatically set. Power BI Desktop looks at column names in the tables you are 

querying to determine if there are any potential relationships. If there are, those relationships are 

created automatically. If Power BI Desktop cannot determine with a high-level of confidence there 

is a match, it will not automatically create the relationship. You can still use the Manage 

Relationships dialog to create or edit relationships.  

2.3.2 Create a relationship by using Autodetect 

On the Home tab, click Manage Relationships > AutoDetect.  
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2.3.3 Create a relationship manually 

On the Home tab, click Manage Relationships > New. 

In the Create Relationship dialog, in the first table drop-down list, select a table, and then select the 

column you want to use in the relationship. 

In the to second table drop-down list, select the other table you want in the relationship, then select 

the other column you want to use, and then click OK. 

 

 

 

2.4 Data Analysis Expressions (DAX)  

2.4.1 What is DAX? 

DAX is a collection of functions, operators, and constants that can be used in a formula, or 

expression, to calculate and return one or more values. Stated more simply, DAX helps you create 
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new information from data already in your model.  

2.4.2 Why is DAX so important? 

It’s quite easy to create a new Power BI Desktop file and import some data into it. You can even 

create reports that show valuable insights without using any DAX formulas at all. But, what if you 

need to analyze growth percentage across product categories and for different date ranges? Or, you 

need calculate year-over-year growth compared to market trends? DAX formulas provide this 

capability and many other important capabilities as well. Learning how to create effective DAX 

formulas will help you get the most out of your data. When you get the information you need, you 

can begin to solve real business problems that affect your bottom line. This is the power in Power 

BI, and DAX will help you get there.  

2.4.3 Syntax 

Syntax includes the various elements that make up a formula, or more simply, how the formula is 

written.  

 

This formula includes the following syntax elements:  

A. The measure name Total Sales.  

B. The equals sign operator (=) indicates the beginning of the formula. When calculated, it will 

return a result.  

C. The DAX function SUM adds up all of the numbers in the Sales[SalesAmount] column.  

D. Parenthesis () surround an expression containing one or more arguments. All functions require 

at least one argument. An argument passes a value to a function.  

E. The referenced table Sales.  

F. The referenced column [SalesAmount] in the Sales table. With this argument, the SUM function 

knows on which column to aggregate a SUM.  

When trying to understand a DAX formula, it is often helpful to break down each of the elements 

into a language you think and speak every day. For example, you can read this formula as:  

For the measure named Total Sales, calculate (=) the SUM of values in the [SalesAmount ] column 

in the Sales table.  

When added to a report, this measure calculates and returns values by summing up sales amounts 

for each of the other fields we include, for example, Cell Phones in the USA.  

 

You might be thinking ‘Isn’t this measure doing the same thing as if I were to just add the 

SalesAmount field to my report?’ Well, yes. But, there’s a good reason to create our own measure 

that sums up values from the SalesAmount field: We can use it as an argument in other formulas. 
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This may seem a little confusing now, but as your DAX formula skills grow, knowing this will 

make your formulas and your model more efficient. In-fact, you’ll see the Total Sales measure 

showing up as an argument in other formulas later on.  

 

Let’s go over a few more things about this formula. In particular, we introduced a function, SUM. 

Functions are pre-written formulas that make it easier to do complex calculations and manipulations 

with numbers, dates, time, text, and more. You will learn more about functions later.  

 

You also see the column [SalesAmount] was preceded by the table Sales in which the column 

belongs. This is known as a fully qualified column name in that it includes the column name 

preceded by the table name. Columns referenced in the same table do not require the table name be 

included in the formula. This can make long formulas that reference many columns shorter and 

easier to read. However, it's good practice to include the table name in your measure formulas, even 

when in the same table.  

 

 

Note  

 

If a table name contains spaces, reserved keywords, or disallowed characters, you’ll need to enclose 

the table name in single quotation marks. You’ll also need to enclose table names in quotation 

marks if the name contains any characters outside the ANSI alphanumeric character range, 

regardless of whether your locale supports the character set or not.  

 

It’s important your formulas have the correct syntax. In most cases, if the syntax is not correct, a 

syntax error will be returned. In other cases, the syntax may be correct, but the values returned 

might not be what you are expecting. The DAX editor in Power BI Desktop includes suggestions; a 

feature used to create syntactically correct formulas by helping you select the correct elements.  

 

Let’s create a simple formula. This task will help you further understand formula syntax and how 

the suggestions feature in the formula bar can help you. 

 

2.5 Data categorization in Power BI Desktop 

 

 

2.6 Tag barcodes in Power BI Desktop for the mobile apps 
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2.7 Set geographic filters in Power BI Desktop for the mobile apps 

 

 

2.8 Using calculated columns in Power BI Desktop 

 

 

 

 

2.9 Using calculated tables in Power BI Desktop 

 

2.10 Measures in Power BI Desktop 

 

 

 

 

2.11 Import and display KPIs in Power BI 

 

 

 

 

 


