Chapter 3

1. Manipulating Charts
Charting or graphing of data makes it easier to understand a trend about presentation of data. Many
of us need to create such graphs, charts or visual chars like pi-chart etc at times. It often
complicated to understand and create charts with conventional tools or software. Not anymore, with
powerful features of Microsoft Excel, charting and graphing has been extremely simplified.
You can create a chart on its own sheet or as an embedded object on a worksheet. You can also
publish a chart on a Web page. To create a chart, you must first enter the data for the chart on the
worksheet. Then create a basic chart that you can format later.

1.1 How to Draw Charts?
First of all make sure that there is some data in your excel sheet and does not contain any blank
cells between the different columns, then click the Insert menu and choose the chart type that you
wish to draw.

Then select the chart in the Insert Chart dialog to create the chart
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Besides, the snappiest way to create a chart is to select some data and press [F11].

The data in your Excel sheet will be organized as a chart. You can change the attributes by
right-click the chart and adjust the options for changing chart types, data, and other formatting.

1.1.1 Chart Plot Area
The area that is covered by a specific chart is called the chart plot area. By default Excel draws
charts according to the default configuration, but it’s very easy to edit the plot area, simply
right-click the chart and choose the Format Plot Area option. Now you will see a dialogue box
which lets you set the chart’s fill style, borders, Glow and soft Edges, and 3-D effects.
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1.1.2 Chart Tools
Chart Tools menu allows you to modify Design, layout and formatting of the chart and the table.
You can tweak many options related to the charts like layouts, formatting, design, chart type,
displaying data, legends, color scheme etc.

In the Design option in charting area, you can select other options line graph, pie chart for different
kind of representation of the data.
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2. Enhancing Chart Appearance
2.1 Working with Titles
2.1.1 Formatting a Title
To change the font, color, border, background, or alignment of a title, you can right-click it and
choose Format Chart Title to access the Format Chart Title dialog box,
The idea of a diagonal chart title might seem silly at first. However, you can drag the title onto the
plot area if you want. A slanted title on the plot area can make a stylish chart annotation.

2.1.2 Formatting Individual Characters in a Title
By formatting title characters individually, you can make your titles look like ransom notes. One
possible use for individual-character formatting is the characters in the word up have been elevated
via the superscript option.
To change the appearance of one or more characters in a title, select the title, pause, and then select
the characters you want to change. The dialog box that appears has only a Font tab. In other words,
you can’t change the background characteristics of selected characters.
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2.2 Working with Gridlines
Excel automatically adds gridlines, but you can delete them if you decide they're not essential, and
reduce clutter in the process. Select Format Gridlines after right click the chart.

2.3 Working with Data Labels
If you delete gridlines, but feel a little insecure without them, you can show your audience the exact
number of value by the data labels above each column. To add data labels, you could first add the
data label and then format it.
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2.4 Change Colors and Use Fill Effects
Excel formats the plot area a standard gray color. But you can choose another color, use no color at
all, or go wild and use pink or purple for the plot area if that's right for your chart. But your chart
will have a professional look even if you use plain white when you use fill effects.
To use a gradient fill, you'd select the plot area, right-click, select the Format Plot Area and
Format Data Series on the shortcut menu, select Fill, and then select a color.
A gradient fill was also used for each data series to give the colors some shading and depth. The
darkest color represents Peacock, whose sales in February were the highest for the quarter, to draw
attention to her achievement. The gradient fills define each column well enough that borders around
each column weren't necessary, and could be deleted.
In general, avoid putting two dark colors next to each other. The contrast between light and dark
adds extra emphasis to your data and makes it easier to see the differences between the different
data series. Greater contrast between colors will also help anyone in your audience who may be
color blind to read your charts.
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3. Working with Chart Data
3.1 Adding Data
Excel provides several ways to add data to a chart. Excel drew two rectangles around the chart’s
source data after the plot area is selected. The first rectangle outlines the worksheet range that the
chart is using for its category-axis labels. The second rectangle outlines the data series. Excel uses
blue for the first rectangle and purple for the second, to help you distinguish the two.

3.1.1 Using Copy and Paste
You can use standard copy-and-paste procedures if your chart and its data are close together on the
same worksheet. Select the new data, and then choose Copy. Next, select the chart, and choose
Paste.
To extend the chart so that it includes the new data, drag the Fill handle in the lower right corner of
either rectangle. Alternatively, you can use drag-and-drop by selecting the new data, including its
category-axis labels. Position your mouse on the border of the selection so that the mouse pointer
changes to an arrow. Then drag the selection and drop it anywhere on the chart. Excel confirms the
addition by extending the rectangles to include the new data.
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3.1.2 Adding Series
Adding a new series is like adding new points to existing series: Select the data series you want to
add, copy it, and then paste it onto the chart. If the new data series is adjacent to the existing data,
Excel has no difficulty figuring out that you want to add a new series rather than some new points.

3.2 Removing Data
The simplest way to remove a data series from a chart is to select the series on the chart itself and
press [Delete]. This method works even if you’ve refined the selection to a single point in the series;
delete that point and the whole series is gone. If you try to delete the series by clearing or deleting
the source data on the worksheet, your chart will still reference the empty or nonexistent cells.
To delete points from either end of all the series in a chart, select the chart area or the plot area, and
then drag the Fill handle at one of the corners of either the purple or blue bounding rectangle that
surrounds your data. To remove points from a particular series, select that series, and then drag the
blue Fill handle.

3.3 Changing or Replacing Data
If you drag the lower or upper perimeter of a data-bounding rectangle, rather than its Fill handle,
Excel moves both the start and endpoint of your series. This can be an effective way to obtain
detailed views of a chart’s data across the whole range of available data. To switch to an entirely
different set of data, select any part of your chart, and then choose Source Data. You can adjust the
entire chart at once (all series) by using the Data Range box on the Data Range tab, or you can
work with individual series on the Series tab.
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3.4 Changing the Plot Order
To change the order in which series are plotted, select any series and choose Selected Data Source.
Use the Move Up and Move Down buttons to manipulate the series order.

3.5 Adding Trend Lines
A trend line is a line that describes the general tendency of a data series. To add a trend line to a
series in an area, bar, column, line, or xy (scatter) chart, first select the series, and then choose Add
Trendline. If you select Polynomial, indicate the highest power for the independent variable in the
adjacent Order box. If you select Moving Average, indicate the number of periods should use in its
calculations in the adjacent Period box. After you’ve indicated the type of trend or regression line,
select the Options tab if you want a name for the trend line to appear in the chart legend. For linear,
polynomial, and exponential trend lines, you can also set the y-intercept in the Set Intercept box.
You can also display the regression equation and the R-squared value beside the trend line plot.
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3.6 Error Bars
Error bars express potential error amounts that are graphically relative to each data point or data
marker in a data series. For example, you could show 5 percent positive and negative potential error
amounts in the results of a scientific experiment:

You can add error bars to data series in a 2-D area, bar, column, line, xy (scatter), and bubble charts.
For xy (scatter) and bubble charts, you can display error bars for the x values, the y values, or both.

3.6.1 Add Error Bars
1.

Selected data point or data series, click the data point or data series that you want, or do the
following to select it from a list of chart elements:

2.

On the Layout tab, in the Analysis group, click Error Bars. Click a predefined error bar
option, such as Error Bars with Standard Error, Error Bars with Percentage, or Error
Bars with Standard Deviation.

3.

Besides, you can click More Error Bar Options, and then under Vertical Error Bars or
Horizontal Error Bars, click the display and error amount options that you want to use.
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3.6.2 Change Error Bar Settings
1.

2.
3.

On a chart sheet or in an embedded chart, click the error bar or data series that has the error
bars that you want to change. When you select an error bar, any changes that you make affect
all of the error bars in its associated data series.
On the Format menu, click Selected Data Series.
Click the Y Error Bars tab or the X Error Bars tab, depending on the type of error bars that you
want to change, and then do one or more of the following:

To select a different type of error bar, click the type that you want under Display.

To change the method used to determine the error, select the method that you want under
Error amount.

To change a custom error amount, click Custom. In the Plus and Minus boxes, specify the
worksheet range to use as error amount values, or enter the values that you want to use,
separated by commas, for example, 0.4, 0.3, 0.8.

3.6.3 Remove Error Bars
On a chart sheet or in an embedded chart, click any error bar to remove all error bars in a data series,
and then press [Delete]. Or you can right-click an error bar, and then click Clear.
You can also remove error bars immediately after you add them to the chart by clicking Undo on
the Edit menu, or by pressing [Ctrl] + [Z].
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4. Advanced Charting Techniques
4.1 Choose the Right Chart Type
Selecting the most effective chart type will make your data clearer, stronger, and more informative.
Excel offers a wide variety of chart types and simple methods for selecting and previewing them.
The best chart type is the one that gets your message across most effectively. This may be rich or
simple, lines or points or parts of a circle, even a combination of several types. The more types
you've seen and tried, the better you'll be able to choose the right one for your purpose.

4.1.1 A Column Chart Compares Values Directly
Imagine that you have a worksheet showing how many cases of Teatime Chocolate Biscuits were
sold by each of three salespeople in each of three months. Now suppose that you want to create a
chart that compares the salespeople, month by month.
A Column chart is a good type for comparing values directly, and you want to compare how many
cases each salesperson sold, so it's a good fit. When choosing a chart type, it's often wise to keep it
simple, so that your message comes across clearly

4.1.2 A Stacked Column Chart Compares Parts of Several Totals
What if you want to compare contributions to total sales, instead of just case numbers? You can
place a different emphasis on the same data by creating a different kind of chart, the Stacked
Column.
A Stacked Column chart compares the contributions to a total of different values, showing either
units or percentages. The chart shown here is a 100% Stacked Column chart that shows
contributions as percentages.
Instead of comparing how much each person sold each month, this chart emphasizes the relative
contribution made by each salesperson to each month's total.
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4.1.3 A Pie Chart Compares Parts of One Total
What if you want just the big picture? You could create a Pie chart. A Pie chart is designed to show
comparisons within a single set of values, and to show how parts contribute to a whole. It's an ideal
chart type to display each month's contribution to a quarterly sales total.
In the chart shown here, you can see that February accounts for almost 50% of the sales in the first
quarter. That message wasn't so strong in the Column charts. Pie charts are available in various
sub-types, such as 3-D, which is visually attractive but can be difficult to understand if it has many
sections. Again, choose the form of chart that makes your point most effectively.

4.1.4 A Line Chart Compares Values over Time
A type of chart well suited to showing changes and trends over time is the Line chart. You could
make comparisons of salesperson performance dramatically visible by showing monthly numbers
this way.
Line charts and XY (Scatter) charts look very similar in the Chart type list. In fact they are quite
different, as you can see in the two charts shown here. It's important to choose the one that will
work for you. Here are some guidelines to help you choose.
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Line charts are good for displaying trends over time in such business numbers as sales,
revenues, and profits. Use a Line chart if you want dates on the bottom of the chart, to make
historical developments visible at a glance. Line charts usually have only one set of numbers,
shown on the vertical axis.
An XY Scatter chart compares two sets of numbers at once, one on the horizontal X axis, one
on the vertical Y axis. The data values are scattered across the chart. You have the option of
connecting the values with lines, but those lines don't show trends over time. XY Scatter charts
are good for showing comparisons of numbers such as scientific or statistical data, where
several measurements need to be plotted on a single chart. If you wanted to show how many
cases of flu occurred in various age groups, or the average incomes in cities of various sizes,
an XY Scatter chart would be an effective type.

4.2 Combination Charts
A combination chart uses two or more chart types to emphasize that the chart contains different
kinds of information. The chart in the example shows one data series (Projected) as a column chart
type and the other (Actual) as a line. To create this kind of overlay effect:
1. Create the first chart
2. Select the data source, copy and paste it into the graph to create the secondary chart
3. Select Chart ➔ Chart Type and select the secondary chart
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4.3 Area Chart
Area charts are much like line charts, but they display different colors in the areas below the lines.
This colorful and visual display distinguishes the data more clearly.

4.3.1 Stacked Area Chart
Data that is arranged in columns or rows on a worksheet can be plotted in an area chart. Area charts
emphasize the magnitude of change over time and can be used to draw attention to the total value
across a trend. For example, data that represents profit over time can be plotted in an area chart to
emphasize the total profit. A stacked area chart also shows the relationship of parts to a whole.

4.3.2 Create an Area Chart that uses Transparency
Unfortunately, data series with smaller values that are plotted in the back of an area chart may be
completely or partially hidden behind data series with larger values that are plotted in front of them.
However, you can use transparency to show the entire outline of smaller data series through any
larger data series in front since Microsoft Office 2007.
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1.
2.
3.
4.
5.
6.

Open the worksheet that contains the data that you want to plot in an area chart.
Select the data that you want to plot in the area chart.
On the Insert tab, in the Charts group, click Area.
Under 3-D Area, click 3-D Area.
Click the chart area of the chart. This displays the Chart Tools.
On the Design tab, in the Chart Styles group, click the chart style that you want to use.

7. In the chart, click the legend, and then press [Delete].
8. To change the size of the chart, on the Format tab, in the Size group, select the shape size that
you want in the Shape Height and Shape Width boxes, and then press [Enter].
9. Click the vertical axis, or select it from a list of chart elements.
10. On the Format tab, in the Current Selection group, click Format Selection.
11. Under Axis Options, in the Display Units box, click Thousands.
12. In the chart, click the first data series, or select it from a list of chart elements.
13. In the Format Data Series dialog box, click Fill.
14. Under Fill, click Solid Fill. In the Color palette, click the color that you want to use for the
selected data series. Drag the Transparency slider to the percentage of transparency that you
want to use, or type the percentage in the Transparency box.
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4.4 Stock Chart
As its name implies, a Stock chart is most often used to illustrate the fluctuation of stock prices.
However, this chart may also be used for scientific data. For example, you could use a Stock chart
to indicate the fluctuation of daily or annual temperatures.
The way Stock chart data is organized in your worksheet is very important. For example, to create a
simple high-low-close Stock chart, your data should be arranged with the stock names entered as
row headings, and High, Low, and Close entered as column

Depending on the type of stock chart you want to create, you must include a specific combination of
data series in your worksheet — and put the data series in order — as shown in the following table.
Stock Chart Type

Required data series and order

High-low-close

High price
Low price
Closing price

Open-high-low-close

Opening price
High price
Low price
Closing price

Volume-high-low-close

Volume traded
High price
Low price
Closing price

Volume-open-high-low-close

Volume traded
Opening price
High price
Low price
Closing price

Advanced Microsoft Excel @ Peter Lo 2020

17

Chapter 3

4.4.1 Create a Stock chart
1.
2.
3.
4.

Select the data you want to display in a Stock chart. Make sure the data is arranged for the type
of Stock chart you want to create, as described in the preceding table.
Click Insert ➔ Chart. In the Chart type box, click Stock.
Under Chart sub-type, click the type you want to use. For a quick preview of the chart you are
creating, click [Press and Hold to View Sample].
Click [Next], and continue with steps 2 – 4 of the Chart Wizard.

4.5 Surface Chart
A Surface chart shows a three dimensional surface that connects a set of data points. A Surface chart
is useful when you want to find optimum combinations between two sets of data. Like a
topographic map, the colors and patterns in a Surface chart indicate areas that contain the same
range of values. Unlike other chart types, colors in a surface chart are not used to distinguish each
data series. Instead, colors are used to distinguish the values.
When you use this data to create a Surface chart, it will be plotted as follows:

The row headings (seconds) appear along the series axis (y-axis).

The column headings (temperatures) appear along the category axis (x-axis).

The data in the center of the worksheet (tensile strength) will be plotted along the value axis
(z-axis).

4.5.1 Surface chart types
A Surface chart can be displayed in different ways by selecting the following chart sub-types:






3-D Surface – This chart shows a 3-D view of the data, which could be imagined as a rubber
sheet stretched over a 3-D Column chart. It is typically used to show relationships between
large amounts of data that may otherwise be difficult to see.
Wireframe 3-D Surface – A variation of the 3-D Surface chart that appears in black and white.
Without color in the surface, a wireframe chart shows only the lines.
Contour – A Contour chart provides a 2-D view of the Surface chart from above, similar to a
2-D topographic map. The lines in a Contour chart connect interpolated points of equal value.
Wireframe Contour – A variation of the Contour chart that appears in black and white. Without
color in the surface, a wireframe chart shows only the lines.
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4.5.2 Create a Surface chart
1.
2.
3.
4.
5.

Select the data you want to display in a Surface or Contour chart.
Click Insert ➔ Chart.
In the Chart type box, click Surface.
Under Chart sub-type, click the type you want to use. For a quick preview of the chart you
are creating, click [Press and Hold to View Sample].
Click [Next], and continue with steps 2 – 4 of the Chart Wizard.

4.5.3 Changing the format of a Surface chart
Because the colors in a Surface chart are based on the values rather than the data series, you cannot
select them in the chart itself. You can, however, select the corresponding color keys in the chart's
legend, and then make the formatting changes you want in the Format Legend Key dialog box.
Using this dialog box, you can:

Change the colors and patterns used in the chart.

Reorder the data series.

Change the depth of the chart.

4.5.4 Format a Surface chart
1.
2.
3.
4.
5.
6.
7.
8.

To display the legend, click Chart ➔ Chart Options, and then select the Show legend check
box on the Legend tab.
In the legend, click the key for which you want to change the format.
On the Format menu, click Selected Legend Key.
On the Patterns tab, make the color, border, or fill effect changes you want.
Repeat step 2-4 for each level you want to format.
To change the order of the data series in the chart, click the Series Order tab, click a series
name in the Series order box, and then click the [Move Up] or [Move Down] buttons.
To change the depth of the Surface chart, click the Options tab, and then type a value between
20 - 2000 in the Chart depth box. By default, the depth of the Surface chart is set to 100.
To add a 3-D shading effect to the Surface chart, on the Options tab, select the 3-D shading
check box.

You can see the effects of your changes in the preview box on the Series Order tab or the Options
tab. The number of colors shown in a Surface chart is dependent on the scale settings of the value
axis. Changes you make to a Surface chart may affect the size of the chart and those scale settings,
showing more or fewer colors.

4.6 Changing Three-Dimensional Viewing Angles
The simplest way to change the viewing angle of a three-dimensional chart is to select one of the
chart’s corners and drag it with the mouse. While you’re dragging, Excel displays an outline of the
chart. This direct-manipulation approach is simple, but you also can easily turn an intelligible chart
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into something quite the opposite. For more precise viewing-angle adjustment, choose Chart ➔
3-D View. The 3-D View dialog box, provides separate controls for modifying your chart’s
elevation, rotation, perspective, and height.

4.6.1 Adjusting the Elevation
The Elevation setting changes your viewing angle relative to the floor of the chart. The default
setting is 15, and you can specify any value from –90 through 90 (With 3D pie charts, you’re
limited to values from 10 through 80). A setting of 90 places you directly above the chart, as if you
were looking down on the tops of markers. With a 90 setting, you look up through the chart’s floor
(which, incidentally, is always transparent regardless of how you format it). To change the elevation,
type a number in the Elevation box or click the large up or down arrow button in the upper left
corner of the dialog box.

4.6.2 Changing the Rotation
Imagine that Excel has anchored your chart to a turntable. The Rotation setting spins the turntable.
Technically, the rotation setting specifies the angle formed by the category axis and a line drawn
horizontally across your screen. The default angle is 20o (pie charts = 0). You can specify any angle
from 0 – 360 by entering it in the Rotation box or by clicking the clockwise and counterclockwise
buttons to the right of the Rotation box.

4.6.3 Changing the Height
The Height setting changes a chart’s value-axis-to-category-axis ratio. The default is 100%; you can
select any value from 5 through 500. The higher the value, the taller your chart.

4.6.4 Changing the Perspective
The Perspective setting determines the apparent depth of three-dimensional area, column, line, and
surface charts. The default setting is 30, but you can specify any value from 0 – 100. Low values
make the chart look flatter, as if you were looking at the chart through a telescope or telephoto lens.
High values have the opposite effect, making it appear as if you were looking through the wrong
end of a pair of binoculars or through a wide-angle lens.
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The default setting specifies that the far side of the chart is 30% smaller than the near side. This
means that with a rotation of 0, the back of the floor is 30 percent narrower than the front of the
floor. Similarly, if the elevation is 90, the bottom of the tallest column in a 3D column chart is about
30% smaller than the top of the column. To change the perspective setting, type a new number in
the Perspective box or click the up or down arrow buttons above the Perspective box.

4.6.5 Changing the Axis Angle and Scale
The Right Angle Axes option sets the axes at right angles independent of chart rotation or elevation.
To see axes in perspective, turn off this option. This option default as off for 3D column charts.
Auto Scaling is available only if you have the Right Angle Axes option selected. When you change
a two-dimensional chart into a three-dimensional chart, Excel sometimes draws it smaller. For
charts with right-angle axes and a rotation of less than 45o, the Auto Scaling option scales the 3D
chart so it’s closer in size to the two-dimensional version.

4.7 Bubble Charts
A Bubble chart is a variation of a Scatter chart in which the data points are replaced with bubbles. A
Bubble chart can be used instead of a Scatter chart if your data has three data series, each of which
contains a set of values. For example, the worksheet in the following picture contains values for
three types of data: number of products, dollar value of sales, and percentage size of market share.

In a Bubble chart, the size of the bubbles is determined by the values in the third data series. For
example, the following Bubble chart displays bubble sizes that correspond to the values in the third
column of the sample data (Market share %).
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Notice that the data in this Bubble chart is plotted as follows:




Number of products is displayed along the horizontal (x) axis.
Sales amounts are displayed along the vertical (y) axis.
Market share percentages are represented by the size of the bubbles.

4.7.1 When to use a Bubble chart
Bubble charts are often used to present financial data. Use a Bubble chart when you want specific
values to be more visually represented in your chart by different bubble sizes. Bubble charts are
useful when your worksheet has any of the following types of data:

Three values per data point – Three values are required for each bubble. These values can be
in rows or columns on the worksheet, but they must be in the following order: x value, y value,




and then size value.
Negative values – Bubble sizes can represent negative values, although negative bubbles do
not display in the chart by default. You can choose to display them by formatting that data
series. When they are displayed, bubbles with negative values are colored white (which cannot
be modified) and the size is based on their absolute value. Even though the size of negative
bubbles is based on a positive value, their data labels will show the true negative value.
Multiple data series – Plotting multiple data series in a Bubble chart (multiple bubble series)
is similar to plotting multiple data series in a Scatter chart (multiple scatter series). While
Scatter charts use a single set of x values and multiple sets of y values, Bubble charts use a
single set of x values and multiple sets of both y values and size values.

4.7.2 Create a Bubble chart
1.
2.
3.
4.

Select the data you want to display in the Bubble chart. It's best not to include row or column
headings in the selection. Otherwise, the chart may produce incorrect results.
Select Insert ➔ Chart. In the Chart type box, click Bubble.
Under Chart sub-type, click the chart sub-type you want to use. For a quick preview of the
chart you are creating, click [Press and Hold to View Sample].
Click [Next], and continue with steps 2 – 4 of the Chart Wizard. Note that smaller bubbles
may be hidden by larger bubbles, making it seem that Excel has not drawn all of the data
markers. When an entire data series contains negative bubble sizes, the series is not displayed
by default. If you want to see the negative bubbles, select the series you want in the Chart
Objects list on the Chart toolbar, and then click Format Data Series on the same toolbar. On the
Options tab, select the Show Negative Bubbles check box.

4.7.3 Formatting Bubble charts
There are several ways to change the format of a Bubble chart:

Display bubbles with a 3-D visual effect – By selecting the 3-D Bubble chart sub-type,
bubbles are formatted with a 3-D visual appearance. A 3-D Bubble chart is 3-D in appearance
only — it actually remains a 2-D chart type. Unlike other 2-D chart types, however, this chart
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type cannot be used in a combination chart.






Adjust the size of bubbles – The size of the bubbles can represent the area of the bubbles or
the width of the bubble, which affects the relative size of one bubble to another. The Width of
bubbles option can be used for representations such as market share between products. You can
also scale the bubble size for a data series by specifying a percentage between 0 and 300 — the
larger the percentage, the larger the bubbles.
Display error bars – To graphically express potential error amounts relative to each bubble in
a bubble series, you can display error bars for the X values, the Y values, or both.
Change the color and fill effects of bubbles – You can assign different colors and fill effects
(such as pattern, texture, and gradient) to individual bubbles or an entire bubble series.
Replace bubbles with pictures – You can replace each bubble or all bubbles in a series with a
picture. The size of the picture is automatically adjusted to match the bubble size for each
corresponding value.

4.7.4 Change the Color and Pattern of Bubbles
1.
2.
3.
4.

In the Bubble chart, select a bubble or bubble series.
Click Format ➔ Selected Data Point or Format ➔ Selected Data Series.
On the Pattern tab, select the options you want.
To change the gradient, texture, or pattern of bubbles, click Fill Effects, and then select the
options you want on the Gradient, Texture, or Pattern tab. To use pictures instead of bubbles,
click the Picture tab, and then click Select Picture to insert the picture you want.

4.8 Pie of Pie and Bar of Pie Charts
Pie charts are excellent for displaying data points as a percentage of the whole. However, when
several data points each amount to less than 5% of the pie, it becomes hard to distinguish the slices.
For example, a pie chart of the following sales data contains three slices that fall below 5%.

Turnover
David
Susan
Teddy
Stepehn
Thomas
Kenneth

To make smaller slices more visible in a pie chart, Excel provides the Pie of Pie and Bar of Pie chart
sub-types. Each of these chart sub-types separates the smaller slices from the main pie chart and
displays them in an additional pie or stacked bar chart, as shown in the next picture.
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Turnover
David
Susan
Teddy
Stepehn
Thomas
Kenneth
Tony
May

Notice that the percentage labels in the secondary pie chart display the same numbers as in the
regular pie chart. The numbers only represent the individual slices that were moved to the
secondary chart; they do not total 100%.

4.8.1 Setting up your data and creating the chart
Pie charts can display only one data series, which means you can include only one column or row of
values in your selection when you create a pie chart. You can also include a row or column of
categories, as long as it is the first column or row in the selection.
When you select the Pie of Pie or Bar of Pie chart sub-type, Excel moves the last third of the data
points into the secondary chart by default. For example, if there are nine data points, the last three
points in your selection are plotted in the secondary chart. However, after the initial chart is created,
you can change the number of data points in the secondary chart by changing settings on the
Options tab of the Format Data Series dialog box.

4.8.2 Create a Pie of Pie or Bar of Pie chart
1.
2.

Select the data that you want to display in the Pie of Pie or Bar of Pie chart.
Click Insert ➔ Chart.

In the Chart type box, click Pie.
Under Chart sub-type, click Pie of Pie or Bar of Pie. For a quick preview of the chart you are
creating, click [Press and Hold to View Sample].
5. Click [Next], and continue with Steps 2 – 4 of the Chart Wizard.
Depending on how many decimal places are specified for percentages on the Number tab of the
Format Cells dialog box (Format menu, Cells command), percentages that are displayed in data
labels may be rounded so that they don't add up correctly.
3.
4.
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4.8.3 Customizing the way data points are displayed
You can format specific chart elements of a Pie of Pie or Bar of Pie chart the same way you would
in a regular pie chart. However, there are a few things that are unique to Pie of Pie and Bar of Pie
charts:

Position of primary and secondary charts – The primary and secondary charts are always
positioned horizontally and adjacent to each other. They cannot be moved separately. The left
chart is always the primary chart, but it's not always the larger of the two charts — the
secondary chart can be larger than the primary chart.

Selection of primary and secondary charts – You cannot select the individual charts or
format them separately. Both primary and secondary charts are part of one data series. You can
only select the entire data series or its individual data points, and then apply formatting to the


selection.
Connector lines – Connector lines are automatically added to emphasize the association
between the two charts. You can format them by applying different line styles. You can also
remove them if you need to.

4.8.4 Change Pie of Pie or Bar of Pie data series options
1.
2.
3.
4.
5.

6.
7.
8.

In the chart, select the entire data series. To select the entire data series, make sure nothing else
is selected, and then click either of the charts once.
Click Format ➔ Selected Data Series.
Click the Options tab.
To specify what kind of data you want in the secondary chart, click an option in the Split
series by box.
To adjust the number of data points that appear in the secondary chart, do one of the following:

If you chose to split the series by position, change the number in the Second plot
contains the last [ ] values box.

If you chose to split the series by value or percent value, change the number in the
Second plot contains all values less than box.

If you want to customize the split of the data, close the dialog box, and then use the
mouse to drag pieces between the two charts. The slice in the primary chart that
represents the data in the secondary chart cannot be moved into the other chart. If you
drag a slice from a pie chart without placing it in the other chart, space is created between
the slices.
To change the size of the secondary chart, increase or decrease the number in the Size of
second plot box (This number represents size as a percentage of the primary chart size).
To remove the connector lines, clear the Series lines check box.
To use the same color for all data points, clear the Vary colors by slice check box. You can
change the color of individual data points. Select the piece that you want to change, and then,
on the Format menu, click Selected Data Point. On the Patterns tab, under Area, click the color
you want to use.

Advanced Microsoft Excel @ Peter Lo 2020

25

Chapter 3

9.

To change the space between the charts, increase or decrease the number in the Gap width box
(This number represents gap width as a percentage of the secondary chart width).

4.9 Gantt Chart
There are many ways to create a Gantt chart. For example, Microsoft Project, a task-planning
program, makes it easy to track and chart project timelines with a built-in Gantt chart view. Another
option is to use Excel. Excel does not contain a built-in Gantt chart format; however, you can create
a Gantt chart in Excel by customizing the stacked bar chart type.

4.9.1 Step 1: Enter the sample data
Open a new worksheet in Excel and enter the values in cells, then format with the date format you
want to use for the chart by clicking Cells on the Format menu, and then clicking the Number tab.
Click Date in the Category list, and select the format you want to use in the Type list.
Task

Start Date

Duration (days)

End Date

Task 1
Task 2
Task 3
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4.9.2 Step 2: Create a stacked bar chart
1.
2.

3.

Select the data source, click Insert ➔ Chart to activate Chart Wizard, and select Stacked Bar
as the chart type
Remove all data series, and then recreate two data series:

Create a new series for the column of Start Date

Create a new series for the column of Duration
Press [Finish] to create the chart.

4.9.3 Step 3: Make the chart look like a Gantt chart
1.
2.
3.
4.

5.

Double-click the first series in the chart. This is the series for Start Date.
On the Patterns tab of the Format Data Series dialog box, click None for Border and None
for Area, and then click [OK].
Double-click the category (x) axis, which in a bar chart is the vertical axis. Click the Scale tab,
and select the Categories in reverse order check box.
Double-click the value (y) axis, which in a bar chart is the horizontal axis. Click the Scale tab
and type the following values in the appropriate boxes: Minimum, Maximum, Major unit
and Minor unit.
Within the legend, select Start Date and then press [Delete].
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