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1. Advanced Editing Technique 

1.1 In-Cell Chart 

1.1.1 Using Function  

When you are creating an Excel Dashboard and are limited by space and do not want to insert a 

chart, you can easily create an in-cell bar chart using the REPT (repeat) function. 

 

The syntax for REPT function is: REPT ( text, number_times ). The REPT function uses the 

vertical bar character | as the first argument: text and references the value cell for the second 

argument: number_times.  

Function Output 

REPT(“X”, 10) XXXXXXXXXX 

REPT("Ha! ", 3) Ha! Ha! Ha! 

REPT("|", 30) |||||||||||||||||||||||||||||| 

 

1.1.2 Using Sparklines  

A sparkline is a tiny chart in a worksheet cell that provides a visual representation of data. Use 

sparklines to show trends in a series of values, such as seasonal increases or decreases, economic 

cycles, or to highlight maximum and minimum values. Position a sparkline near its data for greatest 

impact. Unlike charts on an Excel worksheet, sparklines are not objects, a sparkline is actually a 

tiny chart in the background of a cell.  
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1.1.2.1 Drawing Sparkline 

Creating sparklines in excel is very easy. You follow 3 very simple steps to get beautiful sparklines 

in an instant. 

1. Select the data from which you want to make a sparkline. 

2. Go to Insert ➔ Sparkline and select the type of sparkline (you have 3 options – line, column 

and win-loss chart) 

3. Specify a target cell where you want the sparkline to be placed 

4. Optional: Format the sparkline if you want. 

 

1.1.2.2 Customize Sparkline 

 

In excel, you will find a ribbon called as “Sparklines – Design” ribbon. This is where all the 

formatting options for sparklines are included. Some of the key formatting / customizations you can 

do are, 

 Change the sparkline type 

 Change the source data / target cells of sparkline 

 Set different colors for first point, last point, highest & lowest points (applicable for column 

and line chart types) 

 Set axis options (show / hide axis, set min and max value for vertical axis, set axis type to date 

axis etc.) 

 Group / un-group a bunch of sparklines (you can change formatting options, axis settings 

en-masse when you group sparklines) 

 Remove sparklines 
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1.1.3 Using Conditional Format 

To add conditional formatting with data bars, follow these steps.  

 On the Excel worksheet, select the value cells that you want to format. If the Excel table has 

row or column totals, don't include those cells. 

 On the Ribbon, click the Home tab, and then in the Styles group, click Conditional Formatting.  

 In the list of conditional formatting options, click Data Bars, and then click one of the Data Bar 

options. The Data Bar options are identical, except for the color. 

 

1.1.3.1 Icon with Percentage 

 

1. Select Home ➔ Conditional Formatting ➔ Icon sets 

2. Select 3 traffic lights 

3. Edit the rule as shown below: 

 

 

 

http://chandoo.org/wp/2014/03/10/best-charts-to-show-progress/
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1.1.3.2 Data Bars 

 

1. Select Home ➔ Conditional Formatting ➔ Icon sets 

2. Select Solid Fill if available. 

3. Adjust maximum bar size to 100% so that you can see relative progress better. 

 

1.1.3.3 Pies 

 

1. Select Home ➔ Conditional Formatting ➔ Icon sets 

2. Select Pies if available. 
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1.2 Text to Columns 

You can take the text in one or more cells and split it into multiple cells, or vice versa using the 

Convert Text to Columns Wizard. 

 

1.2.1 Split Full Names into First Name and Last Name 

Suppose you have a dataset as shown below. To quickly split the first name and the last name and 

get these in separate cells, follow the below steps: 

 

1. Select the data set. Go to Data ➔ Data Tools ➔ Text to Columns. This will open the Convert 

Text to Columns Wizard. 

 

2. Make sure “Delimited” is selected and then press [Next]. Select ‘Space’ as the delimiter. If you 

suspect that there could be double/triple consecutive spaces between the names, also select 

‘Treat consecutive delimiters as one’ option. Click [Next] to continue  
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3. Select the destination cell. If you don’t select a destination cell, it would overwrite your 

existing data set with the first name in the first column and last name in the adjacent column. If 

you want to keep the original data intact, either create a copy or choose a different destination 

cell.  

 

4. This would instantly give you the results with the first name in one column and last name in 

another column after you click [Finish]. 

 

This technique works well when you the name constitutes of the first name and the last name only. 

The result you get from using the Text to Columns feature is static. This means that if there are any 

changes in the original data, you’ll have to repeat the process to get updated results. 

1.2.2 Split Email Address into Username and Domain Name 

Text to Columns allows you to choose your own delimiter to split text. This can be used to split 

emails addresses into usernames and domain names as these are separated by the @ sign. Suppose 

you have a dataset as shown below. Here are the steps to split these usernames and domain names 

using the Text to Columns feature: 

 



   Chapter 5 

Excel for Financial Modelling and Data Analysis @ Peter Lo 2023 7 

1. Select the data set, go to Data tab, Data Tools group, select Text to Columns. This will open 

the Convert Text to Columns Wizard. Make sure Delimited is selected and then press [Next]. 

Select Other and enter @ in the box to the right of it. Make sure to deselect any other option. 

Click [Next] to continue. 

  

2. Change the destination cell to the one where you want the result, and then click [Finish]. This 

would split the email address and give you the first name and the last name in separate cells. 

 

1.2.3 Convert Numbers with Trailing Minus Sign to negative numbers 

If you export numeric data from SAP, you will find that the negative numbers with trailing minus 

signs. Suppose you have a dataset as shown below: 

 

1. Select the data set. Go to Data ➔ Data Tools ➔ Text to Columns. This will open the Convert 

Text to Columns Wizard. Make sure "Delimited" is selected and then press [Next]. Press [Next] 

button again to continue. 
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2. Press [Advanced]. 

 
3. In the Advanced Text Import Settings dialog box, select the ‘Trailing minus for negative 

number’ option. Click [OK]. 

 

4. Change the destination cell to the one where you want the result, and press [Finish]. This 

would instantly place the minus sign from the end of the number of the beginning of it. Now 

you can easily use these numbers in formulas and calculations. 

 

1.2.4 Get the Root Domain from URL 

If you work with web URLs, you may sometimes need to know the total number of unique root 

domains. For example, in case of http://www.google.com/example1 and 

http://google.com/example2, the root domain is the same, which is www.google.com. Suppose you 

have a dataset as shown below: 
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1. Select the data set. Go to Data ➔ Data Tools ➔ Text to Columns. This will open the Convert 

Text to Columns Wizard. Make sure "Delimited" is selected and then press [Next]. Select 

Other and enter / in the box to the right of it. Make sure to deselect any other option. Click 

[Next] to continue. 

  
2. Change the destination cell to the one where you want the result, and then click [Finish]. This 

would split the URL and give you the root domain. 

 

This works well when you have all the URLs that have http:// in the beginning. If it doesn’t, then 

you will get the root domain in the first column itself. A good practice is to make these URLs 

consistent before using Text to Columns. 
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2. Advanced Formula Techniques 

2.1 Left Lookup 

The VLOOKUP function only looks to the right. To look up a value in any column and return the 

corresponding value to the left, simply use INDEX and MATCH. 

 

1. First, the MATCH function returns the position of a value in a given range. 

 

2. Use this result and the INDEX function to return the correct answer from the range. 
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2.2 Case-sensitive Lookup 

1. By default, the VLOOKUP function performs a case-insensitive lookup. For example, the 

simple VLOOKUP function below returns the salary of “Mia Clark”. However, we want to 

look up the salary of “MIA Reed”. 

 

2. The EXACT function returns TRUE if two strings are exactly the same.  

 

3. When compare the lookup value with a range, the array constant created by the EXACT 

function is stored in Excel's memory.  
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4. The MATCH function can be used to finds the position of TRUE in this array constant. 

Remember to press [Ctrl] + [Shift] + [Enter]. 

 

5. Use the INDEX function to return a specific value in a one-dimensional range. Remember to 

press [Ctrl] + [Shift] + [Enter]. 

  

2.3 Matrix Lookup 

When searching for something in your Excel spreadsheets, most of the time you'd look up vertically 

in columns or horizontally in rows. But sometimes you need to look across both rows and columns. 

In other words, you aim to find a value at the intersection of a certain row and column. This is 

called matrix lookup (also called 2-dimensional lookup or 2-way lookup), 

2.3.1 Using MATCH and INDEX 

1. To lookup a value in a two-dimensional range, use INDEX and MATCH in Excel. For example, 

you want to find the sales of different ice cream flavors in each month. Use the MATCH 

function to find the position of Feb in the range. 
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2. Use the MATCH function to find the position of Chocolate in the range. 

  

3. Use these results and the INDEX function to find the sales of Chocolate in February. 
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4. Put it all together. 

 

2.3.2 Using INDIRECT 

1. Select the range 

. 

2. On the Formulas tab, in the Defined Names group, click Create from Selection. 

 

3. Select Top row and Left column and click [OK]. 
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4. Excel created 15 named ranges (12 row cells and 3 column cells). Use the intersect operator 

(space) to return the intersection of two named ranges 

 

5. Create a dynamic two-way lookup using INDIRECT. The INDIRECT functions convert the 

text strings ("Feb" in cell G2 and "Chocolate" in cell G3) into valid named ranges. 

 

2.4 Multiple Conditions Lookup 

2.4.1 Using MATCH and INDEX 

1. The VLOOKUP function doesn’t handle multiple columns. You need to use MATCH and 

INDEX function to perform a two-column lookup in Excel. For example, if we want to look up 

the salary of James Clark, we need to use the & operator to join string. 
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2. The MATCH function returns the position of a value in a given range. Remember to press 

[Ctrl] + [Shift] + [Enter]. 

  

3. Use this result and the INDEX function to return the value. 

  

2.4.2 Using CHOOSE and VLOOKUP 

1. The other method for multiple conditions lookup is using CHOOSE and VLOOKUP function. 

Here’s some data and we would love to know what “Bb” is: 

 
2. We create a helper column by concatenating the two inputs and do a basic VLOOKUP. 
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3. With a dash of CHOOSE and sprinkling of Array formulas, we’re about to handle it: 

={VLOOKUP($E2,CHOOSE( {1,2}, $A$2:$A$7 & $B$2:$B$7, $C$2:$C$7), 2,0) } 

  

Using the Array creates a makeshift virtual helper column. You can handle multi condition 

VLOOKUP using the following simple structure 

VLOOKUP ( lookup value, CHOOSE({1, 2, ...N}, Column1 & Column 2 &…& Column N, 

Result Column), 2, 0) 

Where the lookup value is either something pre-concatenated (like Bb or Dd above) or you are 

using multiple criteria that you concatenate when entering the lookup value. The CHOOSE 

structure is easy. Always {1,2} then concatenate (with &) as many columns as you want (that 

the lookup values will need to look in) and the VLOOKUP’s column number is always 2.  

 

Consider the following example 
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If we want to look up the Savings Produced for a Director of Grade D who started in 2014. That’s 3 

lookup criteria. Let’s follow the structure = VLOOKUP( A13 & A14 & A15, CHOOSE({1,2}, 

A2:A10 & B2:B10 & C2:C10, D2:D10), 2, 0) and press [Ctrl] + [Shift] + [Enter] 

The two key things to note is that our lookup value is a concatenation of the criteria, in this case we 

have put the criteria in A13, A14 and A15 (hence A13&A14&A15 is our lookup value). Secondly, 

in the CHOOSE formula, the ranges in the middle part (A2:A10&B2:B10&C2:C10) should be 

concatenated in the same order that the lookup value was concatenated. So, we concatenated Start 

Year & Grade & Role in both the lookup value and lookup columns within the CHOOSE. 

2.5 Return Multiple Columns from VLOOKUP 

1. By utilizing an array formula using an array constant, we can use VLOOKUP to pull data from a 

range of multiple columns at one time. Here we have a data range with various types of fruit and 

the values of each in 5 different columns. 

 

2. We can use the following formula to obtain the values: 

 

There are some rules for using this formula: 

1. First, it’s an array formula, notice the curly brackets around the entire formula. When we started 

the formula, we selected all the cells that the formula would be in. Then when we entered it, we 

used [Ctrl] + [Shift] + [Enter] rather than just Enter. 

2. Second, notice that we did not have to “lock” either the lookup value or table array, since we are 

not copying the formula, but we could have – it would work either way. 

3. Third, instead of a single value or formula like the COLUMN function, the column number is an 

array constant {2, 3, 4, 5, 6}. These curly brackets are entered manually. This tells the 

VLOOKUUP formula not to select a single column, but to select all the ones listed and insert 

the value in the appropriate column. 
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2.6 Calculation on Multiple Columns from VLOOKUP 

VLOOKUP is great for extracting information from a huge data table based on what you are 

looking for. But what if you need to extract more than one column of information? Let’s say you 

have salesperson’s name in left most column, and monthly sales figures in next columns, one for 

each month.  

 
 

By applying the return multiple columns from VLOOKUP technique, together with the 

corresponding mathematically function, it’s possible to  

 

 

Moreover, we can also calculate the commission by using matrix calculation. 
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3. Analysis ToolPak 

3.1 Introduction 

If you need to develop complex statistical or engineering analyses, you can save steps and time by 

using the Analysis ToolPak. You provide the data and parameters for each analysis, and the tool uses 

the appropriate statistical or engineering macro functions to calculate and display the results in an 

output table. Some tools generate charts in addition to output tables. 

The data analysis functions can be used on only one worksheet at a time. When you perform data 

analysis on grouped worksheets, results will appear on the first worksheet and empty formatted 

tables will appear on the remaining worksheets. To perform data analysis on the remainder of the 

worksheets, recalculate the analysis tool for each worksheet. 

3.2 Setup the Add-in 

The Analysis TookPak is an add-in utility, so you should verify that it’s installed on your system 

before you get started.  

1. Click the Microsoft Office Button, and then click Options. 

2. Click Add-Ins, and then in the Manage box, select Excel Add-ins. Click [Go]. 
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3. In the Add-Ins available box, select the Analysis ToolPak check box, and then click [OK]. 

 

4. After you load the Add-in, the [Data Analysis] command is available in the Analysis group 

on the Data tab. 

 

5. When you click on the [Data Analysis] button, list of Analysis Tools will be shown: 
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3.3 Analysis Tools 

3.3.1 Anova 

The Anova analysis tools provide different types of variance analysis. The tool that you should use 

depends on the number of factors and the number of samples that you have from the populations 

that you want to test. 

3.3.1.1 Anova: Single Factor 

This tool performs a simple analysis of variance on data for two or more samples. The analysis 

provides a test of the hypothesis that each sample is drawn from the same underlying probability 

distribution against the alternative hypothesis that underlying probability distributions are not the 

same for all samples. If there are only two samples, you can use the worksheet function T.TEST. 

With more than two samples, there is no convenient generalization of T.TEST, and the Single Factor 

Anova model can be called upon instead. 

3.3.1.2 Anova: Two-Factor with Replication 

This analysis tool is useful when data can be classified along two different dimensions. For example, 

in an experiment to measure the height of plants, the plants may be given different brands of 

fertilizer (for example, A, B, C) and might also be kept at different temperatures (for example, low, 

high). For each of the six possible pairs of {fertilizer, temperature}, we have an equal number of 

observations of plant height. Using this Anova tool, we can test: 

Whether the heights of plants for the different fertilizer brands are drawn from the same underlying 

population. Temperatures are ignored for this analysis. 

Whether the heights of plants for the different temperature levels are drawn from the same 

underlying population. Fertilizer brands are ignored for this analysis. 

Whether having accounted for the effects of differences between fertilizer brands found in the first 

bulleted point and differences in temperatures found in the second bulleted point, the six samples 

representing all pairs of {fertilizer, temperature} values are drawn from the same population. The 

alternative hypothesis is that there are effects due to specific {fertilizer, temperature} pairs over and 

above the differences that are based on fertilizer alone or on temperature alone. 

 

3.3.1.3 Anova: Two-Factor Without Replication 

This analysis tool is useful when data is classified on two different dimensions as in the Two-Factor 

case With Replication. However, for this tool it is assumed that there is only a single observation for 

each pair (for example, each {fertilizer, temperature} pair in the preceding example). 
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3.3.2 Correlation 

The CORREL and PEARSON worksheet functions both calculate the correlation coefficient 

between two measurement variables when measurements on each variable are observed for each of 

N subjects. (Any missing observation for any subject causes that subject to be ignored in the 

analysis.) The Correlation analysis tool is particularly useful when there are more than two 

measurement variables for each of N subjects. It provides an output table, a correlation matrix, that 

shows the value of CORREL (or PEARSON) applied to each possible pair of measurement 

variables. 

The correlation coefficient, like the covariance, is a measure of the extent to which two 

measurement variables "vary together." Unlike the covariance, the correlation coefficient is scaled 

so that its value is independent of the units in which the two measurement variables are expressed. 

(For example, if the two measurement variables are weight and height, the value of the correlation 

coefficient is unchanged if weight is converted from pounds to kilograms.) The value of any 

correlation coefficient must be between -1 and +1 inclusive. 

You can use the correlation analysis tool to examine each pair of measurement variables to 

determine whether the two measurement variables tend to move together — that is, whether large 

values of one variable tend to be associated with large values of the other (positive correlation), 

whether small values of one variable tend to be associated with large values of the other (negative 

correlation), or whether values of both variables tend to be unrelated (correlation near 0 (zero)). 

3.3.2.1 Example: 

We are going to check to see if there is a correlation between the number of leaflets we give out and 

the number of people who visit our shop. 

1. On the Data tab in the Analysis group, click Data Analysis. Select Correlation and press 

[OK]. 

 

2. Input the following information and press [OK]: 

 Specify the input range to be B1:C7 

 Select the Labels in First Row checkbox 
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3. Excel produces the following Summary Output. 

 

 Positive Correlation: A coefficient of 1 denotes a perfect positive correlation. 

(Very Strong = 1) 

 Negative Correlation: A coefficient of -1 denotes a perfect negative correlation. 

(Very Strong = -1) 

 No Correlation: A coefficient of 0 means that there is no correlation. 

3.3.3 Covariance 

The Correlation and Covariance tools can both be used in the same setting, when you have N 

different measurement variables observed on a set of individuals. The Correlation and Covariance 

tools each give an output table, a matrix, that shows the correlation coefficient or covariance, 

respectively, between each pair of measurement variables. The difference is that correlation 

coefficients are scaled to lie between -1 and +1 inclusive. Corresponding covariances are not scaled. 

Both the correlation coefficient and the covariance are measures of the extent to which two 

variables "vary together." 

The Covariance tool computes the value of the worksheet function COVARIANCE.P for each pair 

of measurement variables. (Direct use of COVARIANCE.P rather than the Covariance tool is a 

reasonable alternative when there are only two measurement variables, that is, N=2.) The entry on 

the diagonal of the Covariance tool's output table in row i, column i is the covariance of the i-th 

measurement variable with itself. This is just the population variance for that variable, as calculated 

by the worksheet function VAR.P. 

You can use the Covariance tool to examine each pair of measurement variables to determine 

whether the two measurement variables tend to move together — that is, whether large values of 

one variable tend to be associated with large values of the other (positive covariance), whether 

small values of one variable tend to be associated with large values of the other (negative 

covariance), or whether values of both variables tend to be unrelated (covariance near 0 (zero)). 
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3.3.4 Descriptive Statistics 

The Descriptive Statistics analysis tool generates a report of univariate statistics for data in the input 

range, providing information about the central tendency and variability of your data. 

3.3.5 Exponential Smoothing 

The Exponential Smoothing analysis tool predicts a value that is based on the forecast for the prior 

period, adjusted for the error in that prior forecast. The tool uses the smoothing constant a, the 

magnitude of which determines how strongly the forecasts respond to errors in the prior forecast. 

Note: Values of 0.2 to 0.3 are reasonable smoothing constants. These values indicate that the current 

forecast should be adjusted 20 percent to 30 percent for error in the prior forecast. Larger constants 

yield a faster response but can produce erratic projections. Smaller constants can result in long lags 

for forecast values. 

3.3.6 F-Test Two-Sample for Variances 

The F-Test Two-Sample for Variances analysis tool performs a two-sample F-test to compare two 

population variances. 

For example, you can use the F-Test tool on samples of times in a swim meet for each of two teams. 

The tool provides the result of a test of the null hypothesis that these two samples come from 

distributions with equal variances, against the alternative that the variances are not equal in the 

underlying distributions. 

The tool calculates the value f of an F-statistic (or F-ratio). A value of f close to 1 provides evidence 

that the underlying population variances are equal. In the output table, if f < 1 "P(F <= f) one-tail" 

gives the probability of observing a value of the F-statistic less than f when population variances are 

equal, and "F Critical one-tail" gives the critical value less than 1 for the chosen significance level, 

Alpha. If f > 1, "P(F <= f) one-tail" gives the probability of observing a value of the F-statistic 

greater than f when population variances are equal, and "F Critical one-tail" gives the critical value 

greater than 1 for Alpha. 

3.3.7 Fourier Analysis 

The Fourier Analysis tool solves problems in linear systems and analyzes periodic data by using the 

Fast Fourier Transform (FFT) method to transform data. This tool also supports inverse 

transformations, in which the inverse of transformed data returns the original data. 

 

3.3.8 Histogram 

The Histogram analysis tool calculates individual and cumulative frequencies for a cell range of 

data and data bins. This tool generates data for the number of occurrences of a value in a data set. 

For example, in a class of 20 students, you can determine the distribution of scores in letter-grade 
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categories. A histogram table presents the letter-grade boundaries and the number of scores between 

the lowest bound and the current bound. The single most-frequent score is the mode of the data. 

3.3.9 Moving Average 

The Moving Average analysis tool projects values in the forecast period, based on the average value 

of the variable over a specific number of preceding periods. A moving average provides trend 

information that a simple average of all historical data would mask. Use this tool to forecast sales, 

inventory, or other trends. Each forecast value is based on the following formula. 

Formula to calculate moving averages: 

  

 N is the number of prior periods to include in the moving average 

 Aj is the actual value at time j 

 Fj is the forecasted value at time j 

3.3.10 Random Number Generation 

The Random Number Generation analysis tool fills a range with independent random numbers that 

are drawn from one of several distributions. You can characterize the subjects in a population with a 

probability distribution. For example, you can use a normal distribution to characterize the 

population of individuals' heights, or you can use a Bernoulli distribution of two possible outcomes 

to characterize the population of coin-flip results. 

3.3.11 Rank and Percentile 

The Rank and Percentile analysis tool produces a table that contains the ordinal and percentage rank 

of each value in a data set. You can analyze the relative standing of values in a data set. This tool 

uses the worksheet functions RANK.EQ andPERCENTRANK.INC. If you want to account for tied 

values, use the RANK.EQ function, which treats tied values as having the same rank, or use the 

RANK.AVG function, which returns the average rank for the tied values. 

3.3.12 Regression 

The Regression analysis tool performs linear regression analysis by using the "least squares" 

method to fit a line through a set of observations. You can analyze how a single dependent variable 

is affected by the values of one or more independent variables. For example, you can analyze how 

an athlete's performance is affected by such factors as age, height, and weight. You can apportion 

shares in the performance measure to each of these three factors, based on a set of performance data, 

and then use the results to predict the performance of a new, untested athlete. 

The Regression tool uses the worksheet function LINEST. 

3.3.12.1 Example 

We should like to know is there a relation between Quantity Sold (Output) and Price and 

Advertising (Input).  
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1. On the Data tab in the Analysis group, click Data Analysis. Select Regression and click OK. 

 

2. Input the following information and press [OK]: 

 Select the output (A1:A8) as Y Range. This is the predictor variable (also called 

dependent variable). 

 Select the input (B1:C8) as X Range. These are the explanatory variables (also called 

independent variables). These columns must be adjacent to each other. 

 Select the Labels and Residuals checkbox. 

 

 

 

Quantity Sold Selling Price Advertising Cost

8,500 $2.00 $2,800.00

4,700 $5.00 $200.00

5,800 $3.00 $400.00

7,400 $2.00 $500.00

6,200 $5.00 $3,200.00

7,300 $3.00 $1,800.00

5,600 $4.00 $900.00
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3. Excel produces the following Summary Output. 

 

 R Square equals 0.96, which is a very good fit. 96% of the variation in Quantity Sold is 

explained by the independent variables Price and Advertising. The closer to 1, the better the 

regression line (read on) fits the data. 

 To check if your results are reliable (statistically significant), look at Significance F (0.001). If 

this value is less than 0.05, you're OK. If Significance F is greater than 0.05, it's probably 

better to stop using this set of independent variables. Delete a variable with a high P-value 

(greater than 0.05) and rerun the regression until Significance F drops below 0.05. 

 The regression line is: y = Quantity Sold = 8536 - 836 * Price + 0.59 * Advertising. In other 

words, for each unit increase in price, Quantity Sold decreases with 836 units. For each unit 

increase in Advertising, Quantity Sold increases with 0.592 units. This is valuable information. 

You can also use these coefficients to do a forecast. For example, if price equals $4 and 

Advertising equals $3000, you might be able to achieve a Quantity Sold of 8536 - 836 * 4 + 

0.592 * 3000 = 6970. 

 The residuals show you how far away the actual data points are fom the predicted data points 

(using the equation). For example, the first data point equals 8500. Using the equation, the 

predicted data point equals 8536 - 836 * 2 + 0.592 * 2800 = 8523, giving a residual of 8500 - 

8523 = -23. 
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3.3.13 Sampling 

The Sampling analysis tool creates a sample from a population by treating the input range as a 

population. When the population is too large to process or chart, you can use a representative 

sample. You can also create a sample that contains only the values from a particular part of a cycle 

if you believe that the input data is periodic. For example, if the input range contains quarterly sales 

figures, sampling with a periodic rate of four places the values from the same quarter in the output 

range. 

3.3.14 t-Test 

The t test tells you how significant the differences between groups are; In other words it lets you 

know if those differences (measured in means/averages) could have happened by chance. 

 

The Two-Sample t-Test analysis tools test for equality of the population means that underlie each 

sample. The three tools employ different assumptions: that the population variances are equal, that 

the population variances are not equal, and that the two samples represent before-treatment and 

after-treatment observations on the same subjects. 

For all three tools below, a t-Statistic value, t, is computed and shown as "t Stat" in the output tables. 

Depending on the data, this value, t, can be negative or nonnegative. Under the assumption of equal 

underlying population means, if t < 0, "P(T <= t) one-tail" gives the probability that a value of the 

t-Statistic would be observed that is more negative than t. If t >=0, "P(T <= t) one-tail" gives the 

probability that a value of the t-Statistic would be observed that is more positive than t. "t Critical 

one-tail" gives the cutoff value, so that the probability of observing a value of the t-Statistic greater 

than or equal to "t Critical one-tail" is Alpha. 

"P(T <= t) two-tail" gives the probability that a value of the t-Statistic would be observed that is 

larger in absolute value than t. "P Critical two-tail" gives the cutoff value, so that the probability of 

an observed t-Statistic larger in absolute value than "P Critical two-tail" is Alpha. 

3.3.14.1 t-Test: Paired Two Sample for Means 

You can use a paired test when there is a natural pairing of observations in the samples, such as 

when a sample group is tested twice — before and after an experiment. This analysis tool and its 

formula perform a paired two-sample Student's t-Test to determine whether observations that are 

taken before a treatment and observations taken after a treatment are likely to have come from 

distributions with equal population means. This t-Test form does not assume that the variances of 

both populations are equal.  

Note: Among the results that are generated by this tool is pooled variance, an accumulated measure 

of the spread of data about the mean, which is derived from the following formula. 
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3.3.14.2 t-Test: Two-Sample Assuming Equal Variances 

This analysis tool performs a two-sample student's t-Test. This t-Test form assumes that the two 

data sets came from distributions with the same variances. It is referred to as a homoscedastic t-Test. 

You can use this t-Test to determine whether the two samples are likely to have come from 

distributions with equal population means. 

3.3.14.3 t-Test: Two-Sample Assuming Unequal Variances 

This analysis tool performs a two-sample student's t-Test. This t-Test form assumes that the two 

data sets came from distributions with unequal variances. It is referred to as a heteroscedastic t-Test. 

As with the preceding Equal Variances case, you can use this t-Test to determine whether the two 

samples are likely to have come from distributions with equal population means. Use this test when 

there are distinct subjects in the two samples. Use the Paired test, described in the follow example, 

when there is a single set of subjects and the two samples represent measurements for each subject 

before and after a treatment. The following formula is used to determine the statistic value t. 

 

The following formula is used to calculate the degrees of freedom, df. Because the result of the 

calculation is usually not an integer, the value of df is rounded to the nearest integer to obtain a 

critical value from the t table. The Excel worksheet function T.TEST uses the calculated df value 

without rounding, because it is possible to compute a value for T.TEST with a non-integer df. 

Because of these different approaches to determining the degrees of freedom, the results of T.TEST 

and this t-Test tool will differ in the Unequal Variances case. 

 

3.3.14.4 Example 

Below you can find the study hours of 6 female students and 5 male students. 

 

Female Male

26 23

25 30

43 18

34 25

18 28

52
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1. On the Data tab in the Analysis group, click Data Analysis. 

2. Since the variances of the two populations are unequal, select t-Test: Two-Sample Assuming 

Unequal Variances and click OK. 

 

3. Input the following information and press [OK]: 

 Click in the Variable 1 Range box and select the female’s study hour (A2:A7). 

 Click in the Variable 2 Range box and select the male’s study hour (B2:B6). 

 Click in the Hypothesized Mean Difference box and type 0 (H0: μ1 - μ2 = 0). 

 

4. We do a two-tail test (inequality). lf t Stat < -t Critical two-tail or t Stat > t Critical two-tail, we 

reject the null hypothesis. This is not the case, -2.365 < 1.473 < 2.365. Therefore, we do not 

reject the null hypothesis. The observed difference between the sample means (33 - 24.8) is not 

convincing enough to say that the average number of study hours between female and male 

students differ significantly. 
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3.3.15 z-Test 

The z-Test: Two Sample for Means analysis tool performs a two sample z-Test for means with 

known variances. This tool is used to test the null hypothesis that there is no difference between two 

population means against either one-sided or two-sided alternative hypotheses. If variances are not 

known, the worksheet function Z.TEST should be used instead. 

When you use the z-Test tool, be careful to understand the output. "P(Z <= z) one-tail" is really P(Z 

>= ABS(z)), the probability of a z-value further from 0 in the same direction as the observed z value 

when there is no difference between the population means. "P(Z <= z) two-tail" is really P(Z >= 

ABS(z) or Z <= -ABS(z)), the probability of a z-value further from 0 in either direction than the 

observed z-value when there is no difference between the population means. The two-tailed result is 

just the one-tailed result multiplied by 2. The z-Test tool can also be used for the case where the null 

hypothesis is that there is a specific nonzero value for the difference between the two population 

means. For example, you can use this test to determine differences between the performances of 

two car models. 
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4. Integrating Excel with Other Applications 

4.1 Linking and Embedding 

You can display a linked object or embedded object in a workbook exactly as it appears in the 

source program or as an icon. If the workbook will be viewed online, and you don't intend to print 

the workbook, you can display the object as an icon. This minimizes the amount of display space it 

occupies. Viewers who want to display the information can double-click the icon. 

1. Select Insert tab, Text group, and choose Object. 

 

2. You can either create a new object, or directly create it from a file. If you want to link the data 

to the source file, select the Link to file checkbox. Press [OK] to continue. 

  

3. The new object will be embedded to your worksheet. 
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4.2 Using Hyperlinks  

A hyperlink is a link from a document that opens another page or file when you click it. The 

destination is frequently another Web page, but it can also be a picture, or an e-mail address, or a 

program. The hyperlink itself can be text or a picture. 

When a site user clicks the hyperlink, the destination is shown in a Web browser, opened, or run, 

depending on the type of destination. For example, a hyperlink to a page shows the page in the Web 

browser, and a hyperlink to an AVI file opens the file in a media player 

You can use hyperlinks to do the following: 

 Navigate to a file or Web page on a network, intranet, or Internet  

 Navigate to a file or Web page that you plan to create in the future  

 Send an e-mail message  

 Start a file transfer, such as downloading or an FTP process  

When you point to text or a picture that contains a hyperlink, the pointer becomes a hand, indicating 

that the text or picture is something that you can click. 

A URL (Uniform Resource Locator) contains a protocol, FTP, or FILE, a Web server or network 

location, and a path and file name. The following illustration defines the parts of the URL: 

 

 

 Protocol used (http, ftp, file) 

 Web server or network location 

 Path 

 File name 

 

To create a hyperlink, follow these steps: 

1. Click the cell where you want to create a hyperlink. You can also select an object (such as a 

picture or an element in a chart) that you want to use to represent the hyperlink. 

2. Select Insert tab, Link group, and choose Link. 

 

3. Enter the URL in the Address box of the Insert Hyperlink dialog, and press [OK] to confirm.  
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4. The hyperlink is created for the specified cell. A tooltip will be displayed once you move your 

mouse on that cell 

 

4.3 Using Excel Data in Word and PowerPoint Documents  

Its many presentation features notwithstanding, Microsoft Excel is at heart an analytical tool. When 

it comes time to organize information and present it to others, you’re likely to turn to Word and 

PowerPoint. Naturally, these programs are designed to work hand-in-glove with Excel, so you can 

easily do your number crunching in Excel and transfer the results to Word or PowerPoint when you 

need to make a verbal or visual presentation. 

4.3.1 Pasting an Excel Table from the Clipboard 

If you copy an Excel worksheet range to the Clipboard and then paste into Word, the smart-tag 

menu that appears below the lower-right corner of the pasted data, provides quick access to the 

formatting options that Microsoft thinks you’re most likely to want.  

 

These options are as follows: 

 Keep Source Formatting. Word receives the data as a block of HTML and creates a table, 

preserving the fonts, alignment properties, numeric formatting, text color, and shading of your 

original. In most, but not all, cases, this option (the default) is an adequate way to create a table 

in Word that matches the appearance of your Excel data. After you have performed the paste, 

you can use commands on Word’s Table menu to modify such characteristics as column widths 

and the position of the table within surrounding text.  

 Match Destination Table Style. The data becomes a table in Word, but Word formats it as if 

you had created the table directly in Word. Numeric formatting and character styles that you 

used in Excel are preserved, but in most other respects your data will look as though you typed 

it in Word rather than pasting it from Excel. If your default font in Word is Times New Roman, 
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for example, your table will appear in Times New Roman, regardless of what font you used in 

Excel. Use this option if you want to make the table’s appearance blend in maximally with the 

rest of your document. Note, however, that if your data in Excel uses non-default alignments, 

you’ll probably need to do some formatting after it arrives in Word. As with the default choice 

(Keep Source Formatting), Word’s Table menu is available to help you with column widths, 

text-flow options, and so on. 

 Keep Text Only. If you choose this option, Word does not create a table. Instead, it simply 

pastes each cell’s contents in the current default font, separating cells with single tab characters. 

You might find this option useful if you’re simply copying a single column from Excel. Where 

multiple columns are involved, the Keep Text Only choice usually produces a misaligned hash 

in Word. 

 Apply Style or Formatting. This option behaves like the Keep Source Formatting option, but 

causes Word to display the Styles and Formatting task pane, allowing you to apply styles or 

character formatting immediately. 

4.4 Mail Merge  

4.4.1 Overview 

Mail merge is useful for creating a set of documents that are essentially the same but where each 

document contains unique elements. For example, in a letter that announces a new product, 

company logo and the text about the product will appear in each letter, and the address and greeting 

line will be different in each letter.  

 

4.4.2 Document Type 

Word provides tools for incorporating your data into the following kinds of documents.  

 Letters that include a personalized greeting. Each letter prints on a separate sheet of paper. 

 Email where each recipient's address is the only address on the To line. You'll be sending the 

email directly from Word. 

 Envelopes or Labels where names and addresses come from your data source. 

 Directory that lists a batch of information for each item in your data source. Use it to print out 

your contact list, or to list groups of information, like all of the students in each class. This 

type of document is also called a catalog merge. 
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4.4.3 Data Sources  

Recipients of a mail merge usually come from a list of names and data in an existing list, like an 

Excel spreadsheet, or your Outlook contacts list. The existing list could also be any database that 

you can connect to. If you don't already have a list, you can type one up as part of the mail merge 

process. The list or database is known as the data source for your mail merge. 

 New list: If you don't have a data source yet, use the form that opens to create your list. The 

list is saved as a database (.mdb) file that you can reuse. 

 Existing list: An existing list might be an Excel spreadsheet, Access database, or some other 

type of database. 

− An Excel spreadsheet works well as a data source for mail merge if all data is 

well-formatted and on one sheet so that it can be read by Word. 

− With Access, you can select data from any table or query defined in the database.  

− To access other kinds of data sources, you'll run the Data Connection Wizard: 

 Outlook Contact List: You can retrieve contact information directly from your Outlook 

contact list in Word. 

4.4.4 Creating Mail Merge 

4.4.4.1 Prepare data in Excel for mail merge 

The most important step in the mail merge process is to set up and prepare your data. You'll use 

your Excel spreadsheet as the data source for the recipient list.  

Here are some tips to prepare your data for a mail merge. Make sure:  

• Column names in your spreadsheet match the field names you want to insert in your mail merge. 

For example, to address readers by their first name in your document, you'll need separate 

columns for first and last names. 

• All data to be merged is present in the first sheet of your spreadsheet. 

• Data entries with percentages, currencies, and postal codes are correctly formatted in the 

spreadsheet so that Word can properly read their values. 

• The Excel spreadsheet to be used in the mail merge is stored on your local machine. 

• Changes or additions to your spreadsheet are completed before it's connected to your mail 

merge document in Word.  

4.4.4.2 Start the Mail Merge 

1. This step in the mail-merge process involves two choices. First, choose the type of document 

that you want to merge information into. Then, choose the main document that want to use. 

The main document is the model for all of the merged documents that eventually create.  

 The Mail Merge task pane opens with a question about what type of merged document 

you are creating. After you choose, click Next at the bottom of the task pane.  

 If your main document is already open, or you are starting with a blank document, you 

can click Use the current document. Otherwise, click Start from a template or Start 

from existing document, and then locate the template or document that you want to use. 
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2. To merge unique information into your main document, you must connect to the data file 

where the unique information is stored. If you don't want to use all the data in the file in your 

merge, you can choose the records that you want to use.  

 In this step in the mail-merge process, you connect to the data file where the unique 

information that you want to merge into your documents is stored. If you have a Excel 

worksheet that contains your customer information, click Use an existing list, and then 

click Browse to locate the file. 

 Just because you connect to a certain data file doesn't mean that you have to merge 

information from all the records in that data file into your main document. After you 

connect to the data file that you want to use or create a new date file, the Mail Merge 

Recipients dialog box opens. You can select a subset of records for your mail merge by 

sorting or filtering the list. 

   

3. After you connect your main document to a data file, you're ready to add fields that indicate 

where the unique information will appear in each copy of the document that you generate 

when you merge. To make sure that Word can find a column in your data file that corresponds 

to every address or greeting element, you may need to match fields. 
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 If your main document is still blank, type the information that will appear in each copy. 

Then, add fields by clicking the hyperlinks in the task pane. Fields are placeholders that 

you insert into the main document at locations where you want unique information to 

appear. For example, you can click the Address block or Greeting line links in the task 

pane to add fields near the top of a new product letter, so that each recipient's letter 

contains a personalized address and greeting. Fields appear in your document within 

chevrons, for example, «AddressBlock». If you click More items in the task pane, you can 

add fields that match any of the columns in your data file.  

 

4. After you add fields to your main document, you are ready to preview the merge results. When 

you're satisfied with the preview, you can complete the merge. 

 You can preview your merged documents and make changes before complete the merge 

 What you do now depends on what type of document you're creating. If you are merging 

letters, you can print the letters or modify them individually. If you choose to modify the 

letters, Word saves them all to a single file, with one letter per page. 
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5. Working with External Data  

5.1 Introduction 

You can compile your data into Excel by retyping or by copying and pasting. But importing is most 

effective when you're working with large amounts of data that would be time-consuming to enter 

manually or too large to copy and paste. In addition, if you import your data, Excel can 

automatically update your reports and summaries whenever the original source database is updated.  

The main benefit of connecting to external data is that you can periodically analyse this data in 

Excel without repeatedly copying the data, which is an operation that can be time-consuming and 

error prone. After connecting to external data, you can also automatically refresh your Excel 

workbooks from the original data source whenever the data source is updated with new information. 

5.2 Text Import Wizard 

5.2.1 Different File Types 

Text files, CSV files, and Excel spreadsheets are great ways to store data, depending on your need: 

 Text File (TXT) – Text files contain plain text and are commonly created with Notepad 

− Fixed Width Text File: Data in a fixed-width text file is arranged in rows and columns, 

with one entry per row. Each column has a fixed width, specified in characters, which 

determines the maximum amount of data it can contain. No delimiters are used to separate 

the fields in the file. 

− Tab-Delimited Text File: A tab-delimited text file is a file containing tabs that separate 

information with one record per line. A tab delimited file is often used to upload data to a 

system 

 Comma Separated Value File (CSV) – A CSV file also contains plain text and is versatile 

because it can be opened on any operating system, in any text editor, and also in spreadsheet 

applications, like Excel. If you paste spreadsheet data into a CSV file, it's separated by 

commas. 

 

Fixed-width Text File 

 

Tab-delimited Text File 
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5.2.2 Using Text Import Wizard 

1. In order to activate the Text Import Wizard, select the Data button on the left of the Excel 

Options and tick the checkbox From Text (Legacy). 

 

2. In the Data tab, select Get Data ➔ Legacy Wizards ➔ From Text (Legacy). 
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3. The Text Import Wizard will be popup after select the file. Select “Fixed width” and press 

[Next>].  

 Original data type: If items in the text file are separated by tabs, colons, semicolons, 

spaces, or other characters, select Delimited. If all of the items in each column are the same 

length, select Fixed width. 

 Start import at row: Select a row number to specify the first row of the data that you want 

to import. 

 File origin: Select the character set that is used in the text file. In most cases, you can leave 

this setting at its default. If you know that the text file was created by using a different 

character set than the character set that you are using on your computer, you should change 

this setting to match that character set.  

 

4. To specify how you want to divide the text into columns. 
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5. Define the Column data format and click [Finish] 

 

6. Define where do you want to put the data. 

 

7. The data will be imported. 
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5.3 Power Query 

5.3.1 What is Power Query? 

Power Query is a business intelligence tool available in Excel that allows you to import data from 

many different sources and then clean, transform and reshape your data as needed. It allows you to 

set up a query once and then reuse it with a simple refresh. Power Query can import and clean 

millions of rows into the data model for analysis after. The user interface is intuitive and well laid 

out so it’s really easy to pick up. It’s an incredibly short learning curve when compared to other 

Excel tools like formulas or VBA. 

5.3.2 What can Power Query Import? 

Importing your data with Power Query is simple. Excel provides many common data connections 

that are accessible from the Data tab and can be found from the Get Data command. There are a 

couple of the more common query types available in the top level of the ribbon commands found in 

the Get & Transform section of the Data Tab. 

 

• From File – Get data from a single file such as an Excel workbook, Text or CSV file, XML and 

JSON files. You can also import multiple files from within a given folder. 

• From Database – Get data from various databases such as SQL Server, Microsoft Access, 

Analysis Services, SQL Server Analysis Server, Oracle, IBM DB2, MySQL, PostgreSQL, 

Sybase, Teradata and SAP HANA databases. 

• From Azure – Get data from Microsoft Azure 

• From Online Services – Get data from online services like Sharepoint, Microsoft Exchange, 

Dynamics 365, Facebook and Salesforce. 

• From Other Sources – Get data from other sources like a table or range inside the current 

workbook, from the web, a Microsoft Query, Hadoop, OData feed, ODBC and OLEDB. 
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Depending on which type of data connection you choose, Excel will guide you through the 

connection set up and there might be several options to select during the process. At the end of the 

setup process, you can preview the data in the data preview window to make sure it’s what you’re 

expecting. You can then load the data as is by pressing the [Load] button, or you can proceed to the 

query editor to apply any data transformation steps by pressing the [Edit] button. 

 

5.3.3 Query Editor 

After connecting your data with edit option, you will be presented with the query editor. This is 

where any data transformation steps will be created or edited. There are 6 main areas in the editor. 
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(1) The Ribbon – The user interface for the editor is quite similar to Excel and uses a visual ribbon 

style command center. It organizes data transformation commands and other power query 

options into 5 main tabs. 

(2) Query List – This area lists all the queries in the current workbook. You can navigate to any 

query from this area to begin editing it. 

(3) Data Preview – This area is where you will see a preview of the data with all the transformation 

steps currently applied. You can also access a lot of the transformation commands here either 

from the filter icons in the column headings or with a right click on the column heading. 

(4) Formula Bar – This is where you can see and edit of the current transformation. Each 

transformation you make on your data is recorded and appears as a step in the applied steps 

area. 

(5) Properties – This is where you can name your query. When you close and load the query to an 

Excel table, power query will create a table with the same name as its source query if the table 

name isn’t already taken. 

(6) Applied Steps – This area is a chronological list of all the transformation steps that have been 

applied to the data. You can move through the steps here and view the changes in the data 

preview area. You can also delete, modify or reorder any steps in the query here. 

5.3.4 Import Data to Excel 

5.3.4.1 Import from Fixed-width Text File 

In order to import a text file in fixed-length or tab-delimiter format, follow these steps: 

1. Click the cell you want to put the data and then Data ➔ Get & Transform Data ➔ From 

Text/CSV. 

2. Locate the file you want to import. To specify how you want to divide the text into columns 

and then click [Load]. 
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3. The file will be loaded into the Excel table. 

 

5.3.4.2 Import from Web 

1. The first step is to connect to the data source. For example, we will get the global market data 

from Reuters (https://www.reuters.com/markets/global-market-data). The information we need 

is in a table that is part of the overall webpage. 

 

2. Select Data ➔ Get & Transform Data ➔ From Web. Input URL in the “From Web” dialog 

box and press [OK] to continue. 

 

https://www.reuters.com/markets/global-market-data
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3. Select the table you wish to import. Then press [Load]. 

 

4. The data are imported to Excel. 

 

5.3.4.3 Import by Transformation 

1. Refer to previous example, there are multiple tables in the website. We would like to combine 

them into one single table for output. Select Data ➔ Get & Transform Data ➔ From Web. 

Input URL in the “From Web” dialog box and press [OK] to continue. 
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2. In order to select multiple tables, tick the "Select multiple items" checkbox. Then select the 

table you wish to import. Then press [Transform Data]. 

 

3. In Home tab, Combine group, select Append Queries ➔ Append Queries as New. 

 
4. Select “Three or more tables” and add all tables to “Tables to append” section. Press [OK] to 

continue. 
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5. Three tables combined into a new query “Append1”. Press [Load & Load] to back to Excel. 

 

6. The data will be imported as a single table in worksheet.  

 

5.3.5 Refresh Imported Data 

Excel provides many options for refreshing imported data, including refreshing the data whenever 

you open the workbook and automatically refreshing data at timed intervals. You can continue to 

work in Excel while data is being refreshed, and you can also check the status of the refresh while 

it's being refreshed. 

If your external data source requires a password to gain access to the data, you can require that the 

password be entered each time the external data range is refreshed. 

When an external data range expands and additional records are returned, Excel can fill formulas in 

adjacent columns or within the data range so that they remain next to the appropriate data. 
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5.3.5.1 Configure Connection Properties 

You can define many connection properties such as automatically refresh, background refresh by 

choosing Data tab, Queries & Connections group, select Refresh All ➔ Connection 

Properties…. 

 

Then you can setup your configuration in the Query Properties dialog box,  

 

 Tick the “Enable background refresh” check box to run the query in the background or clear 

it to run the query while you wait. 

 If your enable the “Refresh every minute”, then the workbook will refresh automatically in 

the given period.  

 You can refresh an external data range automatically when you open the workbook if the 

checkbox “Refresh data when opening the file” is ticked. Moreover, if the “Remove data 

from the external data range before saving the workbook” checkbox is ticked, the 

workbook is saved without external data in order to reduce file size 
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5.3.5.2 Refresh Data in an Imported File 

If your worksheet contains more than one external data range that you want to refresh, right click 

the imported data and click Refresh. 

 

5.3.5.3 Preserve Cell Formatting when you Refresh an External Data 

Range 

1. Select the data, then choose Data tab, Queries & Connections group, select Properties. 

 

2. Do one or both of the following under Data formatting and layout section: 

 If you want to preserve cell formatting that you apply, select the Preserve cell formatting 

check box.  

 If you want to preserve column widths that you set, clear the Adjust column width check 

box. 

3. Click [OK].  

4. To refresh the external data range, right click the imported data and click Refresh. 
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6. Collaboration and Security 

6.1 Introduction 

It has always been possible to share Excel files on a network. You just had to make sure that you 

coordinated your efforts to avoid having more than one person open a file at the same time. 

6.2 Shared Workbook 

6.2.1 Enabling the Shared Workbook Feature 

In the Excel Options, click the Customize Ribbon button on the left. To add the Data Form option, 

change the drop-down list to All Commands and add the following commands. 

 Share Workbook (Legacy) 

 Trace Changes (Legacy) 

 Protect and Share Workbook (Legacy) 

 Accept/Reject Change 

 

Once you click [OK] button, the command will be added to the tab. 
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6.2.2 Share Workbook 

1. Create a new workbook or open an existing workbook. Then place it on a network location. 

For example, put it on a location like \\server_name\folder_name. Then choose Share 

Workbook (Legacy). 

2. Select “Use the old-shared workbooks features instead of the new co-authoring 

experience” and click [OK]. Only one user is allowed to change the workbook by default. You 

can change some aspects of the default behavior of shared workbooks. Each shared workbook 

user can set these options individually. Use the first section on the Advanced tab to specify the 

length of time you want to keep track of changes, or whether you want to track them at all 

   

3. If this is a new workbook, type a name in the File name box. If this is an existing workbook, 

click [OK] to save the workbook. When you're done, “- Shared” will appear at the top of the 

Excel window, next to the filename. 

 

6.2.3 Tracking 

Excel can maintain and display information about how a worksheet was changed. Change tracking 

logs details about workbook changes each time you save a workbook. You can use this history to 

understand what changes were made, and to accept or reject revisions. 

This capability is particularly useful when several users edit a workbook. It's also useful when you 

submit a workbook to reviewers for comments, and then want to merge input into one copy, 

selecting which changes and comments to keep 
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6.2.3.1 Highlight Changes 

You can decide at any time to go through each change that has been made to the shared workbook, 

provided the “Track changes while editing. This also shares your workbook” check box was 

selected in the Highlight Changes dialog box when the worksheet was first saved for sharing.  

1. Select Track Change (Legacy) ➔ Highlight Changes…, define When, Who and Where do 

you wish to review in the Highlight Change dialog box.  

 

2. The list for the change will be displayed in color for indication.  

 

3. If the List changes on a new sheet checkbox is select, the selected changes will be displayed 

in a report in a new worksheet. 

 

6.2.3.2 Accept or Reject Changes 

1. Select Track Change (Legacy) ➔ Accept/Reject Changes, define when, who and where do 

you wish to review in the Select Changes to Accept or Reject dialog box. 
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2. Then you can accept or reject each change one by one. 

 

6.2.4 Protect Tracking Changes 

Change tracking in Excel is closely linked with shared workbooks.  

1. Select Protect Shared Workbook (Legacy).  

 

2. If you click Sharing with track changes and then click [OK], change tracking for the shared 

workbook is protected so no one in your workgroup can turn it off directly. However, anyone 

can turn off the protection. To eliminate this possibility, you can enter a password in the 

Protect Shared Workbook dialog box. But you must do this when the workbook is not in 

shared mode. Then anyone who tries to turn off protection must enter the identical, 

case-sensitive password. 

6.2.5 Unsupported Features  

Please be aware that Shared Workbooks is an older method of sharing. Therefore, many items and 

actions are not supported when this method is used. 

Unsupported Items Unsupported Actions 

Creating or inserting tables Inserting or deleting blocks of cells 

Adding or changing conditional formats Deleting worksheets 

Adding or changing data validation Merging cells or splitting merged cells 

Creating or changing charts or 

PivotChart reports 
Sorting or filtering by format 

Inserting or changing pictures or other 

objects 
Using drawing tools 

Inserting or changing hyperlinks Assigning, changing, or removing passwords 

Creating, changing, or viewing scenarios Protecting or unprotecting worksheets or the workbook 

Inserting automatic subtotals Grouping or outlining data 
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Creating data tables Writing, recording, changing, viewing, or assigning macros 

Creating or changing PivotTable reports Changing or deleting array formulas 

Creating or applying slicers Adding, renaming, or deleting XML maps 

Creating or modifying sparklines Mapping cells to XML elements 

Adding or changing Microsoft Excel 4 

dialog sheets 

Using the XML Source task pane, XML toolbar, or XML commands 

on the Data menu 

 Using a data form to add new data 

Adding threaded comments Editing, or deleting threaded comments 

6.3 Protecting Files 

Excel features related to hiding data or locking data with passwords are not intended to secure or 

protect confidential information in Excel. These features are merely meant to obscure data or 

formulas that might confuse some users or to prevent others from viewing or making changes to 

that data. Excel does not encrypt data that is hidden or locked in a workbook. To help prevent 

modification of confidential data and to help protect it from being viewed, you may want to limit 

access to any workbook files that contain such information by storing them in locations that are 

available only to authorized users. Excel provides several layers of security and protection to 

control who can access and change your data: 

 For optimal security, you should protect your entire workbook file with a password, allowing 

only authorized users to view or modify your data. 

 For additional protection of specific data, you can protect certain worksheet or workbook 

elements, with or without a password. Use element protection to help prevent anyone from 

accidentally or deliberately changing, moving, or deleting important data. 

6.3.1 Securing a Workbook file 

Password security at the workbook file level uses advanced encryption to help protect your 

workbook from unauthorized access.  

1. Select File ➔ Save As, and then select Tools ➔ General Options in the Save As dialog. 
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2. You can specify two separate passwords that users must type to and then save the workbook. 

 Password to open – This password is encrypted to help protect your data from 

unauthorized access. 

 Password to modify – This password is not encrypted and is only meant to give specific 

users permission to edit workbook data and save changes to the file. 

 

6.3.2 Protecting Specific Worksheet or Workbook Elements 

When you share an Excel file so that others can collaborate on the data, you can prevent any user 

from making changes to specific worksheet or workbook elements by protecting (or locking down) 

certain parts of the file. You can also specify a password to allow individual users to modify specific 

elements.  

When you protect a worksheet, all cells on the worksheet are locked by default, and users cannot 

make any changes to a locked cell. For example, they cannot insert, modify, delete, or format data 

in a locked cell. You can, however, specify which elements users will be allowed to change when 

you protect the worksheet. 

6.3.2.1 Protect Worksheet 

To protect a worksheet, select Review group, Change Tab, Protect Sheet. You can control access to 

individual worksheet or chart sheet elements by selecting or clearing the following check boxes 
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6.3.2.2 Protect Workbook 

To protect a workbook, select Review group, Change Tab, Protect Workbook. You can control 

access to entity workbook by selecting or clearing the following check boxes. 

 

6.3.3 Permission to Access Specific Areas of a Protected Worksheet 

Before you protect a worksheet, you can unlock the ranges that you want users to be able to change 

or enter data in. You can:  

 Unlock cells for all users on the Protection tab of the Format Cells dialog box by choosing 

Format ➔ Cells. 

 

 Unlock cells for specific users in the Allow Users to Edit Ranges dialog box by choosing 

select Review group, Change Tab, Allow Users to Edit Ranges. 
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Users whom you specify in the Permissions for range dialog box (Permissions button) can 

automatically edit the range without entering the password. All other users are prompted for the 

password when they want to edit the range.  

6.4 Recover Unsaved Excel Sheet 

To save your effort and to save you from mess, there is a wonderful feature which will 

automatically keep saving your Excel sheet at certain interval of time and will maintain revisions of 

the same. 

1. To ensure that Auto Save option is turned on in your Excel, just click on the File ➔ Options. 

On the Excel Options Window, Click the Save tab at the left hand pane. In the “Save 

Workbooks” option, ensure that the option “Save AutoRecover information” is enabled. 

Default time for saving is 10 minutes, you can increase or decrease it as per your needs. When 

this option is enabled and you have been working on an Excel Sheet for 10 minutes or more 

and you close it by mistake, you can recover up to last 5 AutoSave revisions of the same. 

 

2. To recover an AutoSave version of an excel sheet, click File ➔ Info and check out the 

Version and Manage Version option. Some important points related to AutoSave Feature are: 

 Access up to the last five AutoSave versions of your previously saved active workbook. If 

you save and close your workbook, all AutoSave versions will automatically be deleted. If 

you close a previously saved workbook without saving, your last AutoSave version is kept 

until your next editing session.  
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 Recover workbooks that were never previously saved. Unsaved workbooks are saved for 

four days before they are automatically deleted.  

 

 


