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1. Introduction 

1.1 Overview 

Charting or graphing of data makes it easier to understand a trend about presentation of data. Many 

of us need to create such graphs, charts or visual charts like pie chart. It is often complicated to 

understand and create charts with conventional tools or software. In Microsoft Excel, a chart is 

often called a graph. It is a visual representation of data from a worksheet that can bring more 

understanding to the data than just looking at the numbers. 

You can create a chart on its own sheet or as an embedded object on a worksheet. You can also 

publish a chart on a Web page. To create a chart, you must first enter the data for the chart on the 

worksheet. Then create a basic chart that you can format later. 

1.2 How to Create Charts? 

Select the cells you want to chart, including the column titles and row labels. These cells will be the 

source data for the chart. Make sure that there is some data in Excel worksheet and does not contain 

any blank cells between the different columns, then click the Insert menu and choose the chart type 

that you wish to draw.  
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Besides, the snappiest way to create a chart is to select some data and press [F11] button. 

 

The data in your Excel sheet will be organized as a chart. You can change the attributes by 

right-click the chart and adjusting the options for changing chart types, data, and other formatting. 

1.3 Chart Tools 

The Chart Tools menu allows you to modify the design, layout and formatting of the chart and the 

table. You can tweak many options related to the charts like layouts, formatting, design, chart type, 

displaying data, legends, color scheme etc. 

 

In the Design option in the charting area, you can select other options line graph, pie chart for 

different kind of representation of the data.  
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2. Enhancing Chart Appearance 

2.1 Working with Titles 

2.1.1 Formatting a Title 

To change the font, color, border, background, or alignment of a title, you can right-click it and 

choose Format Chart Title to access the Format Chart Title dialog box, 

The idea of a diagonal chart title might seem silly at first. However, you can drag the title onto the 

plot area if you want. A slanted title on the plot area can make a stylish chart annotation.  

 

2.1.2 Formatting Individual Characters in a Title 

By formatting title characters individually, you can make your titles look like ransom notes. One 

possible use for individual-character formatting is the characters in the word up have been elevated 

via the superscript option.  

To change the appearance of one or more characters in a title, select the title, pause, and then select 

the characters you want to change. The dialog box that appears has only a Font tab. In other words, 

you can’t change the background characteristics of selected characters. 
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2.2 Working with Gridlines 

Excel automatically adds gridlines, but you can delete them if you decide they're not essential and 

reduce clutter in the process. Select Format Gridlines after right clicking the chart. 

 

2.3 Working with Data Labels 

If you delete gridlines, but feel a little insecure without them, you can show your audience the exact 

number of values by the data labels above each column. To add data labels, you could first add the 

data label and then format it. 

  

2.4 Change Colors and Use Fill Effects 

Excel formats the plot area a standard gray color. But you can choose another color, use no color at 

all, or go wild and use pink or purple for the plot area if that's right for your chart. But your chart 

will have a professional look even if you use plain white when you use fill effects.  

To use a gradient fill, you'd select the plot area, right-click, select the Format Plot Area and 

Format Data Series on the shortcut menu, select Fill, and then select a color.  
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A gradient fill was also used for each data series to give the colors some shading and depth. The 

darkest color represents Peacock, whose sales in February were the highest for the quarter, to draw 

attention to her achievement. The gradient fills define each column well enough that borders around 

each column weren't necessary and could be deleted. 

In general, avoid putting two dark colors next to each other. The contrast between light and dark 

adds extra emphasis to your data and makes it easier to see the differences between the different 

data series. Greater contrast between colors will also help anyone in your audience who may be 

color blind to read your charts. 

 

2.5 Chart Plot Area 

The area that is covered by a specific chart is called the chart plot area. By default, Excel draws 

charts according to the default configuration, but it’s very easy to edit the plot area, simply 

right-click the chart and choose the Format Plot Area option. Now you will see a dialogue box 

which lets you set the chart’s fill style, borders, Glow and soft Edges, and 3-D effects. 
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3. Working with Chart Data 

3.1 Adding Data 

Excel provides several ways to add data to a chart. Excel drew two rectangles around the chart’s 

source data after the plot area is selected. The first rectangle outlines the worksheet range that the 

chart is using for its category-axis labels. The second rectangle outlines the data series. Excel uses 

blue for the first rectangle and purple for the second, to help you distinguish the two. 

3.1.1 Using Copy and Paste 

You can use standard copy-and-paste procedures if your chart and its data are close together on the 

same worksheet. Select the new data, and then choose Copy. Next, select the chart, and choose 

Paste.  

To extend the chart so that it includes the new data, drag the Fill handle in the lower right corner of 

either rectangle. Alternatively, you can use drag-and-drop by selecting the new data, including its 

category-axis labels. Position your mouse on the border of the selection so that the mouse pointer 

changes to an arrow. Then drag the selection and drop it anywhere on the chart. Excel confirms the 

addition by extending the rectangles to include the new data. 
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3.1.2 Adding Series 

Adding a new series is like adding new points to existing series: Select the data series you want to 

add, copy it, and then paste it onto the chart. If the new data series is adjacent to the existing data, 

Excel has no difficulty figuring out that you want to add a new series rather than some new points.  

 

3.2 Removing Data 

The simplest way to remove a data series from a chart is to select the series on the chart itself and 

press [Delete]. This method works even if you’ve refined the selection to a single point in the series; 

delete that point and the whole series is gone. If you try to delete the series by clearing or deleting 

the source data on the worksheet, your chart will still reference the empty or nonexistent cells. 

To delete points from either end of all the series in a chart, select the chart area or the plot area, and 

then drag the Fill handle at one of the corners of either the purple or blue bounding rectangle that 

surrounds your data. To remove points from a particular series, select that series, and then drag the 

blue Fill handle. 

3.3 Changing or Replacing Data 

If you drag the lower or upper perimeter of a data-bounding rectangle, rather than its Fill handle, 

Excel moves both the start and endpoint of your series. This can be an effective way to obtain 

detailed views of a chart’s data across the whole range of available data. To switch to an entirely 

different set of data, select any part of your chart, and then choose Source Data. You can adjust the 

entire chart at once (all series) by using the Data Range box on the Data Range tab, or you can 

work with individual series on the Series tab. 
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3.4 Changing the Plot Order 

To change the order in which series are plotted, select any series and choose Selected Data Source. 

Use the Move Up and Move Down buttons to manipulate the series order. 

 

3.5 Adding Trend Lines 

A trend line is a line that describes the general tendency of a data series. To add a trend line to a 

series in an area, bar, column, line, or xy (scatter) chart, first select the series, and then choose Add 

Trendline. If you select Polynomial, indicate the highest power for the independent variable in the 

adjacent Order box. If you select Moving Average, indicate the number of periods should use in its 

calculations in the adjacent Period box. After you’ve indicated the type of trend or regression line, 

select the Options tab if you want a name for the trend line to appear in the chart legend. For linear, 

polynomial, and exponential trend lines, you can also set the y-intercept in the Set Intercept box. 

You can also display the regression equation and the R-squared value beside the trend line plot. 
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3.6 Error Bars 

Error bars express potential error amounts that are graphically relative to each data point or data 

marker in a data series. For example, you could show 5 percent positive and negative potential error 

amounts in the results of a scientific experiment: 

 

You can add error bars to data series in a 2-D area, bar, column, line, xy (scatter), and bubble charts. 

For xy (scatter) and bubble charts, you can display error bars for the x values, the y values, or both. 

3.6.1 Add Error Bars 

1. Selected data point or data series, click the data point or data series that you want, or do the 

following to select it from a list of chart elements: 

2. On the Layout tab, in the Analysis group, click Error Bars. Click a predefined error bar 

option, such as Error Bars with Standard Error, Error Bars with Percentage, or Error 

Bars with Standard Deviation. 
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3. Besides, you can click More Error Bar Options, and then under Vertical Error Bars or 

Horizontal Error Bars, click the display and error amount options that you want to use. 

3.6.2 Change Error Bar Settings 

1. On a chart sheet or in an embedded chart, click the error bar or data series that has the error 

bars that you want to change. When you select an error bar, any changes that you make affect 

all of the error bars in its associated data series. 

2. On the Format menu, click Selected Data Series.  

3. Click the Y Error Bars tab or the X Error Bars tab, depending on the type of error bars that you 

want to change, and then do one or more of the following:  

 To select a different type of error bar, click the type that you want under Display.  

 To change the method used to determine the error, select the method that you want under 

Error amount.  

 To change a custom error amount, click Custom. In the Plus and Minus boxes, specify the 

worksheet range to use as error amount values, or enter the values that you want to use, 

separated by commas, for example, 0.4, 0.3, 0.8.  
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3.6.3 Remove Error Bars 

On a chart sheet or in an embedded chart, click any error bar to remove all error bars in a data series, 

and then press [Delete]. Or you can right-click an error bar, and then click Clear. 

You can also remove error bars immediately after you add them to the chart by clicking Undo on 

the Edit menu, or by pressing [Ctrl] + [Z]. 
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4. Most Popular Chart Type 

4.1 Column Chart 

4.1.1 Column Chart 

Column charts are a good way to show change over time because it's easy to compare column 

lengths. Like bar charts, column charts can be used to plot both nominal data and ordinal data, and 

they can be used instead of a pie chart to plot data with a part-to-whole relationship. 

Column charts work best where data points are limited (i.e. 12 months, 4 quarters, etc.). You can 

switch to a line graph with more data points. 

 

Pros 

 Easy to read 

 Simple and versatile 

 Easy to add data labels at ends of bars 

Cons 

 Become cluttered with too many categories 

 Clustered column charts can be difficult to interpret 

4.1.2 Stacked Column Chart 

Stacked column chart allows part-to-whole comparisons over time, or across categories. In a 

stacked column chart, data series are stacked one on top of the other in vertical columns. 

Stacked column charts can show change over time because it's easy to compare total column lengths. 

However, except for the first series of data (next to the x-axis) and total bar length, it's difficult to 

compare the relative size of the components that make up each bar. As categories or data series are 

added, stacked column charts quickly become complicated. 
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Pros 

 Multiple categories and data series in compact space 

 Can show change over time 

Cons 

 Difficult to compare all but first series 

 Become visually complex as categories or series are added 

4.1.3 100% Stacked Column Chart 

A 100% stacked column chart show the relative percentage of multiple data series in stacked 

columns, where the total (cumulative) of stacked columns always equals 100%. The chart can show 

the part-to-whole proportions over time, for example the proportion of quarterly sales per region or 

the proportion of monthly mortgage payment that goes toward interest vs. principal. 

Although stacked column charts can show the change over time of a part-to-whole relationship, it's 

generally difficult to compare the relative size of the components that make up each column.  
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Pros 

 Multiple categories and data series in compact space 

 Can show part-to-whole changes over time 

Cons 

 Difficult to compare all but first series 

 Become visually complex as categories or series are added 

4.1.4 Clustered Column Chart 

A clustered column chart displays more than one data series in clustered vertical columns. Each data 

series shares the same axis labels, so vertical bars are grouped by category. Clustered columns allow 

the direct comparison of multiple series, but they become visually complex quickly. They work best 

in situations where data points are limited. 

 

Pros 

 Allow direct comparison of multiple data series per category 

 Can show change over time 

Cons 

 More difficult to compare a single series across categories 

 Become visually complex as categories or series are added 

4.2 Bar Chart 

4.2.1 Bar Chart 

A bar chart is a good choice for categorical data. Bar charts plot data using horizontal bars, so they 

are very easy to read because the human eye can easily compare bars. Also, because of the 

horizontal layout, bar charts have room to accommodate longer category names. 

Bar charts are also versatile. They can be used to plot both nominal data and ordinal data, and they 

can be used instead of a pie chart to plot data with a part-to-whole relationship. If you're trying to 

decide on a chart type, a bar chart is a good first choice. 



   Chapter 2 

Essential Excel Skill for Job Hunting @ Peter Lo 2023 15 

 

Pros 

 Very easy to read 

 Versatile 

 Easy to add data labels at ends of bars 

 Room for longer text labels 

Cons 

 Become cluttered with too many categories 

 Clustered bar charts are harder to read as data series are added 

4.2.2 Stacked Bar Chart 

A stacked bar allows comparison of components across categories. Data is plotted using horizontal 

bars stacked from left to right. Stacked bar makes it easy to compare total bar lengths. However, 

except for the first series of data (next to the axis) it's more difficult to compare the relative size of 

the components that make up each bar. Also, as categories or data series are added, stacked column 

charts quickly become visually complex. 
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Pros 

 Multiple categories and data series in a compact space 

 Able to show change over time of category sub-components 

Cons 

 Difficult to compare all but first series 

 Become visually complex as categories or series are added 

4.2.3 100% Stacked Bar Chart 

A 100% stacked bar chart designed to show the relative percentage of multiple data series in stacked 

bars, where the total (cumulative) of each stacked bar always equals 100%. Like a pie chart, a 100% 

stacked bar chart shows a part-to-whole relationship. However, unlike a pie chart, a 100% stacked 

bar chart can show how proportions change over time, for example, product market share changes 

per year, as shown above. 

Like all stacked bar charts, the first data series (next to the axis) is easy to compare visually, but 

subsequent data series are harder to compare, since they aren't aligned to a common element.  

 

Pros 

 Able to show part-to-whole changes over time 

 Multiple categories and data series in compact space 

Cons 

 Difficult to compare all but first series 

 Stacked bars normalized to 100% so absolute value dimension is lost 

 Become visually complex as categories or series are added 

4.2.4 Clustered Bar Chart 

A clustered bar chart displays more than one data series in clustered horizontal columns. Each data 

series shares the same axis labels, so horizontal bars are grouped by category. Clustered bars allow 

the direct comparison of multiple series in a given category, but it's more difficult for the human eye 

to compare the same data series across categories. 
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Like clustered column charts, clustered bar charts become visually complex as the number of 

categories or data series increase. They work best in situations where data points are limited. 

 

Pros 

 Allow direct comparison of multiple data series per category 

 Can show change over time 

Cons 

 More difficult to compare a single series across categories 

 Become visually complex as categories or series are added 

4.3 Line Chart 

4.3.1 Line Chart 

A line chart plots each data series as a separate line. Line charts are a good way to show change or 

trends over time. In contrast to column or bar charts, line charts can handle more categories and 

more data points without becoming too cluttered. Line charts can be customized to show or hide 

data markers of various shapes and sizes. 
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Pros 

 Simple presentation; easy to read and create 

 Clean presentation of multiple data series with many data points 

 Good for showing trends over periods of time 

 Can handle positive and negative values 

Cons 

 Harder to read when lines overlap frequently 

 Line can imply more data than actually available (compared to bar or column chart) 

4.4 Pie Chart 

4.4.1 Pie Chart 

The Pie chart expresses a "part to whole" relationship, where all pieces together represent 100%. 

Pie charts work best to display data with a small number of categories (2-5). For example, survey 

questions in yes/no format, data split by gender, new and returning visitors to a website, etc. 

Pie charts should be avoided when there are many categories, or when categories do not total 100%. 

The human eye has trouble comparing the relative size of slices in a pie chart, so pie charts should 

also be avoided when slices are similar, unless similarity is the point. 

 

Pros 

 Simple, compact presentation 

 Can be read "at a glance" with limited categories 

 Excel can calculate % values automatically 

Cons 

 Difficult to compare relative size of slices 

 Become cluttered and dense as categories are added 

 Limited to part-to-whole data 

 Poor at showing change over time 
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4.4.2 Doughnut Chart 

Doughnut charts expressess a "part-to-whole" relationship, where all pieces together represent 

100%. Doughnut charts work best to display data with a small number of categories (2-5). For 

example, you could use a doughnut chart to plot survey questions with a small number of answers, 

data split by gender, Windows vs. Mac users, or other data where categories are limited. 

Doughnut charts should be avoided when there are many categories, or when categories do not sum 

to 100%.  

 

Pros 

 Simple, compact presentation 

 Can be read "at a glance" 

 Excel will calculate percentages automatically 

Cons 

 Difficult to compare relative size of slices 

 Become cluttered and dense as categories are added 

 Limited to part-to-whole data 

 Poor at showing change over time 

4.4.3 Pie of Pie Chart 

The Pie of Pie Chart provides a way to add additional categories to a pie chart without generating a 

pie chart too complex to read. Excel provides a setting that moves the smallest n slices of the pie to 

another smaller pie, where n can be adjusted to suit the data. 

Pie of pie charts should be avoided when there are many categories, or when categories do not total 

100%. The human eye has trouble comparing the relative size of slices in a pie chart, and this 

problem is compounded with the pie of pie variety. 
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Pros 

 A simple way to handle more categories in a pie chart 

 Can be read "at a glance" with limited categories 

 Excel can calculate and display percentages automatically as data labels 

Cons 

 Difficult to compare relative size of slices 

 Become cluttered and dense as categories are added 

 Limited to part-to-whole data 

 Poor at showing change over time 

4.4.4 Bar of Pie Chart 

A Bar of Pie Chart is a type of pie chart that has a bar attached to it. This bar expands a group of 

values that can't be shown on the same pie chart.  

Pie chart is good for showing how much is something part of a whole. But with too many categories 

or participants, the pie chart gets confusing. We combine the smaller slices of pie chart into and 

show it as a whole pie chart, by default named another. To see who or what is the part of this other 

slice of pie chart, we use the bar of pie chart. This bar contains all the members of other groups and 

shows how that other group was created. 
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Pros 

 A simple way to handle more categories in a pie chart 

 Can be read "at a glance" with limited categories 

 Excel can calculate and display percentages automatically as data labels 

Cons 

 Difficult to compare relative size of slices 

 Become cluttered and dense as categories are added 

 Limited to part-to-whole data 

 Poor at showing change over time 

4.5 Area Chart 

4.5.1 Area Chart 

Area charts are much like line charts, but they display different colors in the areas below the lines. 

This colorful and visual display distinguishes the data more clearly. Area charts are a good way to 

show change over time with one data series. They offer a simple presentation that is easy to 

interpret at a glance. 

 

Pros 

 Simple presentation; easy to read and create 

 Good for showing trends over periods of time 

 Can handle positive and negative values 

Cons 

 Don't usually work well for multiple data series 

 Line can imply more data than actually available (compared to bar or column chart) 

4.5.2 Stacked Area Chart 

A Stacked Area Chart shows data series plotted with filled areas stacked, one on top of the other. A 

stacked area chart can show how part to whole relationships change over time. They offer a simple 

presentation that is easy to interpret at a glance. 
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Pros 

 Simple presentation can be red at a glance 

 Can show part to whole changes over time 

Cons 

 Generally harder to add data labels since there is less white space available 

 Area charts can imply more data than actually available 

4.5.3 100% Stacked Area Chart 

A 100% Stacked Area Chart plot data as areas and stacked so that the cumulative area always 

represents 100%. Stacked Area charts can show a progression and composition over time, and the 

100% Stacked Area Chart is meant to show the percentage that each component contributes when 

the cumulative total is not important. 

 

Pros 

 Can show trends over periods of time 

 Can show component contribution changes over time 
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Cons 

 Non-intuitive presentation may be unfamiliar to many 

 Hard to read as data series are added 

4.6 XY (Scatter) Chart 

4.6.1 Scatter Plot 

A Scatter Plot shows the relationship between two variables. A scatter plot works by placing one 

variable on the vertical axis and a different variable on the horizontal axis. Each piece of data is 

then plotted as a discrete point on the chart. In a scatter plot, both the X and Y axis display values – 

an XY chart has no category axis. 

By convention, the X axis represents arbitrary values that do not depend on another variable, 

referred to as the independent variable. Y values are placed on the vertical axis and represent the 

dependent variable. 

 

Pros 

 Can show the relationship of one variable to another 

 Visual display of correlation 

 Ideal for many types of scientific data 

Cons 

 Not as well understood as many other chart types 

 Suitable only for data where correlation is expected 

4.6.2 Bubble Chart 

A Bubble chart is a variation of a scatter chart in which the data points are replaced with bubbles. A 

Bubble chart can be used instead of a scatter chart if your data has three data series, each of which 

contains a set of values. In a Bubble chart, the size of the bubbles is determined by the values in the 

third data series. 
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Pros 

 Can show the relationship of one variable to another 

 Unique ability to show data about a third dimension  

 Can visually display correlation 

Cons 

 Unusual chart type may be difficult to ready for many people 

 More difficult to set up than other chart types 

4.7 Stock Chart 

4.7.1 Candlestick Chart 

A Candlestick chart used to show stock price activity. You'll find this chart under the Stock category 

of chart types, with the name Open-High-Low-Close, sometimes abbreviated OHLC. 

This chart type automatically plots the full range of values as a single line, with indicates high and 

low in a given time interval. On top of the line is a bar which indicates open and close values. Dark 

bars indicate the close price is less than open price (loss), light bars indicate a close price greater 

than open price (gain). 
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Pros 

 Quickly plot stock data in open high low close format 

 At a glance indication of stock price activity 

Cons 

 Not as well understood as many other chart types 

 A specific chart type mostly seen in the financial world 

4.8 Surface Chart 

Surface Chart displays a set of three-dimensional data as a mesh surface. It is useful when you need 

to find the optimum combinations between two sets of data. 

Surface charts are common for temperature analysis. The chart works on numbers and requires at 

least two series for its generation. The chart allows easy visualization-based analysis as it rests on 

the idea of three dimensions. The crucial elements of a surface chart are dimension values or 

categories that are represented on the x-axis, the measure in the context which is represented by the 

y-axis, and the third axis i.e. z-axis represents different series in the given context. 

 

Pros: 

 3d allows you to see objects from different angles, or perspectives. 

 3d illustrations offers more depth due to its added dimension. 

Cons: 

 Time-based 3d charts are harder to read. 

 3d charts don’t automatically add anything new to your existing charts. 

4.9 Radar Chart 

The Radar Charts, sometimes called spider charts, have one axis per category which all use the 

same scale. The axes of a radar chart radiate out from the center of the chart and data points are 

plotted on each axis using a common scale. The result is a geometric shape that shows "at-a-glance" 

performance across all categories. 

Radar charts can be used to plot the performance of employees, athletes, products, and companies in 

various categories. They can be used for performance evaluations and satisfaction surveys. 
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Pros 

 Compact presentation 

 Can show at-a-glance strength or weakness 

 Can handle more than one data series 

Cons 

 Unusual chart type may confuse audience 

 More difficult to read for most people 

4.10 Treemap Chart 

A treemap chart displays hierarchical data in rectangles proportionally sized according to the 

amount of data in each category. Treemap charts are lacking many of the controls available in other 

chart types, but they are an interesting way to quickly visualize certain kinds of data. 

 

Pros 

 Quick visualization of hierarchical data 

 At-a-glance breakdown data in categories 
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Cons 

 Data must be sorted by category 

 Missing many of the options available in other chart types 

4.11 Sunburst Chart 

A sunburst chart is used to display hierarchical data in a circular format where each level of the 

hierarchy is represented as a ring. Top level categories make up the inner ring, and sub-categories 

are plotted as outer rings. Segments in each ring are sized proportionally using a value series. Like a 

treemap chart, the sunburst chart can be used to compare relative sizes. 

 

Pros: 

 Quick visualization of hierarchical data 

 At-a-glance breakdown of data in categories 

Cons: 

 Data must be sorted by category 

 Limited options for controlling format and presentation 

4.12 Histogram 

4.12.1 Histogram 

A histogram is a visual representation of the distribution of numerical data. It is a special kind of bar 

graph where bars represent bins that group together values at specific intervals. The height of each 

bar shows the proportion of values in that bin. Typically, there are no gaps between bins to represent 

continuous data. 
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Pros 

 At-a-glance visualization of the distribution of numerical data 

Cons 

 Less common chart type not as familiar to many people 

 Built-in histogram chart type has limited options 

4.12.2 Pareto Chart 

A Pareto chart is a variant of the histogram chart, arranged in descending order for easy analysis. 

The sequencing is performed automatically, and a separate line is added on a secondary axis to 

make it easy to see contribution toward 100% as columns are plotted to the left. 

Pareto charts highlight the biggest factors in a set of data. Following the idea of 80/20 analysis, they 

try to show which (approximately) 20% of the categories contribute 80% of the data being 

measured. They are often used in process improvement to show which factors deserve the most 

attention. 
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Pros 

 Quickly highlights most important data 

 Excel automatically builds histogram and adds Pareto line 

Cons 

 Less common chart type may be difficult to ready for many people 

 Built-in Pareto Chart is not as easy to customize as a standard combo chart 

4.13 Box and Whisker Chart 

A box and whisker chart shows distribution of data into quartiles, highlighting the mean and outliers. 

The boxes may have lines extending vertically called “whiskers”. These lines indicate variability 

outside the upper and lower quartiles, and any point outside those lines or whiskers is considered an 

outlier. 

Box and whisker charts are most commonly used in statistical analysis. For example, you could use 

a box and whisker chart to compare medical trial results or teachers' test scores. 

 

Pros 

 Handles large data easily 

 Clear summary 

 Display outliner  

Cons 

 Exact values not retained 

4.14 Waterfall Chart 

Waterfall charts are used to plot the cumulative result of values as a visual running total. The initial 

and final values sit directly on the horizontal axis and intermediate values are plotted as floating 

columns - positive values extend upward, and negative values extend downward. The effect is a 

staircase like display is useful for showing how an initial value is affected by subsequent positive 

and negative changes. Waterfall charts are sometimes called bridge charts. 
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Pros 

 At-a-glance visual display of positive and negative changes 

Cons 

 Less common chart type not as familiar to many people 

 Built-in waterfall chart type has limited options 

4.15 Combo Chart 

A Combo Chart is a hybrid of two more chart types, for example, a column chart plus a line chart. 

 

Pros 

 Able to display multiple chart types in a single chart 

 Able to plot values with completely different sales 

 Can show how one factor is influenced by another 

Cons 

 Inherently more complex than other chart types 

 Can become complicated quickly 
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5. Advanced Charting Skill 

5.1 Histogram 

5.1.1 Importance of a Histogram 

Creating a histogram provides a visual representation of data distribution. Histograms can display a 

large amount of data and the frequency of the data values. The median and distribution of the data 

can be determined by a histogram. In addition, it can show any outliers or gaps in the data. 

5.1.2 Distributions of a Histogram 

5.1.2.1 Normal Distribution:  

In a normal distribution, points on one side of the average are as likely to occur as on the other side 

of the average. 

 

5.1.2.2 Bimodal Distribution 

In a bimodal distribution, there are two peaks. In a bimodal distribution, the data should be 

separated and analyzed as separate normal distributions. 

 

5.1.2.3 Right-skewed Distribution 

A right-skewed distribution is also called a positively skewed distribution. In a right-skewed 

distribution, a large number of data values occur on the left side with a fewer number of data values 

on the right side. A right-skewed distribution usually occurs when the data has a range boundary on 

the left-hand side of the histogram. For example, a boundary of 0. 
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5.1.2.4 Left-skewed Distribution 

A left-skewed distribution is also called a negatively skewed distribution. In a left-skewed 

distribution, a large number of data values occur on the right side with a fewer number of data 

values on the left side. A right-skewed distribution usually occurs when the data has a range 

boundary on the right-hand side of the histogram. For example, a boundary such as 100. 

 

5.1.2.5 Random Distribution 

A random distribution lacks an apparent pattern and has several peaks. In a random distribution 

histogram, it can be the case that different data properties were combined. Therefore, the data 

should be separated and analyzed separately. 
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5.1.3 How to create a Histogram? 

A histogram is a common data analysis tool in the business world. It’s a column chart that shows the 

frequency of the occurrence of a variable in the specified range. 

1. Select the entire dataset and insert a Histogram. 

 

2. In order to configure histogram bins, right-click the horizontal axis of the chart, click Format 

Axis, and then click Axis Options. 
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3. Use the information in the following table to decide which options you want to set in the Format 

Axis task pane.  

Option Description 

By Category This option is used when you have text categories. This could be useful 

when you have repetitions in categories, and you want to know the sum 

or count of the categories. For example, if you have sales data for items 

such as Printer, Laptop, Mouse, and Scanner, and you want to know the 

total sales of each of these items, you can use the By Category option. 

Automatic This is the default setting for histograms. The bin width is calculated 

using Scott’s normal reference rule. 

Bin width Here you can define how big the bin should be. Enter a positive decimal 

number for the number of data points in each range. 

Number of bins Here you can specify how many bins (including the overflow and 

underflow bins) you want. It will automatically create a chart with that 

many bins. 

Overflow bin Select this check box to create a bin for all values above the value in the 

box to the right. To change the value, enter a different decimal number 

in the box. 

 

Underflow bin Select this check box to create a bin for all values below or equal to the 

value in the box to the right. To change the value, enter a different 

decimal number in the box. 
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5.2 Bubble Chart 

5.2.1 When to use a Bubble chart 

Bubble charts are often used to present financial data. Use a Bubble chart when you want specific 

values to be more visually represented in your chart by different bubble sizes. Bubble charts are 

useful when your worksheet has any of the following types of data: 

 Three values per data point – Three values are required for each bubble. These values can be 

in rows or columns on the worksheet, but they must be in the following order: x value, y value, 

and then size value.  

 Negative values – Bubble sizes can represent negative values, although negative bubbles do 

not display in the chart by default. You can choose to display them by formatting that data 

series. When they are displayed, bubbles with negative values are colored white (which cannot 

be modified) and the size is based on their absolute value. Even though the size of negative 

bubbles is based on a positive value, their data labels will show the true negative value.  

 Multiple data series – Plotting multiple data series in a Bubble chart (multiple bubble series) 

is similar to plotting multiple data series in a Scatter chart (multiple scatter series). While 

Scatter charts use a single set of x values and multiple sets of y values, Bubble charts use a 

single set of x values and multiple sets of both y values and size values. 

5.2.2 Create a Bubble Chart 

1. Select the data (without heading). Then choose Insert ➔ Recommend Chart. In the chart 

type XY (Scatter), select Bubble under sub-type. 
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2. In order to add the data label, select the data series, right click and select Add Data Labels ➔ 

Add Data Labels. 

 

3. Right click the data series and select Format Data Labels. Select “Value From Cells” in Label 

Option. 

 

4. Select the data label range 
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5. Uncheck “Y Value” for showing region only in data label 

 

6. If the checkbox "Vary Colors by points" is ticked, then all bubble will be painted in different 

colors. 

 

Note that smaller bubbles may be hidden by larger bubbles, making it seem that Excel has not 

drawn all of the data markers. When an entire data series contains negative bubble sizes, the series 

is not displayed by default. If you want to see the negative bubbles, select the series you want in the 

Chart Objects list on the Chart toolbar, and then click Format Data Series on the same toolbar. On 

the Options tab, select the Show Negative Bubbles check box. 
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5.2.3 Formatting Bubble charts 

There are several ways to change the format of a Bubble chart: 

 Display bubbles with a 3-D visual effect – By selecting the 3-D Bubble chart sub-type, 

bubbles are formatted with a 3-D visual appearance. A 3-D Bubble chart is 3-D in appearance 

only — it actually remains a 2-D chart type. Unlike other 2-D chart types, however, this chart 

type cannot be used in a combination chart. 

 Adjust the size of bubbles – The size of the bubbles can represent the area of the bubbles or 

the width of the bubble, which affects the relative size of one bubble to another. The Width of 

bubbles option can be used for representations such as market share between products. You can 

also scale the bubble size for a data series by specifying a percentage between 0 and 300 — the 

larger the percentage, the larger the bubbles. 

 Display error bars – To graphically express potential error amounts relative to each bubble in 

a bubble series, you can display error bars for the X values, the Y values, or both.  

 Change the color and fill effects of bubbles – You can assign different colors and fill effects 

(such as pattern, texture, and gradient) to individual bubbles or an entire bubble series.  

 Replace bubbles with pictures – You can replace each bubble or all bubbles in a series with a 

picture. The size of the picture is automatically adjusted to match the bubble size for each 

corresponding value.  

5.3 Radar Chart 

When you are presenting two-dimensional data, it is very useful to tell the story of the data set just 

by creating the radar chart. The radar chart in excel is more suitable when the exact values aren’t 

critical for a reader, but the overall chart tells some story. Each category can be easily compared, 

each along with its own axis, and overall differences are apparent by the size of each radar. 

In order to present the sales performance over a period of 10 years in a spider chart,  

1. Go to Insert ➔ Recommended Charts, select “Radar with Markers”. 
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2. Change the marker type and size in “Format Data Series”. 

 

By looking at the outset of the spider, we can clearly find out in 2016, Q1 revenue was the highest 

among all the 10 years’ revenue. And in 2015, Q1 revenue was the lowest. 

In Q2, the highest revenue was in 2015, and the lowest point is the year 2019. 

In Q3, the highest revenue was in 2013, and the lowest revenue was in 2014. 

In Q4, the highest revenue was in 2015, and the lowest revenue occurred year is 2016 

In none of the years, there is a consistent growth of the revenue over 4 quarters. There is always 

volatility in revenue generation across quarters. 

If you want to remove the line of the chart but highlight only the markers, you can use the advanced 

formatting: 
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5.4 Gauge Chart (Speedometer) 

5.4.1 Introduction 

Gauge chart is also known as speedometer chart because of its resemblance to a speedometer, 

because it resembles a speedometer it uses dials to visualize the information on the data, it is 

basically a combination of two different types of charts which are doughnut chart and pie chart, it 

can be used by creating a combo chart option in excel. 

Let’s begin by preparing our dataset. We’re going to need data points for plotting them on the gauge, 

as well as additional helper numbers to draw a needle (pointer). 

 

 Data to show: Basically, the value the dial (pointer) will be displaying. 

 Labels and value for Levels: The value ranges that represent the levels. You can think of this as 

speed values on a speedometer. Remember to add totals to last row as this total will be the 

lowest part of the half-circle gauge. 

 Helper for Pointer: The helper values which will replace our pointer. These values help us 

determine where to place the needle of the speedometer. 

− Width: The width of the needle. 

− Start: The point at which needle will start. 

− End: The value of the remaining arc of the pie. The needle is a part of a pie chart where 

the needle is only partially visible. To complete the pie chart and place the needle, the End 

value should be calculated by subtracting the width and start points from the sum of 

values of levels.  

5.4.2 Creating Gauge Chart 

1. Select the data and insert a doughnut chart for the level data. 
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2. After removing the title and the legend, you will get a chart that is a half-circle on one side, and 

the remaining parts on the other. 

 

3. The solid half will be the bottom section of the gauge, so we need to rotate the chart. Right-click 

on a colored part and click on Format Data Series. This will make the right-side panel visible for 

the chart. Set Angle of first slice to 270°. 

 

4. In order to hiding the bottom part, right-click on the bottom half and click on Fill to see the 

color options. Select No Fill to make the half-circle transparent. 
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5. Now you have the first part of your gauge. You can also add data labels to make the gauge 

easier to read.  

 

6. Use the “Category Name” as the label. Remember to remove the label for the Total in the 

half-circle part. 

 
7. Right-click on a chart area and click on Select Data.  
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8. In Select Data Source dialog, click on [Add] button. 

 

9. Select the range that contains Width, Start, End for the Series values input. Also remember to 

enter a name for Series name. 

 

10. Right click the chart, and select “Change Series Chart Type …” 
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11. Select Pie option for the pointer values and tick the “Secondary Axis” for the doughnut chart. 

 

12. Change the “Angle of first slice” to 270° for the Pie chart.  

 

13. Set the other area as “No Fill”. Then the Gauge Chart is completed. 
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5.5 Bullet Chart 

5.5.1 Introduction 

Bullet Chart is used to display key performance indicators. Use them to replace speedometers if you 

want a more compact visual that can be stacked to better compare KPI. Also, speedometers suck. 

A bullet chart has three components. 

 Target Marker: A marker to represent the target.  

 Achievement Bar: A single achievement bar to represent the actual value. This bar should have 

a solid color & little bit narrow than comparison range color bars. 

 Comparison Range: A comparison range of a color theme to use at the background of 

achievement bar. The main idea to use this range is to create a comparison for achievement, 

like stages. 

  

5.5.2 Create Bullet Chart 

1. Right click the axis and choose “Format Axis”, then change the maximum bound to “1.0”. 
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2. Right click the axis and choose “Format Axis”, then change the maximum bound to “1.0”. 

 

3. In the right panel, select Series “Target” from “Axis Options” 

  

4. Select Design ➔ Chang Chart Type. 
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5. Change the “Target” to “Stacked Line with Marker” and tick the “Secondary Axis” checkbox. 

  

6. Change the marker to bigger size rectangle. Bar with blank color fill without border. 
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7. Delete the secondary axis 

 

8. In the right panel, select Series “Achievement” from “Axis Options” 

 

9. Select “Secondary Axis” and change gap width to 500%. 

 



   Chapter 2 

Essential Excel Skill for Job Hunting @ Peter Lo 2023 49 

10. Use a solid fill black color for achievement bar. 

  

11. For creating a comparison range you have to select a color and use four different shades of that. 

For example, you can use four different gray color as follow: 

 

12. Add the “Outside” tick marks in minor type.  
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5.6 Step Chart 

5.6.1 Introduction 

Step chart is useful if you have to display the data that changes at irregular intervals and remains 

constant between the changes. For example, Step chart can be used to show the price changes of 

commodities, changes in tax rates, changes in interest rates, etc.  

A Step Chart shows the trend shows the exact time of change along with the trend of the data points 

as well. While Line Chart only shows the trend of data points, and it will not focus on the exact time 

of change or fluctuation of data points from one period to another. 

Consider the below example, both of these charts look similar, but the line chart is a bit misleading. 

It gives you the impression that the petrol prices have gone up consistently during May 2015 and 

June 2015. But if you look at the step chart, you’ll notice that the price increase took place only on 

two occasions. 

 

5.6.2 Creating Step Chart 

1. Insert two new columns with the same headers, then copy the date values from column A to 

column D by ignoring the first date value. 
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2. Copy the Stock Price from column B to column E by ignoring the last value. 

 

3. Copy the original data under the new create one. 

 

4. Select the data and insert Line Chart. 
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5. Click on the horizontal axis and change the date format to mmm-yyyy. 

 

6. Adjust the bound in Axis for better presentation. 
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5.7 Panel Chart 

5.7.1 Create Panel Chart by Grouping 

1. Create a column chart for the first stock. Select the “Date” and first stock columns only.  

 

2. Create the other three charts for the remaining companies. You can use the [Ctrl] button to 

select the column. 

 

3. Select all the charts (Select one chart first and press [Ctrl] + [A]), make the height and width of 

the chart equal under the “Format” tab. Then select Group all the charts together and makes it 

one single chart. 
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5.7.2 Create Panel Chart by Blank Row 

1. Adjust the data in following format: 

 Change the fate column to “dd-mmm” format 

 Create a blank row between different company. 

 

2. Select the entire data range and insert the Column Chart. 
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5.8 Tornado / Funnel Chart 

5.8.1 Introduction 

Tornado or funnel chart is basically a bar chart of descending sorted data. It looks like a funnel or 

tornado, from which it gets its name. In this chart, one group's data is shown on the left side of the 

axis and other group's data is shown on the right side of the axis. This makes it easy to compare 

these groups. 

5.8.2 Creating Funnel Chart 

1. The minus values are portrayed on the opposite side of the axis. First, convert all values of 

group A into negative.  

 

2. Select Insert ➔ Recommended Charts, then select Bar Charts ➔ Stacked Bar Chart.  
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3. Right-click on the y-axis. Click on the format axis. In labels, select “Low” in “Label Position”. 

 

4. Select any bar and go to Formatting, reduce the “Gap Width” to 0 

 

5. Chang the border as white, remember there are two data series. 
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6. Let's remove the minus sign (-) from the chart. Select the x-axis. Go to formatting. In the axis 

option, click on the number. Select “Custom” in Category. In Format code write this ###0;###0 

Click on [Add]. 

 

7. In the Axis option, check “Categories in reverse order”. 
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5.9 Waterfall Chart 

5.9.1 Introduction 

A waterfall chart is a special kind of chart that illustrates how positive or negative values in a data 

series contribute to the total. In other words, it's an ideal way to visualize a starting value, the 

positive and negative changes made to that value, and the resulting end value. In a waterfall chart, 

the first column is the starting value and the last column is the end value. The floating columns 

between them are the contributing positive or negative values. 

5.9.2 Creating Waterfall Chart 

5.9.2.1 Example 1: Stacked Waterfall Chart 

1. Enter the values in your workbook with the Starting Total e.g. January Income. Then add the 

positive and negative values, like direct & indirect expenses. Finally enter the Ending Total e.g. 

January Total, which will Sum all of the above values. 

 

2. Highlight all the data and go to Insert ➔ Recommended Charts, then select Waterfall and 

press [OK].   
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3. Double Click on the Starting Totals column (e.g. January Income) and this will bring up the 

Format Data Point dialogue box, then select “Set as total”. 

 

4. Now select the Ending Total with your mouse and once again select “Set as Total box”. 
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5.9.2.2 Example 2: Income Statement 

1. We will use the Waterfall Chart to understand the income statement overview and change 

analysis. Highlight all the data and go to Insert ➔ Recommended Charts, then select 

Waterfall and press [OK].   

 

2. The Waterfall Chart will appear on the sheet. Net Sales, Gross Margin, Operating Income, 

Income before taxes, and Net Income are all either Total or Subtotal values, not additional 

values. However, Excel has incorrectly considered all the columns as additional values 

(color-coded as either blue or red). Right Click on Column and select Set as Total. 
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3. Double click on Chart title and rename it as “Income Statement”. 

 

 

 

 

 

 

 

 


