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1. Introduction to Microsoft Excel 

1.1 Overview 

1.1.1 User Interface 

A spreadsheet is an online version of an accountant's worksheet, which can automatically do most 

of the calculating for you. You can do budgets, analyze data, or generate sorted lists.  

When you open Microsoft Excel, you'll see the familiar worksheets you're accustomed to. The old 

look of Excel menus and buttons has been replaced with this new Ribbon, with tabs you click to get 

to commands. 

 

1.1.2 Create new Workbook 

In order to open Excel. Select “Blank workbook” or press [Ctrl] + [N] in the welcome screen. 
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Moreover, you can create a workbook from a template by selecting File➔ New. Then double click 

the template you like. 

 

1.1.3 Enter Data 

To manually enter data, select an empty cell (such as A1) and then type text or a number. 

Press [Enter] to move down, or press [Tab] to move right 

 

1.2 Worksheet Manipulation 

1.2.1 Insert Worksheet 

In order to inset a new worksheet, select Home ➔ Insert ➔ Insert Sheet.

 

Besides, you can select the plus icon at the bottom of the screen. 
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1.2.2 Rename Worksheet 

In order to rename a worksheet, right-click on the Sheet tab, click Rename, and type a new name. 

Besides, you can double-click the sheet name on the Sheet tab to quickly rename it. 

 

1.2.3 Delete Worksheet 

In order to delete an unwanted worksheet, select Home ➔ Insert ➔ Delete Sheet. 

 

Besides, you can right-click the Sheet tab and select Delete. 

 

1.2.4 Move Worksheet within Workbook 

You can use the Move or Copy Sheet command to move or copy entire worksheets, to other 

locations in the same or a different workbook. You can use the Cut and Copy commands to move or 

copy a portion of the data to other worksheets or workbooks. 

 

On the other hand, you can select the worksheet tab, and drag it to where you want it. 

When you move a sheet to another workbook, check any formulas or charts that refer to data on the 

sheet because moving the sheet might cause errors or produce unintended results in your data. 

Similarly, if you move a sheet that is referred to by 3-D references, the calculation might include or 

leave out data on the sheet. 
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1.2.5 Copy Worksheet within Workbook 

In order to copy a worksheet, right click on the worksheet tab and select Move or Copy. Select the 

“Create a copy” checkbox. Then select where you want to place the copy under “Before sheet” 

dialog. Finally, press [OK] to confirm.  On the other hand, you can press [Ctrl] and drag the 

worksheet tab to the tab location you want. 

 

1.3 Select Cell Contents 

In Excel, you can select cell contents of one or more cells, rows and columns. 

If a worksheet has been protected, you might not be able to select cells or their contents on a 

worksheet. 

1.3.1 Select one or more Cells 

1. Click on a cell to select it. Or use the keyboard to navigate to it and select it. 

2. To select a range, select a cell, then with the left mouse button pressed, drag over the other cells. 

Or use the [Shift] and arrow keys to select the range. 

3. To select non-adjacent cells and cell ranges, hold [Ctrl] and select the cells. 

1.3.2 Select one or more Rows and Columns 

1. Select the letter at the top to select the entire column. Or click on any cell in the column and 

then press [Ctrl] + [Space]. 

 

2. Select the row number to select the entire row. Or click on any cell in the row and then press 

[Shift] + [Space]. 

 

3. To select non-adjacent rows or columns, hold [Ctrl] and select the row or column numbers. 
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1.3.3 Select Table, List or Worksheet 

1. To select a list or table, select a cell in the list or table and press [Ctrl] + [A]. 

2. To select the entire worksheet, click the “Select All” button at the top left corner. 

 

1.4 Cell Manipulation 

1.4.1 Move Cells 

Use Cut, Copy, and Paste to move or copy cell contents. Or copy specific contents or attributes from 

the cells. For example, copy the resulting value of a formula without copying the formula, or copy 

only the formula. 

When you move or copy a cell, Excel moves or copies the cell, including formulas and their 

resulting values, cell formats, and comments. 

You can move cells in Excel by drag and dropping or using the Cut and Paste commands. 

1.4.1.1 Move Cells by Drag and Dropping 

1. Select the cells or range of cells that you want to move or copy. 

2. Point to the border of the selection. 

3. When the pointer becomes a move pointer , drag the cell or range of cells to another 

location. 

1.4.1.2 Move Cells by using Cut and Paste 

1. Select a cell or a cell range. 

2. Select Home ➔ Cut or press [Ctrl] + [X]. 

3. Select a cell where you want to move the data. 

4. Select Home ➔ Paste or press [Ctrl] + [V]. 

1.4.2 Merge Cells 

1.4.2.1 Merge Cells 

You can't split an individual cell, but you can make it appear as if a cell has been split by merging 

the cells above it. To merge the cell: 

1. Select the cells to merge. 

2. Select Merge & Center. 
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When you merge multiple cells, the contents of only one cell (the upper-left cell for left-to-right 

languages, or the upper-right cell for right-to-left languages) appear in the merged cell. The contents 

of the other cells that you merge are deleted. 

1.4.2.2 Unmerge Cells 

1. Select the Merge & Center down arrow. 

2. Select Unmerge Cells. 

You cannot split an unmerged cell. After merging cells, you can split a merged cell into separate 

cells again. If you don't remember where you have merged cells, you can use the Find command to 

quickly locate merged cells. 

1.5 Column and Row Manipulation 

1.5.1 Hide or Show Rows and Columns 

Hide or unhide columns in your spreadsheet to show just the data that you need to see or print. 

1.5.1.1 Hide Columns 

1. Select one or more columns, and then press [Ctrl] to select additional columns that aren't 

adjacent. 

2. Right-click the selected columns, and then select Hide. The double line between two columns is 

an indicator that you've hidden a column. 

1.5.1.2 Unhide Columns 

1. Select the adjacent columns for the hidden columns. 

2. Right-click the selected columns, and then select Unhide. Or double-click the double line 

between the two columns where hidden columns exist. 

1.5.2 Resize 

You can manually adjust the column width or row height or automatically resize columns and rows 

to fit the data. The boundary is the line between cells, columns, and rows. If a column is too narrow 

to display the data, you will see ### in the cell. 

1.5.2.1 Resize Rows 

1. Select a row or a range of rows. 

2. On the Home tab, in the Cells group, select Format ➔ Row Width. 

3. Type the row width and select [Ok]. 
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1.5.2.2 Resize Columns 

1. Select a column or a range of columns. 

2. On the Home tab, in the Cells group, select Format ➔ Column Width. 

3. Type the column width and select [Ok]. 

 

1.5.2.3 Automatically Resize all Columns and Rows 

1. In order to automatically resize all columns and rows to fit the data. Select the [Select All] 

button at the top of the worksheet, to select all columns and rows. 

2. Double-click a boundary, all columns or rows resize to fit the data. 

1.6 Freeze Panes to Lock Rows and Columns 

To keep an area of a worksheet visible while you scroll to another area of the worksheet, go to the 

View tab, where you can Freeze Panes to lock specific rows and columns in place, or you can Split 

panes to create separate windows of the same worksheet. 

 

1.6.1 Freeze the First Row 

Select View➔ Freeze Panes ➔ Freeze Top Row. The faint line that appears between row 1 and 2 

shows that the first row is frozen. 

1.6.2 Freeze the First Column 

Select View➔ Freeze Panes ➔ Freeze First Column. The faint line that appears between column 

A and B shows that the first column is frozen. 

1.6.3 Freeze Columns and Rows 

Select the cell below the rows and to the right of the columns you want to keep visible when you 

scroll, then select View ➔ Freeze Panes ➔ Freeze Panes. 

1.6.4 Unfreeze rows or columns 

In order to unfreeze row or column, select View ➔ Freeze Panes ➔ Unfreeze Panes. 
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1.7 Status Bar 

The status bar displays information about what’s happening in your workspace. For example, most 

of the time, Excel displays the word Ready at the left end of the status bar.  

 

  



    Chapter 1 

Essential Excel Skill for Job Hunting @ Peter Lo 2023 9 

2. Worksheet Editing Techniques 

2.1 Copying, Cutting, and Pasting 

2.1.1 Basic Copy Technique 

2.1.1.1 Copy Cell 

1. Select the cells that you want to copy, then select Home ➔ Copy, or press [Ctrl] + [C]. 

2. Select the upper-left cell of the paste area. To move or copy a selection to a different worksheet 

or workbook, click another worksheet tab or switch to another workbook, and then select the 

upper-left cell of the paste area. Then select Home ➔ Paste, or press [Ctrl] + [V]. 

2.1.1.2 Insert Moved or Copied Cells between Existing Cells 

1. Select the cells that you want to copy, then select Home ➔ Copy, or press [Ctrl] + [C]. 

2. Right-click the upper-left cell of the paste area, and then click Insert Cut Cells or Insert 

Copied Cells.  

3. In the Insert Paste dialog box, click the direction in which you want to shift the surrounding 

cells. If you insert whole rows or columns, the surrounding rows and columns are shifted down 

and to the left. 

2.1.1.3 Copy Visible Cells Only 

If some cells, rows, or columns on the worksheet are not displayed, you have the option of copying 

all cells or only the visible cells. For example, you can choose to copy only the displayed summary 

data on an outlined worksheet. 

1. Select the cells that you want to copy, select Home ➔ Find & Select ➔ Go To Special. Under 

Select, click “Visible cells only”, and then click [OK]. 

 

2. Select Home ➔ Copy, or press [Ctrl] + [C]. 

3. Select the upper-left cell of the paste area. Then select Home ➔ Paste, or press [Ctrl] + [V]. 
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2.1.2 Collecting Multiple Items on the Clipboard 

Using the collect and copy feature, you can Copy (or Cut) up to 24 separate items and then paste 

them where you want them (one at a time or all at once). You do this by using the Office Clipboard 

Task Pane.  

You can change the normal collect and copy behavior so that Excel collects items every time you 

copy or cut, regardless of whether the Clipboard Task Pane is present. To do so, click the Options 

button at the bottom of the Clipboard Task Pane and choose Collect Without Showing Office 

Clipboard. 

Although collect and copy is useful for editing tasks, it can also be a great tool for gathering 

information. Copy items such as names or addresses from various locations in the order you want 

them to appear. Then click the Paste All button on the Clipboard Task Pane to paste all the items 

you have collected, in the order collected, into a single column. 
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2.1.3 Using the Paste Options Smart Tag 

This smart tag appears whenever and wherever you paste, offering action options applicable after 

pasting – a sort of “Smart Paste Special”. The best part is that you can try each action in turn. Keep 

selecting Paste options until you like what you see, and then press [Enter]. 

 

Keep Source Formatting: Retains formatting. This is the default action. If the other 

options don’t work for you, you can always come back to 

this one before you press Enter 

Match Destination Formatting: Copies formatted data into a differently formatted table 

without having to redo the formatting 

Values and Number Formatting: Pastes values without losing number formats 

Keep Source Column Widths: Retains column widths. This option is like choosing Keep 

Source Formatting with the added action of “pasting” the 

column width 

Formatting Only: Leaves the contents of the cells alone and transfers the 

formatting. This works in the same way as the Format 

Painter button on the Standard toolbar. 

Link Cells: Instead of pasting the contents of the cut or copied cells, 

pastes a reference to the source cells, ignoring the source 

formatting 
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2.1.4 Paste Special 

2.1.4.1 Pasting Selectively Using Paste Special 

Paste Special is quite possibly the most useful power-editing feature of all. There are many ways to 

use this feature, but probably the most popular is copying the value in a cell without copying the 

formatting or the underlying formula. 

 

All: Predictably, pastes all aspects of the selected cell, which is 

the same as simply using the Paste command 

Formulas: Transfers only the formulas from the cells in the copy range 

to the cells in the paste range, adjusting relative references 

Values: Pastes static text, numeric values, or only the displayed 

values resulting from formulas. 

Formats: Transfers only the formats in the copy range to the paste 

range 

Comments: Transfers only comments attached to selected cells. 

Validation: Pastes only the Data Validation settings that you have 

applied to the selected cells. 

All except borders: Transfers data without disturbing the border formats you 

spent so much time applying 

Column widths: Transfers only column widths, which is handy when trying 

to make a sheet look consistent for presentation 

Formulas and number formats: Transfers only formulas and number formats, which is 

handy when copying formulas to previously formatted 

areas. Usually, you’ll want the same number formats 

applied to formulas you copy, wherever they happen to go 

Values and number formats: Transfers resulting values and number formats 
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2.1.4.2 Pasting Using Math Operators 

You use the options in the Operation section of the Paste Special dialog box to mathematically 

combine the contents of the copy area with the contents of the paste area. When you select any 

option other than None, Excel uses the specified operator to combine the copy and paste ranges. 

For example, we want to get a total of the Northern and Eastern regions. First we copied the 

Northern Region figures to column G, and then we copied the Eastern Region numbers in column D 

and chose Paste Special. We clicked the Values and Add options in the Paste Special dialog box, 

and after clicking [OK]. 

 

The other options in the Operation section of the Paste Special dialog box combine the contents of 

the copy and paste ranges using the appropriate operators. Just remember that the Subtract option 

subtracts the copy range from the paste range, and the Divide option divides the contents of the 

paste range by the contents of the copy range. Also, note that nothing happens if the copy range 

contains text entries and you use Paste Special with an Operation option. 

2.1.4.3 Pasting Links 

The [Paste Link] button in the Paste Special dialog box is a handy way to create references to cells 

or ranges. When you click the [Paste Link] button, Excel enters an absolute reference to the copied 

cell in the new location. For example, if you copy cell A3, and then select cell B5, choose Paste 

Special, and click the [Paste Link] button, the formula =$A$3 is entered into cell B5. 

If you copy a range of cells, the Paste Link button enters a similar formula for each cell in the 

copied range to the same sized range in the new location. 
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2.1.4.4 Skipping Blank Cells 

The Paste Special dialog box contains a Skip Blanks option that you use when you want Excel to 

ignore any blank cells in the copy range. Generally, if your copy range contains blank cells, Excel 

pastes those blank cells over the corresponding cells in the paste area. As a result, empty cells in the 

copy range overwrite the contents, formats, and comments in corresponding cells of the paste area. 

When you select Skip Blanks, the corresponding cells in the paste area are unaffected. 

2.1.4.5 Transposing Entries 

Transpose helps you to reorient the contents of the copied range when you paste (entries in rows 

appear in columns, and entries in columns appear in rows). For example, we needed to use the 

column headings in Row 3 of the top sheet to create identical row headings in column A of the 

bottom sheet. Accomplishing this was as simple as copying cells B3:G3 in the top sheet, clicking 

cell A4 in the bottom sheet, and using Paste Special with Transpose selected. 

 

2.1.5 Pasting Hyperlinks 

The Paste as Hyperlink paste a hyperlink to the copied data in the location you specify. When you 

create a hyperlink, it’s as if Excel draws an invisible box that acts like a button when you click it, 

and places it over the selected cell. 
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2.2 Creating Data Series 

To fill data in a series, enter the beginning of the series in two cells: such as Jan and Feb; or 2014 

and 2015. Select the two cells containing the series, and then drag the fill handle Fill handle across 

or down the cells. 

 

2.2.1 Fill Series 

Uses of the fill handle include quickly and easily filling cells and creating data series using the 

incredibly useful AutoFill feature. 

 If you choose Fill Series on the smart tag action menu, Excel creates the simple series 1, 2, 3 

instead of copying the contents of cell.  

 If you choose Copy Cells on the AutoFill Options menu, instead of extending the series, 

Excel copies the cells, repeating the pattern of selected cells as necessary to fill the range.  

 Moreover, AutoFill normally increments recognizable date and time values when you drag the 

fill handle, even if you initially select only one cell. 

 

 

 

 



    Chapter 1 

Essential Excel Skill for Job Hunting @ Peter Lo 2023 16 

2.2.2 Create a List of Sequential Dates 

1. In order to create a list of sequential data by using the Fill Handle, select the cell that contains 

the first date. Drag the fill handle across the adjacent cells that you want to fill with sequential 

dates. 

2. Select the fill handle  at the lower-right corner of the cell, hold down, and drag to fill the 

rest of the series. Fill handles can be dragged up, down, or across a spreadsheet. 

 

2.2.3 Flash Fill 

Flash Fill is one of the most amazing features of Excel. It grabs a tedious task that would take hours 

to be performed manually and executes it automatically in a flash. And it does so quickly and 

simply without you having to do a thing, but only provide an example of what you want. For 

example, automatically fill a First Name column from a Full Name column. 

1. In the cell under First Name, type Molly and press Enter. 

2. In the next cell, type the first few letters of Garret. 

3. When the list of suggested values appears, press [Enter]. 

4. Select Flash Fill Options for more options. 
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3. Find and Replace 

3.1 Find a String 

1. To find something, select Home ➔ Editing ➔ Find & Select ➔ Find, or press [Ctrl] + [F]. 

 

2. In the Find what: box, type the text or numbers you want to find, or click the arrow in the Find 

what: box, and then select a recent search item from the list. You can use wildcard characters — 

question mark (?), asterisk (*), tilde (~) — in your search criteria. 

• Use the question mark (?) to find any single character — for example, s?t finds "sat" and 

"set". 

• Use the asterisk (*) to find any number of characters — for example, s*d finds "sad" and 

"started". 

• Use the tilde (~) followed by ?, *, or ~ to find question marks, asterisks, or other tilde 

characters  — for example, fy91~? finds "fy91?". 

3. Then click [Find All] or [Find Next] to run your search. When you click [Find All], every 

occurrence of the criteria that you are searching for will be listed, and clicking a specific 

occurrence in the list will select its cell. You can sort the results of a [Find All] search by 

clicking a column heading. If you need to further define your search, you can click [Options] 

button. 

• Within: To search for data in a worksheet or in an entire workbook, select Sheet or 

Workbook. 

• Search: You can choose to search either By Rows (default), or By Columns. 

• Look in: To search for data with specific details, in the box, click Formulas, Values, Notes, 

or Comments.  

o Formulas, Values, Notes and Comments are only available on the Find tab;  

o Only Formulas are available on the Replace tab. 

• Match case: Check this if you want to search for case-sensitive data. 

• Match entire cell contents: Check this if you want to search for cells that contain just the 

characters that you typed in the Find what: box. 

4. If you want to search for text or numbers with specific formatting, click [Format], and then 

make your selections in the Find Format dialog box.  
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3.2 Finding Formatting 

Excel provides a way to find cells based on formatting in conjunction with other criteria, and even 

to find and replace specifically formatted cells, regardless of their content. You can select any 

number of options in this dialog box, and when you are finished, click [OK] to add them to your 

criteria. If you click the [▼] button next to the Format button to display the Format menu, you can 

select Choose Format From Cell. 

 

3.3 Replacing What You Find 

Replace works much like Find by choosing Replace. You can also find and replace formats using 

the dual [Format] buttons. To replace every occurrence of a string or formatting, click Replace All. 

Instead of pausing at each occurrence to allow you to change or skip the current cell, Excel locates 

all the cells that contain the Find What string and replaces them. 

 

1. To replace text or numbers, select Home ➔ Editing ➔ Find & Select ➔ Replace, or press 

[Ctrl] + [H] 

2. In the Find what: box, type the text or numbers you want to find, or click the arrow in the Find 

what: box, and then select a recent search item from the list. 

3. In the Replace with: box, enter the text or numbers you want to use to replace the search text. 

Then click [Replace All] or [Replace]. 
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4. Worksheet Formatting Techniques 

4.1 Formatting Individual Characters 

If you select a cell and apply formats, the entire contents of the cell receive the formats. However, 

you can also apply formatting to individual text characters within cells (but not numeric values or 

formulas). Select individual characters or words, and apply the attributes you want. When you are 

finished, press [Enter] to see the results. 

 

4.2 Format Cell 

In Excel, you can format numbers in cells for things like currency, percentages, decimals, dates, 

phone numbers, or social security numbers. Number formats don't just make your spreadsheet easier 

to read—they also make it easier to use. When you apply a number format, you're telling your 

spreadsheet exactly what types of values are stored in a cell. For example, the date format tells the 

spreadsheet that you're entering specific calendar dates. This allows the spreadsheet to better 

understand your data, which can help ensure that your data remains consistent and that your 

formulas are calculated correctly. 

4.2.1 Applying Number Formats 

Just like other types of formatting, such as changing the font color, you'll apply number formats by 

selecting cells and choosing the desired formatting option. There are two main ways to choose a 

number format: 

The first method is going to the Home tab, click the Number Format drop-down menu in the 

Number group, and select the desired format. 

 



    Chapter 1 

Essential Excel Skill for Job Hunting @ Peter Lo 2023 20 

You can also click one of the quick number-formatting commands below the drop-down menu. 

 

On the other hand, you can select a cell or a cell range, right click and choose “Format Cell…”. 

You can also press [Ctrl] + [1] to call up the Format Cell dialog. 

 

4.2.2 Increase and Decrease Decimal 

The Increase Decimal and Decrease Decimal commands allow you to control how many decimal 

places are displayed in a cell. These commands don't change the value of the cell; instead, they 

display the value to a set number of decimal places. 

 

Decreasing the decimal will display the value rounded to that decimal place, but the actual value in 

the cell will still be displayed in the formula bar. 
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4.2.3 Available Format 

Format Description 

General The default number format that Excel applies when you type a number. For the most 

part, numbers that are formatted with the General format are displayed just the way 

you type them. However, if the cell is not wide enough to show the entire number, 

the General format rounds the numbers with decimals. The General number format 

also uses scientific (exponential) notation for large numbers (12 or more digits). 

Number Used for the general display of numbers. You can specify the number of decimal places 

that you want to use, whether you want to use a thousand separator, and how you want 

to display negative numbers. 

Currency Used for general monetary values and displays the default currency symbol with 

numbers. You can specify the number of decimal places that you want to use, whether 

you want to use a thousand separator, and how you want to display negative numbers. 

Accounting Also used for monetary values, but it aligns the currency symbols and decimal points 

of numbers in a column. 

Date Displays date and time serial numbers as date values, according to the type and locale 

(location) that you specify. Date formats that begin with an asterisk (*) respond to 

changes in regional date and time settings that are specified in Control Panel. Formats 

without an asterisk are not affected by Control Panel settings. 

Time Displays date and time serial numbers as time values, according to the type and locale 

(location) that you specify. Time formats that begin with an asterisk (*) respond to 

changes in regional date and time settings that are specified in Control Panel. Formats 

without an asterisk are not affected by Control Panel settings. 

Percentage Multiplies the cell value by 100 and displays the result with a percent (%) symbol. You 

can specify the number of decimal places that you want to use. 

Fraction Displays a number as a fraction, according to the type of fraction that you specify. 

Scientific Displays a number in exponential notation, replacing part of the number with E+n, 

where E (which stands for Exponent) multiplies the preceding number by 10 to the nth 

power. For example, a 2-decimal Scientific format displays 12345678901 as 1.23E+10, 

which is 1.23 times 10 to the 10th power. You can specify the number of decimal 

places that you want to use. 

Text Treats the content of a cell as text and displays the content exactly as you type it, even 

when you type numbers. 

Special Displays a number as a postal code, phone number, or Social Security number. 

Custom Allows you to modify a copy of an existing number format code. Use this format to 

create a custom number format that is added to the list of number format codes. You 

can add between 200 and 250 custom number formats, depending on the language 

version of Excel that is installed on your computer.  
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4.2.3.1 Number Format 

The Number category in the Format Cells dialog box contains options for displaying numbers in 

integer, fixed-decimal, and punctuated formats. It is essentially the General format with additional 

control over displayed decimal places, thousand separators, and negative numbers. You can use this 

category to format any numbers that do not fall into any of the other categories. 

 

4.2.3.2 Currency Format 

The Currency formats are similar to the Number formats except that instead of selecting the 

thousands separator (which accompanies all currency formats by default), you can select which 

currency symbol, if any, precedes (or trails) the number. Select the currency symbol in the Symbol 

drop-down list, which includes more than 250 different currency symbols from around the world. 
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4.2.3.3 Accounting Format 

The Accounting format in excel is like the Currency format and can be connected to numbers where 

required. The contrast between the Accounting format and the Currency format is that the 

Accounting format puts the dollar sign, for instance, at the extreme left end of the cell, and 

showcases zero as a dash. Format numbers are the same as currency. 

 

4.2.3.4 Date and Time Format 

You can format dates and times as you type. For example, if you type 1/1 in a cell, Excel 

automatically interprets this as a date and displays 1-Jan in the cell. If you would show 1 January 

2021 or 1/1/21 in the cell, you can choose a different date format in the Format Cells dialog box. 

Similarly, if you type 9:30, Excel will interpret this as a time and display 9:30 am. 
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4.3 Custom Formats  

Excel Custom Number formatting is the clothing for data in excel cells. You can dress these the way 

you want. An Excel number format consists of 4 sections of code, separated by semicolons: 

{Positive} ; {Negative} ; {Zero} ; {Text} 

Consider the following example: 

 

 Format for positive numbers (display 2 decimal places and a thousand separator). 

 Format for negative numbers (the same as for positive numbers but enclosed in parenthesis). 

 Format for zeros (display dashes instead of zeros). 

 Format for text values (display text in magenta font color). 

4.3.1 Excel Formatting Rules 

When creating a custom number format in Excel, please remember these rules: 

 A custom Excel number format changes only the visual representation, i.e. how a value is 

displayed in a cell. The underlying value stored in a cell is not changed. 

 When you are customizing a built-in Excel format, a copy of that format is created. The 

original number format cannot be changed or deleted. 

 Excel custom number format does not have to include all four sections. 

− If a custom format contains just 1 section, that format will be applied to all number types - 

positive, negative and zeros. 

− If a custom number format includes 2 sections, the first section is used for positive 

numbers and zeros, and the second section - for negative numbers. 

− A custom format is applied to text values only if it contains all four sections. 

 To apply the default Excel number format for any of the middle sections, type General instead 

of the corresponding format code. For example, to display zeros as dashes and show all other 

values with the default formatting, use this format code: General; -General; "-"; General 

 To hide a certain value type(s), skip the corresponding code section, and only type the ending 

semicolon. For example, to hide zeros and negative values, use the following format code: 

General; ; ; General. As the result, zeros and negative value will appear only in the formula bar 

but will not be visible in cells. 

 To delete a custom number format, open the Format Cells dialog, select Custom in the 

Category list, find the format you want to delete in the Type list, and click the Delete button. 

4.3.2 Creating New Formats 

Use the Custom tab in the Format Cells dialog box to create custom number formats using special 

formatting codes. Excel adds new formats to the bottom of the list of formatting codes in the Type 

list, which also includes built-in formats. To delete a custom format, select the format in the Format 

Cells dialog box and click Delete. However, you cannot delete built-in formats. 
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4.3.3 Custom Format Symbols 

Symbol Meaning 

General Number in General (serial value) format 

0 Digit Placeholder. This symbol ensures that a specified number of digits 

appear on each side of the decimal point. If a number has more digits to the 

right of the decimal point than the number 0s specified in the format, the 

number in the cell is rounded. (E.g. the value .98 is displayed as 0.980 if the 

format is 0.000; .98 is rounded to 1.0 if the format is 0.0) 

? Digit Placeholder. This symbol follows the same rules as the 0 placeholder, 

except that space is left for insignificant zeros on either side of the decimal 

point. This placeholder aligns numbers on the decimal points. (E.g., 1.4 and 

1.45 would line up on the decimal point if both were formatted as 0.??) 

# Digit Placeholder. This symbol works like 0, except that extra zeros do not 

appear if the number has fewer digits on either side of the decimal point than 

#s specified in the format. This symbol shows Excel where to display commas 

or other separating symbols. (E.g. the format #,### display a comma after 

every 3rd digit to the left of the decimal point) 

. Decimal Point. This symbol determines how many digits (0 or #) appear to 

the right and left of the decimal point. (E.g. if you want Excel to include 

commas and display at least one digit to the left of the decimal point in all 

cases, specify the format #,##0). 
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% Percentage Indicator. This symbol multiplies the entry by 100 and insert the 

% character. 

/ Fraction Format Character. This symbol displays the fractional part of a 

number in a non-decimal format. The number of digit placeholders that 

surround this character determines the accuracy of the display. (E.g. the 

decimal fraction 0.269 when formatted with # ?/? is displayed as 1/4, but 

when formatted with # ???/??? is displayed as 46/171) 

, Thousands separator. If the format contains a comma surrounded by #s, 0s, 

or ?s, Excel uses commas to separate hundreds from thousands, thousands 

from millions, and so on. (E.g. the format code #,###,###, would round 

4567890 to 4,568, whereas the format code #,###,###,, would round it to 5) 

E– E+ 

 

Scientific Format Characters. If a format contains one 0 or # to the right of 

an E– or E+, Excel displays the number in scientific notation and inserts E in 

the displayed value. The number of 0s or #s to the right of the E determines 

the minimum number of digits in the exponent. Use E– to place a negative 

sign by negative exponents; use E+ to place a negative sign by negative 

exponents and a positive sign by positive exponents. 

\ Literal demarcation character. Precede each character you want to display 

in the cell (except for : $ – + / ( ) and space) with a backslash. (E.g. the format 

code #,##0 \D;-#,##0 \C displays positive numbers followed by a D, and 

negative numbers followed by a C. To insert several characters, use the 

quotation-mark technique described in the “Text” table entry) 

$ – + / ( ) space Standard formatting characters. These symbols type these characters 

directly. 

_ Underscore. This code leaves space equal to the width of the next character. 

Use this formatting character for alignment purposes. (E.g. _) leaves a space 

equal to the width of the close parenthesis)  

“  ” Literal Character String. This formatting code works like the backslash 

technique except that all text can be included within one set of double 

quotation marks without using a separate demarcation character for each 

literal character. 

* Repetition Initiator. Repeats the next character in the format enough times to 

fill the column width. Use only one asterisk in the format. 

@ Text Placeholder. If the cell contains text, this placeholder inserts that text in 

the format where the @ appears. (E.g. the format code “Hello” @ displays 

“Hello World” in a cell containing the text “World”) 

[  ] Conditional Formats. Conditional formatting can be applied to number 

format. To create a conditional format, you set up the condition inside square 

brackets using the same comparative operators 
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4.3.4 Date and Time Formats 

Code Meaning 

d Day number without leading zero (1 – 31) 

dd Day number with leading zero (01 – 31) 

ddd Day-of-week abbreviation (Sun – Sat) 

dddd Complete day-of-week name (Sunday – Saturday) 

m Month number without leading zero (1 – 12) 

mm Month number with leading zero (01 – 12) 

mmm Month name abbreviation (Jan – Dec) 

mmmm Complete month name (January – December) 

yy Last two digits of year number (00 – 99) 

yyyy Complete four-digit year number (1900 – 2078) 

h Hour without leading zero (0 – 23) 

hh Hour with leading zero (00 – 23) 

m Minute without leading zero (0 – 59) 

mm Minute with leading zero (00 – 59) 

s Second without leading zero (0 – 59) 

ss Second with leading zero (00 – 59) 

s.0 Second and tenths of a second without leading zero 

s.00 Second without leading zero and hundredths of a second without leading zero 

ss.0 Second without leading zero and tenths of a second with leading zero 

ss.00 Second and hundredths of a second with leading zero 

AM/PM Time in AM/PM notation 

am/pm Time in am/pm notation 

4.3.5 Locale 

To specify a language for the TEXT function, you need to know the code for that language. The 

code is a two-letter ISO 639-1 code that represents a particular language. For example, the code for 

English is "en". Once you know the code for the language you want to use, you can specify it in the 

[language] argument like this: 

Format Output 

[$-en-US]d mmmm, yyyy (dddd) 1 January, 2023 (Sunday) 

[DBNum1][$-zh-TW]yyyy"年"mmmmd"日"dddd 二○二三年一月一日星期日 

[DBNum1][$-zh-CN]yyyy"年"mmmmd"日"dddd 二○二三年一月一日星期日 
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4.3.6 Escaping Characters 

Some characters won't work correctly in a custom number format without being escaped. For 

example, the asterisk (*), hash (#), and percent (%) characters can't be used directly in a custom 

number format – they won't appear in the result. The escape character in custom number formats is 

the backslash (\). By placing the backslash before the character, you can use them in custom number 

formats: 

Format Value Result 

\#0 100 #100 

\*0 100 *100 

\%0 100 %100 

4.3.7 Example 

4.3.7.1 Adding Color to Formats 

You can also use the Number formats to change the color of selected cell entries. You can even 

create formats that assign different colors to specific numeric ranges so that all values greater than 

or less than a specified value appear in a different color. To change the color of an entry, type the 

name of the new color in brackets (e.g. [BLUE]) in front of each segment of code. 
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4.3.7.2 Using Custom Format Condition Operators 

You can create custom formats that are variable by adding a condition operator (<, >, =, <=, >=, or 

<>) to the Excel for conditional format.  

 

4.3.7.3 Number Formats for Elapsed Time 

Elapsed time is a special case and needs special handling. By using square brackets, Excel provides 

a special way to display elapsed hours, minutes, and seconds.  
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4.3.7.4 Colors by Index 

In addition to color names, it's also possible to specify colors by an index number between 1-56 

(Color1, Color2, Color3, etc.) 

 

4.3.7.5 Apply Number Formats in Formula 

Although most number formats are applied directly to cells in a worksheet, you can also apply 

number formats inside a formula with the TEXT function. 
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4.3.7.6 Hide all Content 

You can use a custom number format to hide all content in a cell. The code is simply three 

semi-colons and nothing else ;;; 

 

To reveal the content again, you can use the keyboard shortcut [Ctrl] + [Shift] + [~], which applies 

the General format to the corresponding cells. 

4.4 Display or Hide Zero Values 

Sometimes you might not want zero (0) values showing on your worksheets, sometimes you need 

them to be seen. Whether your format standards or preferences call for zeroes showing or hidden, 

there are several ways to make it happen. 

4.4.1 Hide or Display all Zero Values in Worksheet 

1. In order to control the display of zero values in worksheet, click File ➔ Options. 

 



    Chapter 1 

Essential Excel Skill for Job Hunting @ Peter Lo 2023 32 

2. Select the “Advanced” tab, select a worksheet under “Display options for this worksheet”. 

 

3. Setup the display of zero value as follow: 

• To display zero values in cells, check the “Show a zero in cells that have zero value” 

check box. 

• To display zero values as blank cells, uncheck the “Show a zero in cells that have zero 

value” check box. 

4.4.2 Hide Zero Values in Selected Cells 

These steps hide zero values in selected cells by using a number format. The hidden values appear 

only in the formula bar and are not printed. If the value in one of these cells changes to a nonzero 

value, the value will be displayed in the cell, and the format of the value will be similar to the 

general number format. 

1. Select the cells that contain the zero values that you want to hide. 

2. Right click and select Format Cells, or you can press [Ctrl] + [1]. 

3. Go to Number tab, and select Custom. 

4. Type 0;-0;;@ in the Type box, and then click [OK]. 
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4.4.3 Display Hidden Zero Values 

1. Select the cells with hidden zeros. 

2. Right click and select Format Cells, or you can press [Ctrl] + [1]. 

3. Go to Number tab, and select General to apply the default number format, and then click 

[OK]. 
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4.5 Aligning Data  

The Alignment group in Home menu, positions text and numbers in cells. It also contains options 

you can use to create multi line text labels, repeat a series of characters within one or more cells, 

and orient text vertically or at any angle in cells. 

  

4.5.1 Vertical Alignment 

If you'd like to align data vertically, click one of the following icons: 

 Top Align – Aligns the contents to the top of the cell. 

 Middle Align – Centers the contents between the top and bottom of the cell. 

 Bottom Align – Aligns the contents to the bottom of the cell (the default one). 

Please note that changing vertical alignment does not have any visual effect unless you increase the 

row height. 

4.5.2 Horizontal Alignment 

To align your data horizontally, Microsoft Excel provides these options: 

 Align Left – Aligns the contents along the left edge of the cell. 

 Center – Puts the contents in the middle of the cell. 

 Align Right – Aligns the contents along the right edge of the cell. 

4.5.3 Combining Vertical and Horizontal Alignment 

By combining different vertical and horizontal alignments, you can arrange the cell contents in 

different ways. 

   

Align to Upper Left Align to Bottom Right Align to Middle Center 
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4.5.4 Change Text Orientation (Rotate Text) 

Click the Orientation button on the Home tab, in the Alignment group, to rotate text up or down and 

write vertically or sideways. These options come in especially handy for labeling narrow columns: 

Rotate text and write vertically or sideways. 

 

4.5.5 Indent Text 

In Microsoft Excel, the Tab key does not indent text in a cell like it does, say, in Microsoft Word; it 

just moves the pointer to the next cell. To change the indentation of the cell contents, use the Indent 

icons that reside right underneath the Orientation button. 

To move text further to the right, click the Increase Indent icon. If you have gone too far right, click 

the Decrease Indent icon to move the text back to the left. 

 

4.5.6 Align Text using the Format Cells dialog 

In addition to the most used alignment options available on the ribbon, you can use the Format 

Cells dialog box (Right click the cell, and choose Format Cell…) for advance features 
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4.6 Formatting with Styles 

To apply several formats in one step, and to make sure that cells have consistent formatting, you can 

use a cell style. A cell style is a defined set of formatting characteristics, such as fonts and font sizes, 

number formats, cell borders, and cell shading. To prevent anyone from making changes to specific 

cells, you can also use a cell style that locks cells. 

 

Microsoft Office Excel has several built-in cell styles that you can apply or modify. You can also 

modify or duplicate a cell style to create your own, custom cell style. Cell styles are based on the 

document theme that is applied to the whole workbook. When you switch to another document 

theme, the cell styles are updated to match the new document theme. 

4.7 Background Image  

Image the plain black and white data with some graphs being pre-presented in a meeting to some 

client or other audience. An excel sheet is something similar and is pretty plain and simple. Just 

open the excel sheet on which you want to add the background image. If you want to create a new 

one, just open a new blank sheet. Click on Page Layout ➔ Background to add a background 

image. 
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4.8 Add a Watermark 

4.8.1 Create a watermark 

1. Select Insert ➔ Header & Footer. 

2. Tap on the header and on the Header & Footer tab on the ribbon, click Picture. 

3. Select one of the available options to insert your image. In the header, you’ll see & [Picture]. 

4. Tap anywhere outside the header to see the watermark. 

4.8.2 Format the Watermark picture 

1. Click the header in the spreadsheet. 

2. On the Header & Footer tab, click Format Picture. 

3. In the Format Picture dialog box, select Picture tab ➔ Color ➔ select an option. 

4.9 Using Template Files to Store Formatting 

A template file is a model that can serve as the basis for new worksheets. A template can include 

both data and formatting information. The advantages to using templates are standardization and 

protection. To create a template file, follow these steps: 

1. Open the workbook you want to use as a template. 

2. Choose Save As, and supply a file name. 

3. Choose Excel Template from the Save as type list, and click [Save] button.  
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5. Data Form  

5.1 Introduction 

A data form provides a convenient means to enter or display one complete row of information in a 

range or table without scrolling horizontally. You may find that using a data form can make data 

entry easier than moving from column to column when you have more columns of data than can be 

viewed on the screen. Use a data form when a simple form of text boxes that list the column 

headings as labels is sufficient and you don't need sophisticated or custom form features, such as a 

list box or spin button. 

Excel can automatically generate a built-in data form for your range or table. The data form 

displays all column headers as labels in a single dialog box. Each label has an adjacent blank text 

box in which you can enter data for each column, up to a maximum of 32 columns. In a data form, 

you can enter new rows, find rows by navigating, or update rows and delete rows. If a cell contains 

a formula, the formula result is displayed in the data form, but you cannot change the formula by 

using the data form. However, you cannot print a data form until you close the data form.  

5.2 Create a Data Form 

In the Excel Options, click the Customize Ribbon button on the left. To add the Data Form option, 

click the drop-down list where it says Choose Commands From, click on Commands Not in the 

Ribbon and select Form. Now click the Add button for adding the button to the toolbar. 

1. Add a column header to each column in the range or table. Excel uses these column headers to 

create labels for each field on the form. 

2. Select the range or table which you want to add the form, and then select Form. 
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5.3 Add new Record 

1. Click [New] in the data form windows.  

2. Type the information for the new record, and press [Enter] to add the record. 

3. When you finish adding records, click [Close] to add the new record and close the data form. 

 

5.4 Find a Record 

5.4.1 Find a Record by Navigating 

To move through records one at a time, use the scroll bar arrows in the dialog box. To move through 

10 records at a time, click the scroll bar between the arrows.  

To move to the next record in the range or list, click [Find Next]. To move to the previous record in 

the range or list, click [Find Prev].  

5.4.2 Find a Record by Entering Search Criteria 

To set search conditions, or comparison criteria, click [Criteria], then enter the criteria into the data 

form. To find records that match the criteria, click [Find Next] or [Find Prev]. To return to the data 

form without searching for records based on the criteria you specified, click [Form]. 

The following wildcard characters can be used as comparison criteria for filters, and when 

searching and replacing content. 

Use To Find 

? (question mark) Any single character 

For example, sm?th finds "smith" and "smyth" 

* (asterisk) Any number of characters 

For example, *east finds "Northeast" and "Southeast" 

~ (tilde) followed by ?, *, or ~ A question mark, asterisk, or tilde 

For example, fy91~? finds "fy91?" 
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5.5 Change a Record 

1. Find the row that you want to change. 

2. Change the data in the row. To move to the next field in the row, press [Tab]. To move to the 

previous field, press [Shift] + [Tab]. 

3. After you finish changing data, press [Enter] to update the row. Excel automatically moves to 

the next row.  

5.6 Delete a row 

1. In the data form, find the row that you want to delete. 

2. Click [Delete]. Excel prompts you to confirm the operation. You cannot undo a row deletion 

after you confirm it. 

5.7 Close a Data Form 

To close the data form and return to the worksheet, click [Close]. 
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6. Excel Table  

6.1 What is Excel Table? 

A table is a powerful feature to group your data together in Excel. When you create a table, you can 

manage and analyze the data in that table independently of data outside the table. For example, you 

can filter table columns, add a row for totals, apply table formatting. 

The advantages of an Excel table include all of the following: 

 Quick Styles: Add color, banded rows, and header styles with just one click to style your data. 

 Table Names: Give a table a name to make it easier to reference in other formulas.  

 Cleaner Formulas: Excel Formulas are much easier to read and write when working in tables. 

 Auto Expand: Add a new row or column to your data, and the Excel table automatically 

updates to include the new cells. 

 Filters & Subtotals: Automatically add filter buttons and subtotals that adapt as you filter your 

data. 

6.2 Create an Excel Table 

1. On a worksheet, select the range of cells that you want to include in the table. The cells can be 

empty or can contain data.  

2. On the Insert tab, in the Tables group, click Table. 

3. If the selected range contains data that you want to display as table headers, select the My 

table has headers check box. 

 

4. Table headers display default names if you do not select the My table has headers check box. 

You can change the default names by typing the text that you want.  
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6.3 Naming a Table 

Once you create a table, Excel will automatically give it a name. You can find out the table name by  

selecting the table. Click on the Design tab, and then you can find the table name on the left side of 

this menu. If you want to change the name, type in a new name for the table. (no spaces are allowed 

in table names.) 

 

6.4 Format Specific Style 

When you create a table with the Table command on the Insert tab, the table retains any formatting 

that it currently has, and the default Table Style is applied. If you want to apply a specific table style 

when creating an Excel Table: 

1. Select a cell in the list of data that you prepared. 

2. On the Ribbon, click the Home tab. 

3. In the Styles group, click Format as Table 

4. Click on the Style that you want to use 

5. In the Create Table dialog box, the range for your data should automatically appear, and the 

My table has headers option is checked. If necessary, you can adjust the range, and check box. 

6. Click [OK] to accept these settings. 
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6.5 Totals in an Excel Table 

6.5.1 Show Totals in a Table 

After you create an Excel table, it's easy to show the total for a column, or for multiple columns, 

using a built-in Table feature. 

1. Select any cell in the table 

2. Under the Table Design tab, select the Total Row check box in the Table Style Options group, 

3. A Total row will be added at the bottom of the table, and one or more column of numbers 

might show a total. 

 

6.5.2 Change and Add Totals 

In addition to the automatically created totals, you can select totals for other columns. 

1. Click in the Total cell for one of the columns. 

2. From the drop down list, select the function that you want to use in the current column. 

 



    Chapter 1 

Essential Excel Skill for Job Hunting @ Peter Lo 2023 44 

6.6 Remove Duplicate 
Microsoft has made it quicker to remove duplicate rows in Excel, all it takes now is two simple 

steps. The best part is that you don’t need to select any specific row before removing the duplicate 

rows, the build-in Remove Duplicate feature takes care of it. 

1. Sort the record in ascending order 

2. Select the table, and then select Design Tab, then select Remove Duplicates.  

 

3. Select the column for duplicate checking and press [OK] 

 
4. Duplicate row will be removed, and the number of row will be returned. 

 

6.7 AutoFormat 

Style galleries for tables, cells, and PivotTables provide a set of professional formats that can be 

applied quickly. You can choose from many predefined styles or create custom styles as needed. 

Styles replace AutoFormat as the simplest way to apply formatting to a range of cells. 
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6.8 Using Slicers as Filter 

When you need a quick, easy-to-use filter, but one that filters using only large categories, use a 

Slicer. Slicers are boxes that display on your worksheet. They contain buttons that display a list of 

unique contents for the column you want as a filter. Click one of the buttons and the list or Excel 

Table is filtered. 

1. In Design tab, select Insert Slicer from Tools group. 

2. Tick the column you like to create slicers.  

 

3. If you need to select multiple Slicers, hold the [Ctrl] key as you click a slicer. 
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7. Filtering 

7.1 Overview 

Filtering is a quick and easy way to find and work with a subset of data in a range. A filtered range 

displays only the rows that meet the criteria you specify for a column. Excel provides two 

commands for filtering ranges: AutoFilter and Advanced Filter. 

Unlike sorting, filtering does not rearrange a range. Filtering temporarily hides rows you do not 

want displayed. When Excel filters rows, you can edit, format, chart, and print your range subset 

without rearranging or moving it. 

7.2 Use AutoFilter for Simple Criteria and to Filter by Selection 

Using AutoFilter, you can create three types of filters: by a list values, by a format, or by criteria. 

Each of these filter types is mutually exclusive for each range of cells or column table. For example, 

you can filter by cell color or by a list of numbers, but not by both; you can filter by icon or by a 

custom filter, but not by both.  

7.2.1 Data Type Checking 

In your worksheet, the top row of each column should have a heading that describes the contents of 

the column, such as “Last Name” and “Age”. The data in each column should all be the same type. 

For instance, do not mix text in a column with numbers, or numbers in a column with dates. 

 

7.2.2 Activate the AutoFilter 

Activate the AutoFilter by select Data Tab, then Filter. The AutoFilter arrows now appear to the 

right of each column heading. If you select an entire column instead of a single cell before clicking 

the Filter command, an AutoFilter arrow will appear only on the selected column, not on all 

columns of the data. 
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7.2.3 Start Filtering Data 

Suppose your worksheet contains customer sales data. Each customer entry includes information 

about the customer's location, products they purchase, purchase dates, and revenues and profits 

from each purchase. Perhaps you want to view sales activity only for those customers located in the 

West region. Excel can help you do this.  

 

7.2.4 Apply Additional Filters 

If you want to focus on even more specific information, you can filter again on another column, and 

then again on another column, and so on. You can click the arrow next to any heading in any 

column to apply a filter.  

7.2.5 Turn Off Filtering 

How you remove filters depends on how many filters you have applied, and from how many 

columns you wish to remove filters. 

 To remove a filter from one column, click the AutoFilter arrow next to that column, and then 

click All. That command will display the rows hidden by that filter.  

 To turn off AutoFilter, click select Data tab, then click Filter again. 
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7.3 Custom Filter Example 

Excel enables you to perform more intricate types of filtering. Two particularly useful types are: 

 Top 10 Filter  

 Custom Filtering. 

When you apply a filter to a column, the only filters available for other columns are the values 

visible in the currently filtered range. Only the first 1000 unique entries in a list appear when you 

click the arrow 

7.3.1 Finding the Top 10 (or Bottom 10) in a Column 

You can use the Top 10 filter on columns of numbers or dates. With Top 10 you can find either the 

top items or the bottom items (the smallest or largest numbers or dates). And you're not limited to 

finding the top 10 items or the bottom 10 items. You can choose how many items you want to see: 

only 1 or as many as 500. You can use Top 10 to find the highest-priced or lowest-priced products, 

to identify employees with the most recent hire dates, or to see the top or bottom student grades. 

To use Top 10 on a column of data, click on a data cell in the column and then click the column's 

AutoFilter arrow. Select (Top 10…) near the top of the drop down list. The Top 10 AutoFilter 

dialog box opens. In the dialog box, select either Top or Bottom. Then select a number. Finally, 

select either Items or Percent.  

You can filter columns in any order you choose. The filters are applied progressively, in the order 

you apply them. Each filter limits the data to which you can apply the next filter. 

 

7.3.1.1 Filter for the Smallest or Largest Number 

1. Click the arrow  in the column that contains the numbers, and click (Top 10...).  

2. In the box on the left, click Top, or Bottom.  

3. In the box in the middle, enter a number.  

4. In the box on the right, click Items. 

7.3.1.2 Filter for the Top or Bottom Numbers by Percent 

1. Click the arrow  in the column that contains the numbers, and click (Top 10...).  

2. In the box on the left, click Top or Bottom.  

3. In the box in the middle, enter a number.  

4. In the box on the right, click Percent.  
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7.3.2 Using Custom Filters 

When you filter by choosing from the AutoFilter drop-down list, you hide everything except your 

single choice. If you want to see more than one selection in a column, you can create custom filters.  

To create a custom filter, click (Custom…) near the top of the drop down list. The Custom 

AutoFilter dialog box opens. You can now enter two filtering requirements for the column of data.  

 

7.3.2.1 Filter a Range for Rows that Contain Specific Text 

1. Click the arrow  in the column that contains the numbers, and click (Custom).  

2. In the box on the left, click equals, or does not equal, contains, or does not contain.  

3. In the box on the right, enter the text you want. If you need to find text values that share some 

characters but not others, use a wildcard character.  

4. To add another criteria, click And or Or, and repeat the previous step.  

7.3.2.2 Filter for Blank or Nonblank Cells 

Click the arrow  in the column that contains the numbers, then click (Blanks) or (NonBlanks). 

The Blanks and NonBlanks options are available only if the column you want to filter contains a 

blank cell. 

7.3.2.3 Filter for Numbers Greater than or Less than Another Number 

1. Click the arrow  in the column that contains the numbers, and click (Custom).  

2. In the box on the left, click is greater than, is less than, is greater than or equal to, or is less 

than or equal to.  

3. In the box on the right, enter a number.  

4. To add another criteria, click And or Or, and repeat the previous step.  

7.3.2.4 Filter for a Number Equal to or Not Equal to Another Number 

1. Click the arrow  in the column that contains the numbers, and click (Custom).  

2. In the box on the left, click equals, or does not equal.  

3. In the box on the right, enter a number.  

4. To add another criteria, click And or Or, and repeat the previous step.  
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7.3.2.5 Filter for the beginning or end of a text string 

1. Click the arrow  in the column that contains the numbers, and click (Custom).  

2. In the box on the left, click begins with, or does not begin with, or ends with, or does not 

end with.  

3. In the box on the right, enter the text you want. If you need to find text values that share some 

characters but not others, use a wildcard character.  

4. To add another criteria, click And or Or, and repeat the previous step.  

7.4 Use Advanced Filter for more Complex Criteria 

Excel's Advanced Filter is really helpful when it comes to finding data that meets two or more 

complex criteria such as extracting matches and differences between two columns, filtering rows 

that match items in another list, finding exact matches including uppercase and lowercase characters, 

and more. 

The Data ➔ Filter ➔ Advanced Filter lets you use complex criteria to filter a range, but it works 

differently from the AutoFilter command in several important ways. 

1. It displays the Advanced Filter dialog box instead of the Custom AutoFilter dialog box. 

2. You do not type the complex criteria in the Advanced Filter dialog box as you do in the 

Custom AutoFilter dialog box. Rather, you type the complex criteria in a criteria range on the 

worksheet and above the range you want to filter. Excel uses the separate criteria range in the 

Advanced Filter dialog box as the source for the complex criteria. 

3. Although you can filter a range in place, like the AutoFilter command, the Advanced Filter 

command does not display drop-down lists for the columns 

In order to use the Advanced Filter 

1. Insert at least three blank rows above the range that can be used as a criteria range. The criteria 

range must have column labels. Make sure there is at least one blank row between the criteria 

values and the range.  

2. In the rows below the column labels, type the criteria you want to match. 

3. Select the range, and then select Data ➔ Filter ➔ Advanced Filter 
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7.4.1 Using OR Criteria 

To find rows that meet multiple criteria for one column, type the criteria directly below each other 

in separate rows of the criteria range. For example: In order to find either Salesperson = "Davolio" 

OR Salesperson = "Buchanan" 

1. Type = "=Davolio" in cell B2 

2. Type = "= Buchanan" in cell B3 

3. Select Data ➔ Filter ➔ Advanced Filter, and define the List range (A6:C10), the Criteria 

range (B1:B3)  

4. The rows that contain either "Davolio" or "Buchanan" in the Salesperson column (A8:C10) is 

filtered. 

  

7.4.2 Using AND Criteria 

To find rows that meet multiple criteria in multiple columns, type all of the criteria in the same row 

of the criteria range. For example: In order to find Type = "Produce" AND Sales > 1000 

1. Type ="=Produce" in cell A2 

2. Type =”>1000” in cell C2 

3. Select Data ➔ Filter ➔ Advanced Filter, and define the List range (A6:C10), the criteria 

range (A1:C2)  

4. The rows that contain "Produce" in the Type column and a value greater than $1,000 in the 

Sales column (A9:C10) is filtered. 

  

  



    Chapter 1 

Essential Excel Skill for Job Hunting @ Peter Lo 2023 52 

7.4.3 Multiple Criteria in Multiple Columns where Any Criteria can be 

True 

To find rows that meet multiple criteria in multiple columns, where any criteria can be true, type the 

criteria in different rows of the criteria range. For example, in order to find Type = "Produce" OR 

Salesperson = "Davolio" 

1. Type ="=Produce" in cell A2 

2. Type ="=Davolio" in cell B3 

3. Select Data ➔ Filter ➔ Advanced Filter, and define the List range (A6:C10), the criteria 

range (A1:B3)  

4. The rows that contain "Produce" in the Type column or "Davolio" in the Salesperson column 

(A8:C10) is filtered. 

  

7.4.4 Multiple Sets of Criteria where Each Set Includes Criteria for 

Multiple Columns 

To find rows that meet multiple sets of criteria, where each set includes criteria for multiple 

columns, type each set of criteria in separate rows. For example, in order to find (Salesperson = 

"Davolio" AND Sales >3000) OR (Salesperson = "Buchanan" AND Sales > 1500)  

1. Type ="=Davolio" in cell B2 and =">3000" in cell C2 

2. Type ="=Buchanan" in cell B3 and =">1500" in cell C3 

3. Select Data ➔ Filter ➔ Advanced Filter, and define the List range (A6:C10), the criteria 

range (A1:C3)  

4. The rows that contain both "Davolio" in the Salesperson column and a value greater than 

$3,000 in the Sales column, or displays the rows that contain "Buchanan" in the Salesperson 

and a value greater than $1,500 in the Sales column (A9:C10) is filtered. 
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7.4.5 Multiple Sets of Criteria where Each Set Includes Criteria for One 

Column 

To find rows that meet multiple sets of criteria, where each set includes criteria for one column, 

include multiple columns with the same column heading. For example, in order to find (Sales > 

6000 AND Sales < 6500 ) OR (Sales < 500)  

1. Type =">6000 " in cell C2 and ="<6500" in cell D2 

2. Type ="<500" in cell C3  

3. Select Data ➔ Filter ➔ Advanced Filter, and define the List range (A6:C10), the criteria 

range (A1:D3)  

4. The rows that contain values between 5,000 and 8,000 and values less than 500 in the Sales 

column (A8:C10) is filtered. 

   

7.4.6 Criteria to Find Text Values that Share Some Characters but Not 

Others 

To find text values that share some characters but not others, do one or more of the following. For 

example, in order to find (Type begin with "ME" or the 2nd character is "u" 

1. Type ="Me" in cell A2 

2. Type ="=?u*" in cell B3  

3. Select Data ➔ Filter ➔ Advanced Filter, and define the List range (A6:C10), the criteria 

range (A1:C3)  

4. The rows with "Me" as the first characters in the Type column or rows with the second 

character equal to "u" in the Salesperson column (A7:C9) is filtered. 
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7.4.7 Extracting a Unique List 

You can use Excel Advanced Filter to quickly extract unique records from a data set. 

1. Suppose you have a dataset as shown below. Select the entire data set (including the headers). 

 

2. Select Data ➔ Sort & Filter ➔ Advanced, or press [Alt] + [A] + [Q]. This will open the 

Advanced Filter dialog box 

3. In the Advanced Filter dialog box, input the following information: 

• Select the “Copy to another location” option. This will allow you to specify the location 

where you can get the list of unique records. 

• Make sure the “List range” refers to the dataset from which you want to find unique 

records. Also, make sure headers in the data set are included. 

• Specify the “Copy To” address where you want to get the list of unique records. 

• Tick the “Copy Unique Records Only” checkbox. 

4. This will instantly give you a list of all the unique records. 
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8. Sorting 

Excel provides numerous ways to sort worksheet ranges. You can sort by columns or rows, in 

ascending or descending order, and with capitalization considered or ignored. You can even define 

custom sorting sequences so that, for example, your company’s division names always appear in a 

particular order, regardless of their alphabetic sequence. 

8.1 Default Sort Orders 

After sorting a list of Excel figures, are some of the numbers not in the order you expect? A 

common reason for this problem is that some numbers may be formatted and stored as text instead 

of as numbers. When you sort data that includes values formatted and stored as text and as numbers, 

Excel sorts the text values separately from the number values. For example, the sales value for 

Tennis is formatted as text, and there were no sales for Soccer. When you sort this data by the Sales 

column in ascending order, you will get the following result: 

  

In an ascending sort, Microsoft Excel uses the following order. In a descending sort, this sort order 

is reversed except for blank cells, which are always placed last. 

Numbers     Numbers are sorted from the smallest negative number to the largest 

positive number. 

Dates     Dates are sorted from the earliest date to the latest date. 

Alphanumeric sort   When you sort alphanumeric text, Excel sorts left to right, character by 

character. For example, if a cell contains the text "A100," Excel places the 

cell after a cell that contains the entry "A1" and before a cell that contains 

the entry "A11." 

Text and text that includes numbers are sorted in the following order: 

0 1 2 3 4 5 6 7 8 9 (space) ! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < 

= > A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 

Apostrophes (') and hyphens (-) are ignored, with one exception: If two 

text strings are the same except for a hyphen, the text with the hyphen is 

sorted last. 

Logical values In logical values, FALSE is placed before TRUE. 

Error values All error values are equal. 

Blanks     Blanks are always placed last. 
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8.2 Sorting on Column (by Row) 

You can sort on as many as three columns at once.  

1. Select a column of alphanumeric data in a range of cells, or make sure that the active cell is in 

a table column containing alphanumeric data.  

2. On the Data tab, in the Sort & Filter group, do one of the following: 

 To sort in ascending alphanumeric order, click  Sort A to Z. 

 To sort in descending alphanumeric order, click  Sort Z to A. 

3. Optionally, you can do a case-sensitive sort. 

 In the Sort dialog box, click Options.  

 In the Sort Options dialog box, select Case sensitive. 

 Click OK twice. 

4. To reapply a sort after you change the data, click a cell in the range or table, and then on the 

Data tab, in the Sort & Filter group, click Reapply. 

 

8.3 Sorting by Columns 

To sort by columns, follow these steps: 

1. Select a column of alphanumeric data in a range of cells, or make sure that the active cell is in 

a table column containing alphanumeric data.  

2. In the Sort dialog box, click Options.  

3. In the Sort Options dialog box, select Sort left to right. 

4. Click OK twice. 

5. Fill out the boxes and option buttons in the Sort dialog box, and click [OK]. 
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8.4 Sorting Months, Weekdays, or Custom Lists 

Excel normally sorts text in alphabetical order, but it can sort on the basis of any of its custom lists 

if you want it to. The program includes four custom lists by default  

 Sun, Mon, Tues, …  

 Sunday, Monday, Tuesday, …  

 Jan, Feb, Mar, …  

 January, February, March, …  

If you have a column consisting of these day or month labels, you can sort them in their proper 

chronological order. If you’ve created other custom lists, you can sort text fields in the order of 

those lists as well. 

 

 

To sort on the basis of a custom list, click Order in the Sort dialog box, and then select Custom 

List…. The four default custom lists will appear there, along with any others that you have created. 
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8.5 Sorting Cells that Contain Formulas 

You need to exercise caution when sorting cells that contain formulas with cell references. If you 

sort by row, references to other cells in the same row will be correct after the sort, but references to 

cells in other rows of the list will no longer be correct. 

Similarly, if you sort by column, references to other cells in the same columns will be correct after 

the sort, but references to cells in other columns will be broken. With either kind of sort, relative 

references to cells outside the list will be broken by the sort. 

To avoid the problems associated with sorting ranges containing formulas, observe the following 

rules: 

 In formulas that reference cells outside the sort range, use only absolute references. 

 When sorting by row, avoid formulas that reference cells in other rows. If you must use such 

formulas, reference cells by name, not by address. 

 When sorting by column, avoid formulas that reference cells in other columns. If you must use 

such formulas, reference cells by name, not by address. 
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9. Validating Data Entry 

Data validation is an Excel feature that you can use to define restrictions on what data can or should 

be entered in a cell. You can configure data validation to prevent users from entering data that is not 

valid. If you prefer, you can allow users to enter invalid data but warn them when they try to type it 

in the cell. You can also provide messages to define what input you expect for the cell, and 

instructions to help users correct any errors. When data is entered that doesn't meet your 

requirements, Excel displays a message with instructions you provide.  

 

9.1 Types of data you can validate 

Excel lets you designate the following types of valid data for a cell: 

Numbers: Specify that the entry in a cell must be a whole number or a decimal 

number. You can set a minimum or maximum, exclude a certain number or 

range, or use a formula to calculate whether a number is valid. 

Dates and Times: Set a minimum or maximum, exclude certain dates or times, or use a 

formula to calculate whether a date or time is valid 

Length: Limit how many characters can be typed in a cell, or require a minimum 

number of characters. 

List of Values: Make a list of the choices for a cell — such as small, medium, large — and 

allow only those values in the cell. You can display a dropdown arrow 

when a user clicks the cell to make it easy to pick from your list. 
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9.2 Types of messages you can display 

For each cell you validate, you can display two different messages: one that appears before the user 

enters data, and one that appears after the user tries to enter data that doesn't meet your 

requirements. If users have the Office Assistant turned on, the Assistant displays the messages. 

  

9.2.1 Input Message 

This type of message appears as soon as a user clicks the validated cell. You can use it to provide 

instructions about the type of data you want entered in the cell. 

9.2.2 Error Alert 

This type of message appears only when the user types data that isn't valid and presses [Enter]. You 

can choose from three types of error messages. If you don't specify any messages, Excel flags 

whether the data a user enters is valid so that you can check for it later, but does not notify the user 

when an entry is invalid 

Information Message: This message does not prevent entry of invalid data. In addition to the 

text you provide, it has an information icon, an OK button, which 

enters the invalid data in the cell, and a Cancel button, which restores 

the previous value to the cell. 

Warning Message: This message does not prevent entry of invalid data. It has the text you 

provide, a warning icon, and three buttons: Yes enters the invalid data 

in the cell, No returns to the cell for further editing, and Cancel restores 

the previous value to the cell. 

Stop Message: This message won't allow invalid data to be entered. It has text you 

provide, a stop icon, and two buttons: Retry returns to the cell for 

further editing, and Cancel restores the previous value to the cell. Note 

that this message isn't intended as a security measure: although users 

can't enter invalid data by typing and pressing [Enter], they can 

circumvent the validation by copying and pasting or filling data in the 

cell.  
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9.3 Setting up Data Validation 

Once you know what validation you want to use on a worksheet, you can use select the Data tab, 

and then select Data Validation to set it up. Here's a general overview of the process: 

1. Set up your worksheet – Start by entering the data and formulas on your worksheet. If you're 

using a list of valid choices, enter and name your list.  

2. Define the settings for a cell – Beginning with the first cell you want to validate, use the Data 

Validation dialog box to designate the type of validation you want, an input message if you 

want one, and an error message if you want one.  

3. Set up validation for other cells – You can often save time by copying the validation settings 

from the first cell to other cells and then modifying the settings.  

4. Test your validation rules – Try entering both valid and invalid data in the cells to make sure 

your settings are working as you intended and your messages are appearing when you expect. 

Use the Validation command to make any changes to the settings. If you make changes to the 

validation in one cell, you can automatically apply your changes to all other cells that have the 

same settings.  

5. Set up your lists of valid choices – If you used a list of valid choices and don't want users to 

be able to find and change the list, you can put the list on another worksheet, set up the 

validation, hide the worksheet that contains the list, and then help protect the workbook with a 

password. The workbook password will help guard the worksheet that contains the list from 

others.  

6. Apply protection, if desired – If you're planning to protect the worksheet or workbook, do 

that after you're finished setting up validation. Make sure you unlock any validated cells before 

protecting the worksheet, otherwise users won't be able to type in the cells.  

7. Share the workbook, if desired – If you're planning to share the workbook, do that after 

you're finished setting up validation and protection. After you share a workbook, you won't be 

able to change the validation settings unless you stop sharing, but Excel will continue to 

validate the cells you've designated while the workbook is shared.  

8. Check the results for invalid data – After users enter data in the worksheet, you can check 

for invalid data. 

9.4 Entering data in validated cells 

Here's what the process of entering data is like for users. You can use input and error messages to 

provide the instructions users need to understand how you've set up the worksheet to ensure correct 

data.  

9.4.1 Viewing your input message    

When a user clicks a validated cell or uses the arrow keys to move into the cell, your input message 

appears either in an Assistant balloon or a separate message box. If you provided a dropdown list 

for the cell, the dropdown arrow appears to the right of the cell. 
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9.4.2 Typing data    

As the user types data or clicks the dropdown arrow to select a value from your list, the input 

message stays on the screen (the dropdown list may cover part of your message). 

9.4.3 Entering Valid Data    

If the user types valid data and presses [Enter], the data is entered in the cell and nothing special 

happens. 

9.4.4 Entering Invalid Data 

If the user types data that doesn't meet your criteria, and you specified an error message for invalid 

data, your message appears either in an Assistant balloon or a separate message window. The user 

can then read the message and decide what to do.  

 For an information message, the user can click [OK] to enter the invalid data, or click [Cancel] 

to start over.  

 For a warning message, the user can click [Yes] to enter the invalid data, [No] to edit the cell 

some more, or [Cancel] to start over.  

 For a stop message, the user can't enter the invalid data, and can either click [Retry] to edit the 

cell or [Cancel] to start over.  

If you don't provide messages, entering data in validated cells is the same for users as regular Excel 

data entry. However, Excel does flag any cells that have invalid entries so you can easily find those 

entries. 

9.5 Checking a Worksheet for Invalid Entries 

When you receive worksheets back from users who may have entered invalid data, you can have 

Excel display red circles around any data that didn't meet your criteria, making it easy to scan the 

worksheet for errors. Use the [Circle Invalid Data] and [Clear Validation Circles] buttons on the 

Auditing toolbar for this purpose. When you correct the data within the cell, the circle disappears. 
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10. Conditional Formats 

10.1 Create Conational Formatting Rules 

Use conditional formatting to help you visually explore and analyze data, detect critical issues, and 

identify patterns and trends. Conditional formatting makes it easy to highlight interesting cells or 

ranges of cells, emphasize unusual values, and visualize data by using data bars, color scales, and 

icon sets that correspond to specific variations in the data. A conditional format changes the 

appearance of cells on the basis of conditions that you specify. If the conditions are true, the cell 

range is formatted; if the conditions are false, the cell range is not formatted.  

There are two ways to create conditional formatting rules: 

 Build-in Rules: There are many built-in conditions, you can select them under Conditional 

Formatting in Home tab. 

 Custom Rules: Select Conditional Formatting ➔ New Rules to create your own. 

10.2 Edit Conditional Formatting Rule 

1. You can edit the entire rule from the conditional formatting rules manager by accessing 

Conditional Formatting ➔ Manage Rules … in the Home tab. 

 
2. “Show formatting rules for:” is set to “Current Selection” by default. You can change to 

“This Worksheet” if you want to list all rules within worksheet. Then find out the rule that you 

want to change and press the [Edit Rule…] button. 
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3. You can change the condition and format in this “Edit Formatting Rules” dialog box. 

 

10.3 Delete Conditional Formatting Rule 

10.3.1 Delete All Rules  

Removing all conditional formatting rules in a sheet is very straightforward, select Conditional 

Formatting ➔ Clear Rules ➔ Clear Rules from Entire Sheet, then all rules will be removed. 

 

10.3.2 Delete Rules from Selected Cell 

If you only want to remove the conditional format rules from the select cell, press Conditional 

Formatting ➔ Clear Rules ➔ Clear Rules from Selected Cells. Then the rule for the selected 

cell will be removed.  
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10.3.3 Delete Rules by Conational Formatting Rules Manager 

You can also delete the whole rule that apply to multiple cells from Conditional Formatting ➔ 

Manage Rules …. Then select the rule and press [Delete Rule] in Conational Formatting Rules 

Manager. Remember to press [OK] to confirm the change. 

 

10.4 Highlight Cells using Comparison Operators 

To more easily find specific cells within a range of cells, you can format those specific cells based 

on a comparison operator. For example, in an inventory worksheet sorted by categories, you can 

highlight the products with fewer than 10 items on hand in yellow. Or, in a retail store summary 

worksheet, you can identify all stores with profits greater than 10%, sales volumes less than 

$100,000, and region equal to "SouthEast". 

1. Select the cells, and click Conditional Formatting ➔ Highlight Cells Rules, then select the 

comparison operators (Greater Than…, Less Than…, Between… , or Equal To…). 

 

2. Input the value in the dialog box. Strong recommend selecting numeric value only when using 

comparison operator to prevent invalid output. 
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10.5 Highlight Cells that Contain Specified Text 

1. Select the table and click Conditional Formatting ➔ Highlight Cells Rules ➔ Text that 

Contains…. 

 

2. Type the specified text in the dialog box, and press [OK] button. 

 

10.6 Using Data Bars for High / Low Overview 

A data bar helps you see the value of a cell relative to other cells. The length of the data bar 

represents the value in the cell. A longer bar represents a higher value, and a shorter bar represents a 

lower value. Data bars are useful in spotting higher and lower numbers, especially with large 

amounts of data, such as top selling and bottom selling toys in a holiday sales report. 
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10.7 Create Heat Map by using Color Scale  

Color scales are visual guides that help you understand data distribution and variation. A two-color / 

three-color scale helps you compare a range of cells by using a gradation of two / three colors. The 

shade of the color represents higher, (middle), or lower values.  

 One color is assigned to the cell with the lowest value 

 Another color is assigned to the cell with the highest value. 

 All cells and values in between are assigned colors that are a blend of those 2 colors. 

For example, in a green, yellow, and red three-color scale, you can specify that higher value cells 

have a green color, middle value cells have a yellow color, and lower value cells have a red color. 

 

10.8 Using Icon Set for Category 

Use an icon set to annotate and classify data into three to five categories separated by a threshold 

value. Each icon represents a range of values. For example, in the 3 Arrows icon set, the green up 

arrow represents higher values, the yellow sideways arrow represents middle values, and the red 

down arrow represents lower values. 
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10.9 Highlight Cells by Ranking 

10.9.1 Highlight Cells by Top or Bottom Rules 

You can find the highest and lowest values in a range of cells based on a cutoff value that you 

specify. For example, you can find the top 5 selling products in a regional report, the bottom 15% 

products in a customer survey, or the top 25 salaries in a department personnel analysis. 

Select Conditional Formatting ➔ Top/Bottom Rules, then select the condition (Top 10 items…, 

Bottom 10 items…, Top 10 %…, Bottom 10 %…), you want to apply: 
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10.9.2 Highlight Cell by Above or Below Average 

You can find values above or below an average or standard deviation in a range of cells. For 

example, you can find the above average performers in an annual performance review or you can 

locate manufactured materials that fall below two standard deviations in a quality rating.  
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10.10 Highlight Duplicate Value 

1. Select the table column that you want to check for duplicate values. For example, you could 

select the Product ID column to look for products that have the same ID value. Note: You can 

highlight more than one column, but if you do, Excel highlights identical values that appear in 

more than one column. For example, if the same number appears in the Product ID column and 

in the Price column, Excel highlights it even though it isn't really a duplicate. 

2. Choose Conditional Formatting➔Highlight Cells Rules➔Duplicate Values. 

 

3. When the Duplicate Values dialog box appears, choose the type of formatting you'd like to use 

to highlight repeated values. People often choose to change the background color. 

 

4. Click [OK]. Excel changes the background color of all values that appear more than once in 

the selected column. Conditional formatting keeps working even after you've applied it. So, if 

you add a new record that duplicates the value of an existing record in the column you're 

checking, Excel immediately highlights it. It's like having a duplicate value cop around at all 

times. 
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10.11 Highlight Cells by Determine another Cell 

If your conditional formatting needs are more complex, you can use a logical formula to specify the 

formatting criteria. For example, you may want to compare values to a result returned by a function 

or evaluate data in cells outside the selected range.  

1. For example, we would like to highlight the Item Code if the quantity is zero. First, select 

Conditional Formatting ➔ New Rule…  

 

2. Select “Use a formula to determine which cells to format” in the New Formatting Rule 

dialog box, then input the format and pick the formatting. 

 

3. The cell will be highlighted after you press [OK] button. 
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10.12 Find Cells that have Conditional Formats 

If your worksheet has one or more cells with a conditional format, you can quickly locate them so 

that you can copy, change, or delete the conditional formats. You can use the Go To Special 

command to either find only cells with a specific conditional format or find all cells with 

conditional formats. 

1. Select Find & Replace ➔ Go To Special in Home tab. 

 

2. Select “Conditional formats” in the “Go To Special” dialog box. 

 

3. The cell with the conditional format will be selected 
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11. Pages Setup and Printing  

11.1 Sample Printing 

Before you print anything in Excel, remember that there are many options available for an optimal 

print experience. Some formatting, such as colored text or cell shading, may look good on the 

screen but not look how you expect when it prints on a black-and-white printer. You may also want 

to print a worksheet with gridlines displayed so that the data, rows, and columns stand out better. 

11.1.1 Print One or Several Worksheets 

Select the worksheets that you want to print. Click File➔ Print, or press [Ctrl] + [P]. Click the 

[Print] button or adjust Settings before you click the [Print] button. 

 

11.1.2 Print All or Part of a Worksheet 

Select the range of data that you want to print in the worksheet, then click File ➔ Print. Under 

Settings, click the arrow next to Print Active Sheets and select the appropriate option before you 

click the [Print] button. 
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11.1.3 Print an Excel table 

Select the table you want to print in the worksheet, then click File ➔ Print. Under Settings, click 

the arrow next to Print Active Sheets and select Print Selected Table before you click the [Print] 

button. 

 

11.2 Setting the Scaling Ratio  

Using the Scaling setting on the Page tab of the Page Setup dialog box, you can override the 

default size of your printouts in one of two ways: by specifying a scaling factor (10% - 400%) or by 

fitting the report to a specified number of pages. Excel always scales in both the horizontal and 

vertical dimensions.  
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11.3 Creating Header and Footer 

On the Header/Footer tab of the Page Setup dialog box, you can provide essential information about 

your printout (such as file name, creation date, page number, and author’s name) by including a 

header (printed at the top of each page) or footer (printed at the bottom of each page). 

 

11.3.1 Creating Custom Headers and Footers 

If you don’t find what you need in the list of predefined headers and footers, you can create your 

own or modify one of Excel’s. If you create custom headers or footers for the current workbook, 

Excel adds them to these drop-down lists. Click the [Custom Header…] button to open the 

Header dialog box, or the [Custom Footer…] button to open the footer dialog box. 
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11.3.2 Adding Pictures to Headers and Footers 

You can add pictures to custom headers and footers using the [Insert Picture] and [Format Picture] 

buttons. When you insert the picture, Excel displays &[Picture] in the section box of the Header or 

Footer dialog box. (Unlike other header and footer codes, you can’t just type in this code). After you 

insert the picture, click the [Format Picture] button to specify the size, brightness, and contrast of 

the picture and to rotate, scale, or crop the picture.  

11.4 Page Break 

11.4.1 Adjusting Page Breaks 

Excel makes it easy to adjust the positions of page breaks. You can do this by selecting View tab, 

and then Page Break Preview. You can move page breaks by dragging them with the mouse. You 

can even edit your worksheet while in Page Break Preview mode.  

11.4.2 Inserting and Removing Manual Page Breaks 

To add a page break, select any cell of the row directly beneath or in the column directly to the right 

of where you want the break to occur, and then choose Layout tab, Breaks group, Insert Page 

Break. If you select a cell where data appears both below and to the right, Excel applies page 

breaks both horizontally and vertically. To remove a break, position your mouse in the row below a 

horizontal break, or in the column to the right of a vertical break, and then choose Layout tab, 

Breaks group, Remove Page Break.  

11.5 Printing 

11.5.1 Printing Gridlines 

By default, Excel does not print gridlines, regardless of whether you have them displayed on your 

worksheet. If you want to print gridlines, select the Gridlines check box on the Sheet tab of the 

Page Setup dialog box. 
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11.5.2 Printing Comments 

To make sure the comments in your worksheet are included with your printout, select one of the 

Comments options on the Sheet tab of the Page Setup dialog box.  

 If you select At end of sheet from the drop-down list, Excel adds a page to the end of the 

printout and prints all your notes together, starting on that new page.  

 If you select As displayed on Sheet, Excel prints the comments where they are located on a 

worksheet 

11.5.3 Printing Drafts 

If your printer offers a draft-quality mode, you can obtain a quicker, though less attractive, printout 

by selecting the Draft Quality option on the Sheet tab of the Page Setup dialog box. This option 

has no effect if your printer has no draft-quality mode and is most useful for dot matrix or other 

slow printers, or if your worksheet contains a lot of graphics. 

11.5.4 Printing Row and Column Headings 

If you select the Row and column headings option on the Sheet tab of the Page Setup dialog box, 

Excel prints row letters to the left of and column numbers on top of worksheet data. This option is 

handy when you’re using printouts to document the structure of a worksheet.  

11.5.5 Setting the Printing Order of Large Print Ranges 

When you print a large report, Excel breaks the report into page-size sections based on the current 

margin and page-size settings. If the print range is both too wide and too deep to fit on a single page, 

Excel normally works in Down, then over order. If you prefer to have Excel print each horizontal 

chunk before moving down to the next vertical chunk, select the Over, then down option on the 

Sheet tab of the Page Setup dialog box. 

11.5.6 Print Titles 

When Excel breaks up a large report into pages, the column and row labels might appear only on 

the first page of the printout. You can use the Sheet tab of the Page Setup dialog box to force Excel 

to print the contents of one or more columns, one or more rows, or a combination of columns and 

rows on every page of a report.  

If the portion of the spreadsheet you want to select is not visible, click the button on the right side of 

the Rows to repeat at top box. The dialog box collapses to give you more room; to redisplay the 

full dialog box, click the button on the right side of the box. Click the Columns to repeat at left 

box, and then select the column. 

 


